summaryrefslogtreecommitdiff
path: root/net-firewall
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/Manifest.gzbin4233 -> 4234 bytes
-rw-r--r--net-firewall/shorewall/Manifest2
-rw-r--r--net-firewall/shorewall/shorewall-5.2.8-r1.ebuild52
3 files changed, 24 insertions, 30 deletions
diff --git a/net-firewall/Manifest.gz b/net-firewall/Manifest.gz
index 97823f2bf85e..ed4a91dd8c47 100644
--- a/net-firewall/Manifest.gz
+++ b/net-firewall/Manifest.gz
Binary files differ
diff --git a/net-firewall/shorewall/Manifest b/net-firewall/shorewall/Manifest
index 6aed3a7aa50b..9389517b02c0 100644
--- a/net-firewall/shorewall/Manifest
+++ b/net-firewall/shorewall/Manifest
@@ -22,5 +22,5 @@ DIST shorewall-init-5.2.8.tar.bz2 42589 BLAKE2B 74e265ed9d938b6130800f548f5f4765
DIST shorewall-lite-5.2.8.tar.bz2 47250 BLAKE2B 2fff00d7a6248a3db0aa5d6b3ed041b06bdfa35b71195088659afd4036cf61c6bc2f3de739803d4e26e56785aa90c87ec6a2120239183351fae7a54065f1a629 SHA512 d72f260b095f1dfb2b0a0c967ae80bfd7f5f3469a08eb446c0b3e1b1e662cb500510b75f2979a00a9ef57b16e6a23a95483c34e2a5c5d2d090bc1e071ea87292
DIST shorewall6-5.2.8.tar.bz2 203102 BLAKE2B d9117d42cd25e18aa1104ec3f4498227eedcce5c3531623e2e4d6ec27ba5221f98e1ae2e596ac90d7415cd366b2dbfdd024adaaef0c1c2756900188bde105903 SHA512 7044efe84b2c585fcd0bfb661666c71cea140157f22ba7d4881006e24d785eb0091c071c825fa5948bc1383e7fd4617cc8f3d4e68865cf472ddea3811bf1833d
DIST shorewall6-lite-5.2.8.tar.bz2 47178 BLAKE2B 47026c3fdab7564c8e48b653a4c67db99fe5ff07de723169f65185aea563691806164a637a38c419d19619cf1380462fa7287b0993d9389dd311393bac911602 SHA512 a80ffc7baf7800e024e41a0f9736543b15d10f2d403540e48e8a2cd2ba0196ce04ff01ac98fc03852c7d268bb4954714dd428375e768b80aa4792683b8775935
-EBUILD shorewall-5.2.8-r1.ebuild 16952 BLAKE2B a6c8ae6c86e82c18d733ce065a9a2761a3678713811f4dc1a0e0b15156f10b73b9bcd4d521546b90b5b444aff6f7242e4cadc7093365b0d264a5ec59b15e8f99 SHA512 d7cd074407a99e0143f9dcc25f690ecbf8157664b8e4a9c409d047daee51e94d838dcd33f10d7982dc8022eefa8f9b8937a08596e49aea021b641301249df664
+EBUILD shorewall-5.2.8-r1.ebuild 16847 BLAKE2B 4f290631f18142f20166238c016281abae8a7ea9d4ea39269c176e14537a5ed1f28d74f9ad6e8d1e2c6a9e41c310a11c07f65823f4ec63e271364b5c3c8b1e93 SHA512 11be86a2824e21d8fb108ab1ef8bdbf11662a8937f2541caaa114387cdf9cdf5b874100da31f6c17cad72fdf5367042a5ff4b235bd3e4920c2429e66de93ba3d
MISC metadata.xml 2143 BLAKE2B 6924e8496c8bf1e0410a94bfae2cd85ca9ecc9b4d8e51a0d0deffee205abd2e8689de8fb3c57cf640bbc5fe8da9e54a2de6e8d9a7068f3e72e07c1f6462339f6 SHA512 8cb38dce4a1ffc5b07242d3256f2c7b442caba4ef21bdfe98bc847cc603d21708fab025f38d276969cabd9ace1ff7367dad06ef7daaec09cb39a131aef898ecf
diff --git a/net-firewall/shorewall/shorewall-5.2.8-r1.ebuild b/net-firewall/shorewall/shorewall-5.2.8-r1.ebuild
index a6be3bc94a36..2d8268652faa 100644
--- a/net-firewall/shorewall/shorewall-5.2.8-r1.ebuild
+++ b/net-firewall/shorewall/shorewall-5.2.8-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit linux-info prefix systemd
+inherit eapi9-ver linux-info prefix systemd
DESCRIPTION='A high-level tool for configuring Netfilter'
HOMEPAGE="https://shorewall.org/"
@@ -426,39 +426,33 @@ pkg_postinst() {
fi
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ! ver_test ${v} -ge ${MY_MAJOR_RELEASE_NUMBER}; then
- # This is an upgrade
+ if ver_replacing -lt ${MY_MAJOR_RELEASE_NUMBER}; then
+ # This is an upgrade
- elog "You are upgrading from a previous major version. It is highly recommended that you read"
- elog ""
- elog " - /usr/share/doc/shorewall*/releasenotes.tx*"
- elog " - https://shorewall.org/Shorewall-5.html#idm214"
-
- if use ipv4; then
- elog ""
- elog "You can auto-migrate your configuration using"
- elog ""
- elog " # shorewall update -A"
-
- if use ipv6; then
- elog " # shorewall6 update -A"
- fi
+ elog "You are upgrading from a previous major version. It is highly recommended that you read"
+ elog ""
+ elog " - /usr/share/doc/shorewall*/releasenotes.tx*"
+ elog " - https://shorewall.org/Shorewall-5.html#idm214"
- elog ""
- elog "*after* you have merged the changed files using one of the configuration"
- elog "files update tools of your choice (dispatch-conf, etc-update...)."
+ if use ipv4; then
+ elog ""
+ elog "You can auto-migrate your configuration using"
+ elog ""
+ elog " # shorewall update -A"
- elog ""
- elog "But if you are not familiar with the \"shorewall[6] update\" command,"
- elog "please read the shorewall[6] man page first."
+ if use ipv6; then
+ elog " # shorewall6 update -A"
fi
- # Show this elog only once
- break
+ elog ""
+ elog "*after* you have merged the changed files using one of the configuration"
+ elog "files update tools of your choice (dispatch-conf, etc-update...)."
+
+ elog ""
+ elog "But if you are not familiar with the \"shorewall[6] update\" command,"
+ elog "please read the shorewall[6] man page first."
fi
- done
+ fi
if ! use init; then
elog ""