summaryrefslogtreecommitdiff
path: root/net-fs/nfs4-acl-tools/nfs4-acl-tools-0.4.3_rc1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/nfs4-acl-tools/nfs4-acl-tools-0.4.3_rc1.ebuild')
-rw-r--r--net-fs/nfs4-acl-tools/nfs4-acl-tools-0.4.3_rc1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-fs/nfs4-acl-tools/nfs4-acl-tools-0.4.3_rc1.ebuild b/net-fs/nfs4-acl-tools/nfs4-acl-tools-0.4.3_rc1.ebuild
new file mode 100644
index 000000000000..01732f05fadc
--- /dev/null
+++ b/net-fs/nfs4-acl-tools/nfs4-acl-tools-0.4.3_rc1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Commandline and GUI tools that deal directly with NFSv4 ACLs"
+HOMEPAGE="https://git.linux-nfs.org/?p=steved/nfs4-acl-tools.git;a=summary"
+if [[ ${PV} != *_rc* ]] ; then
+ SRC_URI="
+ https://linux-nfs.org/~steved/${PN}/${P}.tar.gz
+ "
+ # KEYWORDS="~amd64 ~x86"
+else
+ SRC_URI="
+ https://git.linux-nfs.org/?p=steved/nfs4-acl-tools.git;a=snapshot;h=refs/tags/${P/_/-};sf=tgz
+ -> ${P}.tar.gz
+ "
+ S="${WORKDIR}/${PN}-${P/_/-}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# TODO only for 0.4.3_rc1
+# - it has minimal changes compared to 0.4.2
+# - no new release since 2022-11-22
+# - so we might as well keyword this as well
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="test"
+
+RDEPEND="sys-apps/attr"
+DEPEND="
+ ${RDEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.7-libtool.patch" # bug #731162
+ "${FILESDIR}/${PN}-0.3.5-jobserver-unavailable.patch"
+ "${FILESDIR}/${PN}-0.4.2-libattr.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}