summaryrefslogtreecommitdiff
path: root/net-im/kadu/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/kadu/files')
-rw-r--r--net-im/kadu/files/kadu-4.3-do-not-force-ccache.patch17
-rw-r--r--net-im/kadu/files/kadu-4.3-fix-plugins-rpath.patch12
2 files changed, 29 insertions, 0 deletions
diff --git a/net-im/kadu/files/kadu-4.3-do-not-force-ccache.patch b/net-im/kadu/files/kadu-4.3-do-not-force-ccache.patch
new file mode 100644
index 000000000000..2511f3c42b99
--- /dev/null
+++ b/net-im/kadu/files/kadu-4.3-do-not-force-ccache.patch
@@ -0,0 +1,17 @@
+diff -ruN kadu-4.3/CMakeLists.txt my/CMakeLists.txt
+--- kadu-4.3/CMakeLists.txt 2017-01-24 22:36:21.000000000 +0100
++++ my/CMakeLists.txt 2017-11-03 03:00:07.005162047 +0100
+@@ -75,13 +75,6 @@
+ endif ()
+ endif ()
+
+-## CCache is cool stuff to improve compilation time
+-find_program (CCACHE_FOUND ccache)
+-if (CCACHE_FOUND)
+- set_property (GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
+- set_property (GLOBAL PROPERTY RULE_LAUNCH_LINK ccache)
+-endif (CCACHE_FOUND)
+-
+ # Look above, DEBUG_ENABLED is always enabled in Debug configuration.
+ # Enable it in all configurations when ENABLE_DEVELOPER_BUILD is on.
+ if (ENABLE_DEVELOPER_BUILD)
diff --git a/net-im/kadu/files/kadu-4.3-fix-plugins-rpath.patch b/net-im/kadu/files/kadu-4.3-fix-plugins-rpath.patch
new file mode 100644
index 000000000000..bb171af5f41b
--- /dev/null
+++ b/net-im/kadu/files/kadu-4.3-fix-plugins-rpath.patch
@@ -0,0 +1,12 @@
+diff -ruN kadu-4.3/cmake/KaduMacros.cmake my/cmake/KaduMacros.cmake
+--- kadu-4.3/cmake/KaduMacros.cmake 2017-01-24 22:36:21.000000000 +0100
++++ my/cmake/KaduMacros.cmake 2017-11-03 03:24:17.827054622 +0100
+@@ -221,7 +221,7 @@
+
+ if (NOT WIN32)
+ set_target_properties (${KADU_PLUGIN_NAME} PROPERTIES
+- INSTALL_RPATH "${KADU_INSTALL_LIB_DIR}/kadu"
++ INSTALL_RPATH "${KADU_INSTALL_PREFIX}/${KADU_INSTALL_LIB_DIR}/kadu"
+ BUILD_WITH_INSTALL_RPATH TRUE
+ )
+ endif ()