summaryrefslogtreecommitdiff
path: root/net-im/poezio
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/poezio')
-rw-r--r--net-im/poezio/Manifest4
-rw-r--r--net-im/poezio/poezio-0.15.1.ebuild77
-rw-r--r--net-im/poezio/poezio-9999.ebuild6
3 files changed, 83 insertions, 4 deletions
diff --git a/net-im/poezio/Manifest b/net-im/poezio/Manifest
index ceba9996c34c..427d453931e6 100644
--- a/net-im/poezio/Manifest
+++ b/net-im/poezio/Manifest
@@ -1,5 +1,7 @@
AUX Do-not-install-man-pages-and-files-in-usr-share-poez.patch 1030 BLAKE2B 5ce807a6a3346a980f6fc5aa2da1d5df6f5c3cc1ea5a2743f39a64f81830387e8388cbf0791b1f21de60136f6b53cb072917b86c365c3c01460c06a4814abc0b SHA512 9b878fae63f108b54726805aa123ce6a361a67a44a02a8bdf3af3ef22e37a6770b4827ec9d83f507d3973b1c8df741cc956fba1d06e6c14a125f54c0b2028b6a
DIST poezio-0.14.tar.gz 662379 BLAKE2B 467741d82945c084c79811d41ff85358ad236d0dcefca7e6f1f8ed5d78aa127f800d2370d624ebaf9e2eb20e1038f280c2e874694ea2b86965fe329b82c4b7d8 SHA512 6e68954a918c645592e2d2f8a265e2f2445a39e256c0525a5517e758a90cc404e066cc08d67ad0f8a3c7d6f3efd61f13a776737d110dd23df7a5f7fab54fc6b5
+DIST poezio-0.15.1.tar.gz 3406541 BLAKE2B ecff8f168fe29814e30769cea8bda083d5b46571b72d4d8bf797a801f8b76ec02fe84336c56842e901b6b97e29885bfff3a4359f057587bbd83ce4a82e4b0ec4 SHA512 6baff764fe5775108f3a0657f044ff86ddac6c9f22b64382c8dbdd7a273baed5084fc4d76e236f0419deeba5d50198c860ce1830ceb8b61fe4b5e918f7180516
EBUILD poezio-0.14.ebuild 1705 BLAKE2B d0dfd238e1cab05cc0a599a9b8199ed3cff78c4aaa7f37ce8edcfda1a62e6477e896ec87e6285ac18f000fa061e8574ffe5c5faf42dcaf181bf895db131546ae SHA512 49cb562d7a1fb5c64e94af7407b672babe7d9effdbb339548da5ea49789db9c1dcda16062f4d4b0c481135266d31d158066630d2394771f09663d48c064ba668
-EBUILD poezio-9999.ebuild 1706 BLAKE2B eedab7bce9234c958de958c7e0f61140cb2f55d563043963be1730e808589a6d2c26debe91f233e13b7cd6baea3c87b207563dc3b5bedc9b14f67f10a86e4e95 SHA512 a905288979118317d672b6a55544e3a39c5dec6d34b20031c58c54c979a791a00856927bcfe16b16d726a0a259334417cb08c709b55cff504b1c42dd2bfca9bb
+EBUILD poezio-0.15.1.ebuild 1708 BLAKE2B 7494b5c294a5ae3d954d320fc3ebf753a90b725b4ceb7f97eef77e030bf4430a172fda83a6f34beae8a672185e12a234a5d55222a968ea55c948ee4e4d4d0963 SHA512 6261bf75e57358dd7707e38a0f30751eb8be92b8e8b47e4466cb4e9e555b7ed82740f8937a3fb52ea888b20d469261e9b5ffbb3efe36d5c2d2a7513df0c6d4f0
+EBUILD poezio-9999.ebuild 1708 BLAKE2B 7494b5c294a5ae3d954d320fc3ebf753a90b725b4ceb7f97eef77e030bf4430a172fda83a6f34beae8a672185e12a234a5d55222a968ea55c948ee4e4d4d0963 SHA512 6261bf75e57358dd7707e38a0f30751eb8be92b8e8b47e4466cb4e9e555b7ed82740f8937a3fb52ea888b20d469261e9b5ffbb3efe36d5c2d2a7513df0c6d4f0
MISC metadata.xml 371 BLAKE2B 518d241e739146cd8d8b75ddc2dbc139923c849fbbba087fd7790af48edc300be8a3d27fc130dd68f381bcc2354c6bafd90cedc1ea06549ea8e428d1b4c09bd8 SHA512 c09a864b2767b33ea2666b0714375cc507d9c29666deae2307642a97c36513831085bdc51b7732530afa162aec648e8e0c4b7ebcd334fecca5279084a6f7ad60
diff --git a/net-im/poezio/poezio-0.15.1.ebuild b/net-im/poezio/poezio-0.15.1.ebuild
new file mode 100644
index 000000000000..c48fd9b91186
--- /dev/null
+++ b/net-im/poezio/poezio-0.15.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1 optfeature xdg
+
+DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
+HOMEPAGE="https://poez.io/ https://codeberg.org/poezio/poezio"
+LICENSE="GPL-3+"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/${PN}/${PN}.git https://github.com/poezio/poezio.git"
+ inherit git-r3
+
+ # We build the html documentation using sphinx.
+ BDEPEND="dev-python/sphinx"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ >=dev-python/slixmpp-1.10.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/Do-not-install-man-pages-and-files-in-usr-share-poez.patch"
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+ # Delete unmaintained plugin which requires an excessive external dep
+ rm plugins/mpd_client.py || die
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if [[ -n "${EGIT_REPO_URI}" ]]; then
+ emake -C doc html
+ fi
+}
+
+# Poezio provides its own Python C extension 'poopt', which needs to be
+# correctly discovered to run the tests. See
+# https://projects.gentoo.org/python/guide/test.html#importerrors-for-c-extensions
+python_test() {
+ cd "${T}" || die
+ epytest "${S}"/test
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman data/poezio.1 data/poezio_logs.1
+
+ if [[ -n "${EGIT_REPO_URI}" ]]; then
+ docinto html
+ dodoc -r doc/build/html/*
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "screen autoaway support" dev-python/pyinotify
+}
diff --git a/net-im/poezio/poezio-9999.ebuild b/net-im/poezio/poezio-9999.ebuild
index ad409144eace..c48fd9b91186 100644
--- a/net-im/poezio/poezio-9999.ebuild
+++ b/net-im/poezio/poezio-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{11..13} )
inherit distutils-r1 optfeature xdg
@@ -28,7 +28,7 @@ RDEPEND="
dev-python/aiodns[${PYTHON_USEDEP}]
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
- >=dev-python/slixmpp-1.8.2[${PYTHON_USEDEP}]
+ >=dev-python/slixmpp-1.10.0[${PYTHON_USEDEP}]
"
PATCHES=(