summaryrefslogtreecommitdiff
path: root/net-im/skypeforlinux
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/skypeforlinux')
-rw-r--r--net-im/skypeforlinux/Manifest2
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.73.0.129.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index b33005aa0c7f..7d8f00ba9b18 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -1,5 +1,7 @@
DIST skypeforlinux_8.72.0.94-1.x86_64.rpm 118230043 BLAKE2B 9d7d8609c117947fbab4e2ac68a9bbe909f94f2ae82bc910cad66412aaced2ba13f35ce785a4f0d95690125c42789cbc4bbec6831bc0038add7fe7a98469f20b SHA512 349550d69efce07e3c9fa92ea659fc0d4b87e4e110c0bdfac9ecd365685b4d5623362b315cb3eaab7eb91078dde7e1c286165ce487e8b93585e59272e8cca3e3
+DIST skypeforlinux_8.73.0.129-1.x86_64.rpm 123370656 BLAKE2B 831188ea01a8ae27b6c5b557f7e752740a3f32928bd113bd6d8fffd31badfbff4a8f088e8e0b8fdc1b1b133ff5e6b692db3b83df4669da5d92725847a3555280 SHA512 153afbf9e7b3ad8d3ca9002835d54038e8450868df2506a61cd278ddfe3329241a913d0caef9ad0179c3f8a6a2d8f7138e4fff74c7ef7b12ddbdbe60f78e58a2
DIST skypeforlinux_8.73.0.92-1.x86_64.rpm 119323419 BLAKE2B e201be43c6f331555d3759e9484d13c1d0613dd9e60ce67c3dafec27fa9d183ddc89e1c23feb1722ace2fd492185f8402be6abec80c748e6ad1f666878a72025 SHA512 dc6b72dc43443ad7747a30adef7b08afb50b4cc40a61cff2eb8989c9f68ae817c221d4ce2812d5d54cb9a4ac5f2accfe350efdfab622096d2d0805953fbddd13
EBUILD skypeforlinux-8.72.0.94.ebuild 3160 BLAKE2B 4ada892e98d1c7c911ee821382f57bf8d17748862143a2e178a5e4402ea3bb13a63d65b4719ff4126d4005cfd28b3ab5ceb5d0fee697dcf5509d717ac8fc5f0a SHA512 978a18853d478585145a3187ab242d33785a79f7f67cd97ac51e3fea67b6e2717e0cc04e1bab0b800e95f46b6ce288e8606b4ea86bfec2b53e419e6f7595db69
+EBUILD skypeforlinux-8.73.0.129.ebuild 3160 BLAKE2B 4ada892e98d1c7c911ee821382f57bf8d17748862143a2e178a5e4402ea3bb13a63d65b4719ff4126d4005cfd28b3ab5ceb5d0fee697dcf5509d717ac8fc5f0a SHA512 978a18853d478585145a3187ab242d33785a79f7f67cd97ac51e3fea67b6e2717e0cc04e1bab0b800e95f46b6ce288e8606b4ea86bfec2b53e419e6f7595db69
EBUILD skypeforlinux-8.73.0.92.ebuild 3160 BLAKE2B 4ada892e98d1c7c911ee821382f57bf8d17748862143a2e178a5e4402ea3bb13a63d65b4719ff4126d4005cfd28b3ab5ceb5d0fee697dcf5509d717ac8fc5f0a SHA512 978a18853d478585145a3187ab242d33785a79f7f67cd97ac51e3fea67b6e2717e0cc04e1bab0b800e95f46b6ce288e8606b4ea86bfec2b53e419e6f7595db69
MISC metadata.xml 460 BLAKE2B 136f61594a68e6efed725d448cd9fcd0e0c72f884cd64ef5f8c3adbc39fd4322a4ed8ef692fa500bb00488e616520efdec943be7c4d0381345247776a8258d42 SHA512 d82b35cfa2dc12b2629f7084f071d3d3cd83e2d6246cb4c2544883f28becde6677a1739f7c028e69352267561441419d135774daa1177a803d485d38880191a8
diff --git a/net-im/skypeforlinux/skypeforlinux-8.73.0.129.ebuild b/net-im/skypeforlinux/skypeforlinux-8.73.0.129.ebuild
new file mode 100644
index 000000000000..a44feb7c8927
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.73.0.129.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}