summaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telegram-desktop')
-rw-r--r--net-im/telegram-desktop/Manifest2
-rw-r--r--net-im/telegram-desktop/telegram-desktop-5.12.3.ebuild244
2 files changed, 246 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index 8bfd374218b1..e5988d49865a 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -7,6 +7,8 @@ AUX tdesktop-5.7.2-cstring.patch 350 BLAKE2B f6a7922d7a4fc6c2230e82f8e31d69a456b
AUX tdesktop-5.8.3-cstdint.patch 603 BLAKE2B 66ecbbaa7773661ed53d12482800771ea044cadc000f16eb530d107b005576b24c71bbb86d990c9eb36f16309f83380a01c1e940d957695892a97afef0a7107e SHA512 f7655b307d11e6b255f1262d636a79f75e176e0cba264a8c37b245a7702ad7ebaa46b63d834a7383cd2223fb4f465b02eaf1843f086ce9ef378ccadf16398168
DIST tdesktop-5.10.7-full.tar.gz 72571050 BLAKE2B 38c8103bcf4579474c500afe33ed1a9bbe7e7451a50c38a1f320637083f1718165b8d6ae3303918a99fd9667fb77695cfaf15535249554720ea434b9b13b602b SHA512 1761b1489058edb10a78785aca22cf0093761a07a4da721bf5276883d117cece36ae68243288be9e06e18fe7627e9d5f2a80aaa8e521c5eefbaa94118d48979a
DIST tdesktop-5.11.1-full.tar.gz 72594842 BLAKE2B d0a637795b4c00ca8c3c88d5a678b0b87cb3b0d2dc7dc13a0e77e4e598891f01745ae1981544b4c6bc6d53746b197fad8bf4b51217108540e15cf0319348a117 SHA512 c184f159191bea34ec66b90df1834ffb24ed5d96b35fe7e09e7a790c46fd5e3d6352ff9e76d49550732d7f3e81dce9a12052d4990de39352c446db7bb77aff3c
+DIST tdesktop-5.12.3-full.tar.gz 72628307 BLAKE2B 2a625d5e71c3a583c7acf1419ff3f31173446a1475514e981c6483aa18a88ff7e1aa57252412bab3c3e9b162bc9ac6286718f2c96c2f0758f635678086469a99 SHA512 cd366f6cecfc72396ae2b8453d015e85f1f579c60212f0b77f84057ba6caf6aa97d7ed08fde2ab8bf2f29017fdd7c0b617392ec74537be4f8445ef81ea135e5c
EBUILD telegram-desktop-5.10.7.ebuild 8310 BLAKE2B 7ab046e37a6ef8b840765cd77a1a049d70b1bad3b6a67fa3e0584b5364a105b55377d61b7a8c0c13a91e8e428e73fb30454806ff4dff14f690b2e5c17c24b4e2 SHA512 3dedc82291ee913098d1548f64106704ca3e314f5dab6fd9e1701d90e3f6662adfe4ca1447b8360837f3f0b2662df98a4a0919f65e70e12372108078c206e510
EBUILD telegram-desktop-5.11.1.ebuild 8352 BLAKE2B 13c8c6bac28b274149640149c54c844a19f2d3e97cdeade658f2a83100c0187820cec8d9e9cc194964c8e3d9e141a7b65a28814e1f1f8070a92dcfb7171926e4 SHA512 f39de350a97dff964d778727ef0c4c30c83a880899744e2c152e7799342bf217caf4974525eb00c21f7f1594a7ec39574018b14968de2262d1f6da6f4bb7588c
+EBUILD telegram-desktop-5.12.3.ebuild 8352 BLAKE2B 13c8c6bac28b274149640149c54c844a19f2d3e97cdeade658f2a83100c0187820cec8d9e9cc194964c8e3d9e141a7b65a28814e1f1f8070a92dcfb7171926e4 SHA512 f39de350a97dff964d778727ef0c4c30c83a880899744e2c152e7799342bf217caf4974525eb00c21f7f1594a7ec39574018b14968de2262d1f6da6f4bb7588c
MISC metadata.xml 1297 BLAKE2B 8fd0b98eabe1a75d627899eb69dcc26b6c3b6d297b43b2d65081a57d697e05eec18dfeb0e95510473988641356dd39c16c91d391cf4a0ca09cfc531abcdb4115 SHA512 6b420a9bde7e85f502b24eb93c36ba24bd4a2978623ce4ab0c0746717609d63654120cea0af0391caf94f364784d030c9a3c492c791e4a0588d60db308d8b862
diff --git a/net-im/telegram-desktop/telegram-desktop-5.12.3.ebuild b/net-im/telegram-desktop/telegram-desktop-5.12.3.ebuild
new file mode 100644
index 000000000000..2bc462f7ad65
--- /dev/null
+++ b/net-im/telegram-desktop/telegram-desktop-5.12.3.ebuild
@@ -0,0 +1,244 @@
+# Copyright 2020-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit xdg cmake python-any-r1 optfeature flag-o-matic
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org https://github.com/telegramdesktop/tdesktop"
+
+MY_P="tdesktop-${PV}-full"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD GPL-3-with-openssl-exception LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv"
+IUSE="dbus enchant +fonts +jemalloc +libdispatch screencast qt6 wayland webkit +X"
+
+CDEPEND="
+ !net-im/telegram-desktop-bin
+ app-arch/lz4:=
+ dev-cpp/abseil-cpp:=
+ dev-cpp/ada:=
+ >=dev-cpp/glibmm-2.77:2.68
+ dev-libs/glib:2
+ dev-libs/openssl:=
+ >=dev-libs/protobuf-21.12
+ dev-libs/xxhash
+ media-libs/libjpeg-turbo:=
+ ~media-libs/libtgvoip-2.4.4_p20240706
+ media-libs/openal
+ media-libs/opus
+ media-libs/rnnoise
+ ~media-libs/tg_owt-0_pre20241202:=[screencast=,X=]
+ >=media-video/ffmpeg-6:=[opus,vpx]
+ sys-libs/zlib:=[minizip]
+ !enchant? ( >=app-text/hunspell-1.7:= )
+ enchant? ( app-text/enchant:= )
+ jemalloc? ( dev-libs/jemalloc:= )
+ libdispatch? ( dev-libs/libdispatch )
+ !qt6? (
+ >=dev-qt/qtcore-5.15:5=
+ >=dev-qt/qtgui-5.15:5=[dbus?,jpeg,png,wayland?,X?]
+ >=dev-qt/qtimageformats-5.15:5
+ >=dev-qt/qtnetwork-5.15:5[ssl]
+ >=dev-qt/qtsvg-5.15:5
+ >=dev-qt/qtwidgets-5.15:5[png,X?]
+ kde-frameworks/kcoreaddons:5
+ webkit? ( wayland? (
+ >=dev-qt/qtdeclarative-5.15:5
+ >=dev-qt/qtwayland-5.15:5[compositor(+)]
+ ) )
+ )
+ qt6? (
+ >=dev-qt/qtbase-6.5:6=[dbus?,gui,network,opengl,wayland?,widgets,X?]
+ >=dev-qt/qtimageformats-6.5:6
+ >=dev-qt/qtsvg-6.5:6
+ webkit? ( wayland? (
+ >=dev-qt/qtdeclarative-6.5:6
+ >=dev-qt/qtwayland-6.5:6[compositor,qml]
+ ) )
+ )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-keysyms
+ )
+"
+RDEPEND="${CDEPEND}
+ webkit? ( || ( net-libs/webkit-gtk:4.1 net-libs/webkit-gtk:6 ) )
+"
+DEPEND="${CDEPEND}
+ >=dev-cpp/cppgir-2.0_p20240315
+ >=dev-cpp/ms-gsl-4.1.0
+ dev-cpp/expected-lite
+ dev-cpp/range-v3
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-build/cmake-3.16
+ >=dev-cpp/cppgir-2.0_p20240315
+ dev-libs/gobject-introspection
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+ wayland? ( dev-util/wayland-scanner )
+"
+
+PATCHES=(
+ "${FILESDIR}"/tdesktop-4.2.4-jemalloc-only-telegram-r1.patch
+ "${FILESDIR}"/tdesktop-4.10.0-system-cppgir.patch
+ "${FILESDIR}"/tdesktop-5.2.2-qt6-no-wayland.patch
+ "${FILESDIR}"/tdesktop-5.2.2-libdispatch.patch
+ "${FILESDIR}"/tdesktop-5.7.2-cstring.patch
+ "${FILESDIR}"/tdesktop-5.8.3-cstdint.patch
+ "${FILESDIR}"/tdesktop-5.11.1-qt5.patch
+)
+
+pkg_pretend() {
+ if has ccache ${FEATURES}; then
+ ewarn "ccache does not work with ${PN} out of the box"
+ ewarn "due to usage of precompiled headers"
+ ewarn "check bug https://bugs.gentoo.org/715114 for more info"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ # Happily fail if libraries aren't found...
+ find -type f \( -name 'CMakeLists.txt' -o -name '*.cmake' \) \
+ \! -path './Telegram/lib_webview/CMakeLists.txt' \
+ \! -path './cmake/external/expected/CMakeLists.txt' \
+ \! -path './cmake/external/kcoreaddons/CMakeLists.txt' \
+ \! -path './cmake/external/qt/package.cmake' \
+ -print0 | xargs -0 sed -i \
+ -e '/pkg_check_modules(/s/[^ ]*)/REQUIRED &/' \
+ -e '/find_package(/s/)/ REQUIRED)/' || die
+ # Make sure to check the excluded files for new
+ # CMAKE_DISABLE_FIND_PACKAGE entries.
+
+ # Control QtDBus dependency from here, to avoid messing with QtGui.
+ # QtGui will use find_package to find QtDbus as well, which
+ # conflicts with the -DCMAKE_DISABLE_FIND_PACKAGE method.
+ if ! use dbus; then
+ sed -e '/find_package(Qt[^ ]* OPTIONAL_COMPONENTS/s/DBus *//' \
+ -i cmake/external/qt/package.cmake || die
+ fi
+
+ # Control automagic dep only needed when USE="webkit wayland"
+ if ! use webkit || ! use wayland; then
+ sed -e 's/QT_CONFIG(wayland_compositor_quick)/0/' \
+ -i Telegram/lib_webview/webview/platform/linux/webview_linux_compositor.h || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Having user paths sneak into the build environment through the
+ # XDG_DATA_DIRS variable causes all sorts of weirdness with cppgir:
+ # - bug 909038: can't read from flatpak directories (fixed upstream)
+ # - bug 920819: system-wide directories ignored when variable is set
+ export XDG_DATA_DIRS="${EPREFIX}/usr/share"
+
+ # Evil flag (bug #919201)
+ filter-flags -fno-delete-null-pointer-checks
+
+ # The ABI of media-libs/tg_owt breaks if the -DNDEBUG flag doesn't keep
+ # the same state across both projects.
+ # See https://bugs.gentoo.org/866055
+ append-cppflags -DNDEBUG
+
+ # https://github.com/telegramdesktop/tdesktop/issues/17437#issuecomment-1001160398
+ use !libdispatch && append-cppflags -DCRL_FORCE_QT
+
+ local use_webkit_wayland=$(use webkit && use wayland && echo yes || echo no)
+ local qt=$(usex qt6 6 5)
+ local mycmakeargs=(
+ -DQT_VERSION_MAJOR=${qt}
+
+ # Override new cmake.eclass defaults (https://bugs.gentoo.org/921939)
+ # Upstream never tests this any other way
+ -DCMAKE_DISABLE_PRECOMPILE_HEADERS=OFF
+
+ # Control automagic dependencies on certain packages
+ ## Header-only lib, some git version.
+ -DCMAKE_DISABLE_FIND_PACKAGE_tl-expected=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt${qt}Quick=${use_webkit_wayland}
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt${qt}QuickWidgets=${use_webkit_wayland}
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt${qt}WaylandClient=$(usex !wayland)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt${qt}WaylandCompositor=${use_webkit_wayland}
+ ## KF6CoreAddons is currently unavailable in ::gentoo
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF${qt}CoreAddons=$(usex qt6)
+
+ -DDESKTOP_APP_USE_LIBDISPATCH=$(usex libdispatch)
+ -DDESKTOP_APP_DISABLE_X11_INTEGRATION=$(usex !X)
+ -DDESKTOP_APP_DISABLE_WAYLAND_INTEGRATION=$(usex !wayland)
+ -DDESKTOP_APP_DISABLE_JEMALLOC=$(usex !jemalloc)
+ ## Enables enchant and disables hunspell
+ -DDESKTOP_APP_USE_ENCHANT=$(usex enchant)
+ ## Use system fonts instead of bundled ones
+ -DDESKTOP_APP_USE_PACKAGED_FONTS=$(usex !fonts)
+ )
+
+ if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+ einfo "Found custom API credentials"
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+ -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+ )
+ else
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+ # Building with snapcraft API credentials by default
+ # Custom API credentials can be obtained here:
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+ # After getting credentials you can export variables:
+ # export MY_TDESKTOP_API_ID="17349""
+ # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+ # and restart the build"
+ # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+ # portage will use custom variable every build automatically
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="611335"
+ -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if ! use X && ! use screencast; then
+ ewarn "both the 'X' and 'screencast' USE flags are disabled, screen sharing won't work!"
+ ewarn
+ fi
+ if ! use jemalloc && use elibc_glibc; then
+ # https://github.com/telegramdesktop/tdesktop/issues/16084
+ # https://github.com/desktop-app/cmake_helpers/pull/91#issuecomment-881788003
+ ewarn "Disabling USE=jemalloc on glibc systems may cause very high RAM usage!"
+ ewarn "Do NOT report issues about RAM usage without enabling this flag first."
+ ewarn
+ fi
+ if ! use libdispatch; then
+ ewarn "Disabling USE=libdispatch may cause performance degradation"
+ ewarn "due to fallback to poor QThreadPool! Please see"
+ ewarn "https://github.com/telegramdesktop/tdesktop/wiki/The-Packaged-Building-Mode"
+ ewarn
+ fi
+ if use wayland && ! use qt6; then
+ ewarn "Wayland-specific integrations have been deprecated with Qt5."
+ ewarn "The app will continue to function under wayland, but some"
+ ewarn "functionality may be reduced."
+ ewarn "These integrations are only supported when built with Qt6."
+ ewarn
+ fi
+ optfeature_header
+ if ! use qt6; then
+ optfeature "AVIF, HEIF and JpegXL image support" kde-frameworks/kimageformats:5[avif,heif,jpegxl]
+ else
+ optfeature "AVIF, HEIF and JpegXL image support" kde-frameworks/kimageformats:6[avif,heif,jpegxl]
+ fi
+}