summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Manifest.gzbin8417 -> 8421 bytes
-rw-r--r--net-im/telegram-desktop/Manifest2
-rw-r--r--net-im/telegram-desktop/telegram-desktop-5.13.1.ebuild216
3 files changed, 218 insertions, 0 deletions
diff --git a/net-im/Manifest.gz b/net-im/Manifest.gz
index 7e66e7caa521..8a6a7d046866 100644
--- a/net-im/Manifest.gz
+++ b/net-im/Manifest.gz
Binary files differ
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index 4dc024f5e838..cc70ab14573e 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -6,5 +6,7 @@ AUX tdesktop-5.2.2-qt6-no-wayland.patch 3630 BLAKE2B c573d04493233efc065a74644e0
AUX tdesktop-5.7.2-cstring.patch 350 BLAKE2B f6a7922d7a4fc6c2230e82f8e31d69a456ba4726fc09ee1406d1b2a6bef12d3cdcec614a58f6c12b21a7cda6318d02cabba420ef293e1bcca9deb8f699298103 SHA512 36fac80b3c4212c15daf6cb4a912dd30031bede7c120509aadf44958d6a04af5647fcb4ca2bf158065d7fadd53a837e7f8e5a2b8ec32947afb32671d37652ff6
AUX tdesktop-5.8.3-cstdint.patch 603 BLAKE2B 66ecbbaa7773661ed53d12482800771ea044cadc000f16eb530d107b005576b24c71bbb86d990c9eb36f16309f83380a01c1e940d957695892a97afef0a7107e SHA512 f7655b307d11e6b255f1262d636a79f75e176e0cba264a8c37b245a7702ad7ebaa46b63d834a7383cd2223fb4f465b02eaf1843f086ce9ef378ccadf16398168
DIST tdesktop-5.12.3-full.tar.gz 72628307 BLAKE2B 2a625d5e71c3a583c7acf1419ff3f31173446a1475514e981c6483aa18a88ff7e1aa57252412bab3c3e9b162bc9ac6286718f2c96c2f0758f635678086469a99 SHA512 cd366f6cecfc72396ae2b8453d015e85f1f579c60212f0b77f84057ba6caf6aa97d7ed08fde2ab8bf2f29017fdd7c0b617392ec74537be4f8445ef81ea135e5c
+DIST tdesktop-5.13.1-full.tar.gz 72699182 BLAKE2B 85e6e29be38f72d9171c530ba8a1a04661ed5a6deb1b66a8f4a1120ffe5d43844aedbc21e5c7bfa78f3893939777e37b8dc9a32541118da9164ee0faa6afede0 SHA512 6d15ad0641e0e47e4d48869885c63e6d1ddbfb5461c121cf33ac77d231a6fc77a6eb5333ad7b76d3aa2e1111d9a5f58846fae83cd36886838d6791dbfaa65929
EBUILD telegram-desktop-5.12.3-r3.ebuild 7428 BLAKE2B f1ea40cad3bd14b147cf09236bc68ca08a31ea1cb536fafe646c33f2c47a24ed0ebf95d3575b7b3049f868a99419d7c4b5d2782030ec8dab90456a851660edf5 SHA512 055f5630ab17828f8f675d2fdc8165e0fd9f981276ef06f573c257b18049603f3850d29f11df67532389fac5275f4c96eac95be98bd3f177cb176329950fe19f
+EBUILD telegram-desktop-5.13.1.ebuild 7429 BLAKE2B f25aa9ab18f4821e3fbcc7397cea4fdc97aa9fb563399daa60bd343df1f610a47730e0f7c8194cf8305497f53e9530de8426e607eac4eff94709aee0119438cf SHA512 76fa1eb52bbb6147de0df72df0b9893fc645d89430338f476ad08928dec97aa62e22a24835e306fb3296eb41bcc775dbc4a7e203867ef01133175365810e4dc2
MISC metadata.xml 1248 BLAKE2B f1b20562a63d6bb5fb1684390c534fb9c3ddde8c2129646a79b34e1836357594cfc6bce0882c853bd3fced5ae848d6e161c41ebb3c1faab35331007299666f1b SHA512 ebba1655ec833792d9edf8ee9b29837bcb5682213b295b0fd10e38df65e4aa8abd113916f7c1b454bc76e34aaf48760e9e08dc09772652648cb683fe5d37ca1d
diff --git a/net-im/telegram-desktop/telegram-desktop-5.13.1.ebuild b/net-im/telegram-desktop/telegram-desktop-5.13.1.ebuild
new file mode 100644
index 000000000000..ebd3e7a2115d
--- /dev/null
+++ b/net-im/telegram-desktop/telegram-desktop-5.13.1.ebuild
@@ -0,0 +1,216 @@
+# Copyright 2020-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit xdg cmake python-any-r1 optfeature flag-o-matic
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org https://github.com/telegramdesktop/tdesktop"
+
+MY_P="tdesktop-${PV}-full"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD GPL-3-with-openssl-exception LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv"
+IUSE="dbus enchant +fonts +jemalloc +libdispatch screencast wayland webkit +X"
+
+CDEPEND="
+ !net-im/telegram-desktop-bin
+ app-arch/lz4:=
+ dev-cpp/abseil-cpp:=
+ dev-cpp/ada:=
+ >=dev-cpp/glibmm-2.77:2.68
+ dev-libs/glib:2
+ dev-libs/openssl:=
+ >=dev-libs/protobuf-21.12
+ dev-libs/xxhash
+ >=dev-qt/qtbase-6.5:6=[dbus?,gui,network,opengl,ssl,wayland?,widgets,X?]
+ >=dev-qt/qtimageformats-6.5:6
+ >=dev-qt/qtsvg-6.5:6
+ media-libs/libjpeg-turbo:=
+ ~media-libs/libtgvoip-2.4.4_p20240706
+ media-libs/openal
+ media-libs/opus
+ media-libs/rnnoise
+ ~media-libs/tg_owt-0_pre20241202:=[screencast=,X=]
+ >=media-video/ffmpeg-6:=[opus,vpx]
+ sys-libs/zlib:=[minizip]
+ kde-frameworks/kcoreaddons:6
+ !enchant? ( >=app-text/hunspell-1.7:= )
+ enchant? ( app-text/enchant:= )
+ jemalloc? ( dev-libs/jemalloc:= )
+ libdispatch? ( dev-libs/libdispatch )
+ webkit? ( wayland? (
+ >=dev-qt/qtdeclarative-6.5:6
+ >=dev-qt/qtwayland-6.5:6[compositor,qml]
+ ) )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-keysyms
+ )
+"
+RDEPEND="${CDEPEND}
+ webkit? ( || ( net-libs/webkit-gtk:4.1 net-libs/webkit-gtk:6 ) )
+"
+DEPEND="${CDEPEND}
+ >=dev-cpp/cppgir-2.0_p20240315
+ >=dev-cpp/ms-gsl-4.1.0
+ dev-cpp/expected-lite
+ dev-cpp/range-v3
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-build/cmake-3.16
+ >=dev-cpp/cppgir-2.0_p20240315
+ dev-libs/gobject-introspection
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+ wayland? ( dev-util/wayland-scanner )
+"
+
+PATCHES=(
+ "${FILESDIR}"/tdesktop-4.2.4-jemalloc-only-telegram-r1.patch
+ "${FILESDIR}"/tdesktop-4.10.0-system-cppgir.patch
+ "${FILESDIR}"/tdesktop-5.2.2-qt6-no-wayland.patch
+ "${FILESDIR}"/tdesktop-5.2.2-libdispatch.patch
+ "${FILESDIR}"/tdesktop-5.7.2-cstring.patch
+ "${FILESDIR}"/tdesktop-5.8.3-cstdint.patch
+ "${FILESDIR}"/tdesktop-5.12.3-fix-webview.patch
+)
+
+pkg_pretend() {
+ if has ccache ${FEATURES}; then
+ ewarn "ccache does not work with ${PN} out of the box"
+ ewarn "due to usage of precompiled headers"
+ ewarn "check bug https://bugs.gentoo.org/715114 for more info"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ # Happily fail if libraries aren't found...
+ find -type f \( -name 'CMakeLists.txt' -o -name '*.cmake' \) \
+ \! -path './Telegram/lib_webview/CMakeLists.txt' \
+ \! -path './cmake/external/expected/CMakeLists.txt' \
+ \! -path './cmake/external/kcoreaddons/CMakeLists.txt' \
+ \! -path './cmake/external/qt/package.cmake' \
+ -print0 | xargs -0 sed -i \
+ -e '/pkg_check_modules(/s/[^ ]*)/REQUIRED &/' \
+ -e '/find_package(/s/)/ REQUIRED)/' || die
+ # Make sure to check the excluded files for new
+ # CMAKE_DISABLE_FIND_PACKAGE entries.
+
+ # Control QtDBus dependency from here, to avoid messing with QtGui.
+ # QtGui will use find_package to find QtDbus as well, which
+ # conflicts with the -DCMAKE_DISABLE_FIND_PACKAGE method.
+ if ! use dbus; then
+ sed -e '/find_package(Qt[^ ]* OPTIONAL_COMPONENTS/s/DBus *//' \
+ -i cmake/external/qt/package.cmake || die
+ fi
+
+ # Control automagic dep only needed when USE="webkit wayland"
+ if ! use webkit || ! use wayland; then
+ sed -e 's/QT_CONFIG(wayland_compositor_quick)/0/' \
+ -i Telegram/lib_webview/webview/platform/linux/webview_linux_compositor.h || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Having user paths sneak into the build environment through the
+ # XDG_DATA_DIRS variable causes all sorts of weirdness with cppgir:
+ # - bug 909038: can't read from flatpak directories (fixed upstream)
+ # - bug 920819: system-wide directories ignored when variable is set
+ export XDG_DATA_DIRS="${EPREFIX}/usr/share"
+
+ # Evil flag (bug #919201)
+ filter-flags -fno-delete-null-pointer-checks
+
+ # The ABI of media-libs/tg_owt breaks if the -DNDEBUG flag doesn't keep
+ # the same state across both projects.
+ # See https://bugs.gentoo.org/866055
+ append-cppflags -DNDEBUG
+
+ # https://github.com/telegramdesktop/tdesktop/issues/17437#issuecomment-1001160398
+ use !libdispatch && append-cppflags -DCRL_FORCE_QT
+
+ local use_webkit_wayland=$(use webkit && use wayland && echo yes || echo no)
+ local mycmakeargs=(
+ -DQT_VERSION_MAJOR=6
+
+ # Override new cmake.eclass defaults (https://bugs.gentoo.org/921939)
+ # Upstream never tests this any other way
+ -DCMAKE_DISABLE_PRECOMPILE_HEADERS=OFF
+
+ # Control automagic dependencies on certain packages
+ ## Header-only lib, some git version.
+ -DCMAKE_DISABLE_FIND_PACKAGE_tl-expected=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt6Quick=${use_webkit_wayland}
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt6QuickWidgets=${use_webkit_wayland}
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt6WaylandClient=$(usex !wayland)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt6WaylandCompositor=${use_webkit_wayland}
+
+ -DDESKTOP_APP_USE_LIBDISPATCH=$(usex libdispatch)
+ -DDESKTOP_APP_DISABLE_X11_INTEGRATION=$(usex !X)
+ -DDESKTOP_APP_DISABLE_WAYLAND_INTEGRATION=$(usex !wayland)
+ -DDESKTOP_APP_DISABLE_JEMALLOC=$(usex !jemalloc)
+ ## Enables enchant and disables hunspell
+ -DDESKTOP_APP_USE_ENCHANT=$(usex enchant)
+ ## Use system fonts instead of bundled ones
+ -DDESKTOP_APP_USE_PACKAGED_FONTS=$(usex !fonts)
+ )
+
+ if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+ einfo "Found custom API credentials"
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+ -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+ )
+ else
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+ # Building with snapcraft API credentials by default
+ # Custom API credentials can be obtained here:
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+ # After getting credentials you can export variables:
+ # export MY_TDESKTOP_API_ID="17349""
+ # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+ # and restart the build"
+ # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+ # portage will use custom variable every build automatically
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="611335"
+ -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if ! use X && ! use screencast; then
+ ewarn "both the 'X' and 'screencast' USE flags are disabled, screen sharing won't work!"
+ ewarn
+ fi
+ if ! use jemalloc && use elibc_glibc; then
+ # https://github.com/telegramdesktop/tdesktop/issues/16084
+ # https://github.com/desktop-app/cmake_helpers/pull/91#issuecomment-881788003
+ ewarn "Disabling USE=jemalloc on glibc systems may cause very high RAM usage!"
+ ewarn "Do NOT report issues about RAM usage without enabling this flag first."
+ ewarn
+ fi
+ if ! use libdispatch; then
+ ewarn "Disabling USE=libdispatch may cause performance degradation"
+ ewarn "due to fallback to poor QThreadPool! Please see"
+ ewarn "https://github.com/telegramdesktop/tdesktop/wiki/The-Packaged-Building-Mode"
+ ewarn
+ fi
+ optfeature_header
+ optfeature "AVIF, HEIF and JpegXL image support" kde-frameworks/kimageformats:6[avif,heif,jpegxl]
+}