summaryrefslogtreecommitdiff
path: root/net-irc
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/Manifest.gzbin7909 -> 7909 bytes
-rw-r--r--net-irc/anope/Manifest2
-rw-r--r--net-irc/anope/anope-2.0.14.ebuild24
3 files changed, 10 insertions, 16 deletions
diff --git a/net-irc/Manifest.gz b/net-irc/Manifest.gz
index 2d746ce411d5..29451cc9b93b 100644
--- a/net-irc/Manifest.gz
+++ b/net-irc/Manifest.gz
Binary files differ
diff --git a/net-irc/anope/Manifest b/net-irc/anope/Manifest
index 936cbfff903c..b601a4f0b430 100644
--- a/net-irc/anope/Manifest
+++ b/net-irc/anope/Manifest
@@ -3,5 +3,5 @@ AUX anope-2.0.7-example.conf-user.patch 391 BLAKE2B 781e413ef79a7ca601710957b519
AUX anope-conf.d-v2 344 BLAKE2B 8817bba9938aa03abf79e61b86ddde537c6ec68b6584074e1f9bc50fe8334c5d0135ca17551390618f60b26d93f0209789b9337879dbecdcb4fced3d2bb88b3b SHA512 ae1851ccaa128404f3a721c92571ae3c4e0efd18c318485594f87da565b2de505ee9ace580b5d1c4ce4a7b53a4eba8338874195ca3a2cbc415ab6facdb3c9d7a
AUX anope-init.d 724 BLAKE2B afe0abfaebf66408ecc1a3c99fdb5795898559551700073078f9352f2ada8ba5bc90fc1a8b5e4779bd132606d9297c19fd418db02d8a26b6629da675f6fc0d8c SHA512 e058ccfb4a44238cd1540704f130207236be71799d0a5f4678638d313d958b10dfc5de9cd515f18ccdd9faf41dc93eaf33b5f4013f534efec00adc401a2cb97c
DIST anope-2.0.14.tar.gz 1642605 BLAKE2B 0c741a0f214a3807dcfaa1a90f63d922549c92904cb632432129ca1f252f182037882b954d4ef3d8d1417d00ebd96de58528a3916aac24a556507872df326408 SHA512 0dfa71a8ecd164fb8bf2864ac13969610b8fcd0ec9dea2e65dabc2d8808fe392f966d08dfffce31410344ea5a1ab88d85e9083b4ce25003a699adf0f3649b08d
-EBUILD anope-2.0.14.ebuild 4379 BLAKE2B 2c7881b7d384ba2aa73f9f0007f7d540b4f8dc29bd7b285e50a8a313c3976785f1cb89a5e9bd7928f71610db3df0e5e1b4db84e48d2a2a8dfc5c6046ece3d4ca SHA512 3281430b473ac4681e80466707646d574fe5f1fa7e399458bbe6f1bc4d58097cf5c47cdd1e88189236c9104c15c944096a29f4c08fdb34423df549315177587c
+EBUILD anope-2.0.14.ebuild 4253 BLAKE2B 9353e1e60e4f3f1536e9591a094658fefc8502dd06d7b25461f20d54e38f655d4c19491cfa04e1acee000cd7687596f0ad841212f04ef5a6644b36a602e6c810 SHA512 157306a8059e3344268c0128541e8857fa598faacd0f98fa58083cd045ef89af24e84f1bd96d636027f67c505cc0ac7c3dbe8513764a86a4af8504c2c2fdf54f
MISC metadata.xml 852 BLAKE2B 98a0fa9f486bf215b38317e6e200856c2993f2e8d537e66796a5974ca3ee29e6f0f871df1b1f815df44d72338daf3773a51385233e0435044805dbeaa35df12b SHA512 fc8a47790f6125b702ea9616e804d1b7b92872c8e9cc333619499d5346dd449db4b775628a6e0b4b7b97175df05aa497b745ace498d26b2ffc3c82b866268b24
diff --git a/net-irc/anope/anope-2.0.14.ebuild b/net-irc/anope/anope-2.0.14.ebuild
index 612104802ab8..1da9d273b863 100644
--- a/net-irc/anope/anope-2.0.14.ebuild
+++ b/net-irc/anope/anope-2.0.14.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit cmake eapi9-ver
DESCRIPTION="Anope IRC Services"
HOMEPAGE="https://www.anope.org/ https://github.com/anope/anope/"
@@ -137,18 +137,12 @@ pkg_postinst() {
# Only tell them about this on a fresh install.
ewarn "Anope won't run out of the box, you still have to configure it to match your IRCd's configuration."
ewarn "Edit /etc/anope/services.conf to configure Anope."
- else
- # We're replacing some versions. Find out which.
- local ver
- for ver in ${REPLACING_VERSIONS} ; do
- if ver_test ${ver} -lt 2.0.7 ; then
- # In this version, we introduced correct FHS structure
- # We need the users to make some changes to their services.conf
- ewarn "Please modify your services.conf to include the following directive:"
- ewarn "in options{}, please include user=\"anope\" and group=\"anope\""
- ewarn "This is needed because Anope now starts as root and drops down."
- ewarn "Reference: https://wiki.anope.org/index.php/2.0/Configuration#Services_Process_Options"
- fi
- done
+ elif ver_replacing -lt 2.0.7 ; then
+ # In this version, we introduced correct FHS structure
+ # We need the users to make some changes to their services.conf
+ ewarn "Please modify your services.conf to include the following directive:"
+ ewarn "in options{}, please include user=\"anope\" and group=\"anope\""
+ ewarn "This is needed because Anope now starts as root and drops down."
+ ewarn "Reference: https://wiki.anope.org/index.php/2.0/Configuration#Services_Process_Options"
fi
}