summaryrefslogtreecommitdiff
path: root/net-irc
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/Manifest.gzbin8056 -> 8052 bytes
-rw-r--r--net-irc/polari/Manifest2
-rw-r--r--net-irc/polari/polari-43.0.ebuild52
3 files changed, 54 insertions, 0 deletions
diff --git a/net-irc/Manifest.gz b/net-irc/Manifest.gz
index c4bb61d89a9b..93df6ea73f6c 100644
--- a/net-irc/Manifest.gz
+++ b/net-irc/Manifest.gz
Binary files differ
diff --git a/net-irc/polari/Manifest b/net-irc/polari/Manifest
index 8d3bafe2588e..ea1df3c342e2 100644
--- a/net-irc/polari/Manifest
+++ b/net-irc/polari/Manifest
@@ -1,3 +1,5 @@
DIST polari-42.0.tar.xz 1125160 BLAKE2B e4edeb2023c2df2e1ad855ceea4dc9e646eca18da61643698410724d1fbe031ee609a30e139b2ab2ad6ddf22d1a4ea0b408b4b93d7ac8874c35c9d49f96f16bd SHA512 a64e1841d91809389af4b1f7eebd1b1e187f9e5f7058a84ab3b50bbbdc3786a7ec89bd4ccc4935473d1de1c40f6dbd6daf30b6bff48dd132e28a4be3e8bfb114
+DIST polari-43.0.tar.xz 1128316 BLAKE2B 224c70d77ad772aacc5264b2ff15b9371cbfb47bcdaef3b3fd6b55b86e48947b960773e9568f3a6830b1958b2d901ec9d3e3da3cd3fb1c6341a5fa7d34ab5014 SHA512 ff1d96f7e464043616760f378136c3dfb1b5fc3fce3d24fe067540ce0a306d76027681f085ad0030959a6b1653d9f0291e108457305c16849936ab25861fe285
EBUILD polari-42.0.ebuild 1058 BLAKE2B a8b84f2ef48fe1e0a42c41fb5fa25fe48558c0edc2ec0ed74aef06fbec2b0cb69f8de3db5e3b37b58884b61ca55327480f7b30017714af664533af60b3f8be98 SHA512 22cfe5afe01e7ec962e0341d5e782c30c8f98c709ba885c703c8d1ce76f24a2c84df217e909e019968c1fd1cb777cfed2498beb4c34184c56b20a20efdece9d5
+EBUILD polari-43.0.ebuild 1060 BLAKE2B 62b623fac1cf94eb664b8de82a73a1c99e75aeace1c9650814628fb170f34819cf7e9c5b6b0a22a73e1cc4aa4dd14f56aa54ac4612940b217b1665beb2426c21 SHA512 685e9d657d40bf8b442dd036bc285a988c89ca495cd4372bc86fa27b416171710e4f6eb8638c72f59140514ef4899b4c67f789952b900b587e4ca0832260fa33
MISC metadata.xml 254 BLAKE2B de7a97001e5947704f42973c8a0c3a23c2d80afb976254f5fd21e9d372a946e055d4cdc3c0eaed010505f87929b56e8b1e650c945e2a302644adbc9440833be8 SHA512 c81da4f9b80e5691a167f4590906952e25356604ec17689c005be14efb394c0634776bbe84df936edde239480bdf46db41216b00da4a3a45f670e9ca18ab0132
diff --git a/net-irc/polari/polari-43.0.ebuild b/net-irc/polari/polari-43.0.ebuild
new file mode 100644
index 000000000000..6913d04f14d8
--- /dev/null
+++ b/net-irc/polari/polari-43.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="An IRC client for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Polari https://gitlab.gnome.org/GNOME/polari"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.43.4:2
+ net-libs/telepathy-glib[introspection]
+ >=dev-libs/gobject-introspection-1.50:=
+ >=dev-libs/gjs-1.73.1
+
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=app-text/gspell-1.4.0[introspection]
+ x11-libs/pango[introspection]
+ app-crypt/libsecret[introspection]
+ net-libs/libsoup:3.0[introspection]
+ net-im/telepathy-logger[introspection]
+"
+RDEPEND="${DEPEND}
+ >=net-irc/telepathy-idle-0.2
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ dev-libs/json-glib
+ )
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}