summaryrefslogtreecommitdiff
path: root/net-libs/dleyna
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/dleyna')
-rw-r--r--net-libs/dleyna/Manifest2
-rw-r--r--net-libs/dleyna/dleyna-0.8.3-r1.ebuild57
-rw-r--r--net-libs/dleyna/files/dleyna-0.8.3-fix-basename-declration-musl.patch41
3 files changed, 100 insertions, 0 deletions
diff --git a/net-libs/dleyna/Manifest b/net-libs/dleyna/Manifest
index 2cb9ed35ce4c..3174b5d1cd8b 100644
--- a/net-libs/dleyna/Manifest
+++ b/net-libs/dleyna/Manifest
@@ -1,3 +1,5 @@
+AUX dleyna-0.8.3-fix-basename-declration-musl.patch 1804 BLAKE2B e1de9ff7310b251f3f0f889f1876b8a4b3e49ba1635cf64f9963bb1f0fd9e90b995e22283f1a57f11ca3b4f74f5401f1082c933cf830452db0c25776437eada2 SHA512 c1e76158d5ec216e2922f737b2a18b5de23a96f9c0c2f91c3f3c7d5a313a7c4565853bd33cba55af2a69b138fb6f6ea2040fcd5d525a7b5d8e100d52465a5e85
DIST dLeyna-v0.8.3.tar.bz2 149796 BLAKE2B e1fc2d1d5fa6178856d5114b55dbaae5a969ab7f2b5716ab70c1359755b21927ed0ecfd8d943520254a1ead2b2db368838787f0954bc312712a8075ea3f94896 SHA512 a62c643467b2f75efb9e794802b3bc183a5f8cfe9b80eeaee627aeaa471d7fb107cf1bde549c274ecd86ca06ad5870a481316e1101647c9d7e6243114b5dd06e
+EBUILD dleyna-0.8.3-r1.ebuild 1282 BLAKE2B d0995236b9de1cbee9ac286d75249ea1c6eb1c94284149db0dd710fbebbb1a8d86f9594b56d5d7aff2dc746c275a32dd74e616beda98c300c95987c9d014d348 SHA512 6f0ff65ec4f4e3e1d0e7b9f39e70f79c5d5de88afe4af43b7bdeaccd9b11bbf217937e1934f4b4028508cc8a8eee442e0ca24132397c76d97bccf15ac4a9ca21
EBUILD dleyna-0.8.3.ebuild 1206 BLAKE2B 86f4e63381cb4f0f830ea7860fccf18d05d4a95d578d1b6948f9c7a3eeeef9ab99232ecaaeb87498d5287fe06d98bbf439dbb900771323babb51da4bc5240b53 SHA512 a52abd7bcac25503de1048808e60ecdcac961263036b61a2a938523e3726fb66e3964182686d7989989a892ecab915bfed74365025b605fd7aef060eb3b5c12c
MISC metadata.xml 347 BLAKE2B f530e4051daea6e7c842e14aab33cd08680f7414dd5bb06fb0c4e7aafc9c851daff77752e77e1f12b333e992854ae97217f78d30a2be2b601ea3465b4e0ff31e SHA512 e5d55300134824082f76ed5fd0a9e5753ef74e98796b17da4c47e7b5e0e5480e82b3e6db6d4880e2ca00b12e01c1514736a41ae0967226283d329f576ab497a3
diff --git a/net-libs/dleyna/dleyna-0.8.3-r1.ebuild b/net-libs/dleyna/dleyna-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..a749a75155a1
--- /dev/null
+++ b/net-libs/dleyna/dleyna-0.8.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-single-r1
+
+DESCRIPTION="A set of services and D-Bus APIs to simplify access to UPnP/DLNA media devices"
+HOMEPAGE="https://gitlab.gnome.org/World/dLeyna"
+SRC_URI="https://gitlab.gnome.org/World/dLeyna/-/archive/v${PV}/dLeyna-v${PV}.tar.bz2"
+S="${WORKDIR}"/dLeyna-v${PV}
+
+LICENSE="LGPL-2.1"
+SLOT="1.0/6" # soname of libdleyna-core-1.0.so
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/gssdp-1.6.0:1.6=
+ >=net-libs/gupnp-1.6.0:1.6=
+ >=net-libs/gupnp-av-0.12.9:0=
+ >=media-libs/gupnp-dlna-0.9.4:2.0=
+ >=net-libs/libsoup-3.0:3.0
+ dev-libs/libxml2
+
+ ${PYTHON_DEPS}
+
+ !net-libs/dleyna-connector-dbus
+ !net-libs/dleyna-core
+ !net-libs/dleyna-renderer
+ !net-misc/dleyna-server
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/docutils
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.8.3-fix-basename-declration-musl.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddbus_service_dir="${EPREFIX}/usr/share/dbus-1/services"
+ -Dman_pages=true
+ -Ddocs=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}
diff --git a/net-libs/dleyna/files/dleyna-0.8.3-fix-basename-declration-musl.patch b/net-libs/dleyna/files/dleyna-0.8.3-fix-basename-declration-musl.patch
new file mode 100644
index 000000000000..4d59ac72d69e
--- /dev/null
+++ b/net-libs/dleyna/files/dleyna-0.8.3-fix-basename-declration-musl.patch
@@ -0,0 +1,41 @@
+https://gitlab.gnome.org/World/dLeyna/-/commit/8c8e17a77dc666738a6f1c309b46056dd25fe576
+From: Brahmajit Das <brahmajit.xyz@gmail.com>
+Date: Mon, 5 Aug 2024 07:07:37 +0000
+Subject: [PATCH] Fix implicit declaration of basename
+
+On musl there is only one implementation of basename, which comes from
+the libgen.h header file. However, in this case the code is using GNU
+implementation of basename, which is not available on musl. This results
+in build error:
+
+../dLeyna-v0.8.3/libdleyna/core/log.c: In function 'dleyna_log_init':
+../dLeyna-v0.8.3/libdleyna/core/log.c:156:17: error: implicit declaration of function 'basename'; did you mean 'g_basename'? [-Wimplicit-function-declaration]
+ 156 | openlog(basename(program), option, LOG_DAEMON);
+ | ^~~~~~~~
+ | g_basename
+../dLeyna-v0.8.3/libdleyna/core/log.c:156:17: error: passing argument 1 of 'openlog' makes pointer from integer without a cast [-Wint-conversion]
+ 156 | openlog(basename(program), option, LOG_DAEMON);
+ | ^~~~~~~~~~~~~~~~~
+ | |
+ | int
+In file included from ../dLeyna-v0.8.3/libdleyna/core/log.h:27,
+ from ../dLeyna-v0.8.3/libdleyna/core/log.c:30:
+
+Please also reffer: https://bugs.gentoo.org/936939
+
+Co-authored-by: Jens Georg <mail@jensge.org>
+Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com>
+--- a/libdleyna/core/log.c
++++ b/libdleyna/core/log.c
+@@ -153,7 +153,7 @@ void dleyna_log_init(const char *program, const char *version)
+ s_log_context.log_domain = g_strdup(program);
+ prv_set_flags_from_param();
+
+- openlog(basename(program), option, LOG_DAEMON);
++ openlog(NULL, option, LOG_DAEMON);
+
+ old = setlogmask(LOG_MASK(LOG_INFO));
+ syslog(LOG_INFO, "dLeyna core version %s", VERSION);
+--
+GitLab
+