summaryrefslogtreecommitdiff
path: root/net-libs/gnutls/gnutls-3.6.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gnutls/gnutls-3.6.5.ebuild')
-rw-r--r--net-libs/gnutls/gnutls-3.6.5.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/net-libs/gnutls/gnutls-3.6.5.ebuild b/net-libs/gnutls/gnutls-3.6.5.ebuild
index 7f3b673fd300..0e4f46b96b24 100644
--- a/net-libs/gnutls/gnutls-3.6.5.ebuild
+++ b/net-libs/gnutls/gnutls-3.6.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools libtool multilib-minimal
+inherit libtool multilib-minimal
DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
HOMEPAGE="http://www.gnutls.org/"
@@ -23,12 +23,12 @@ RDEPEND=">=dev-libs/libtasn1-4.9:=[${MULTILIB_USEDEP}]
dev-libs/libunistring:=[${MULTILIB_USEDEP}]
>=dev-libs/nettle-3.4.1:=[gmp,${MULTILIB_USEDEP}]
>=dev-libs/gmp-5.1.3-r1:=[${MULTILIB_USEDEP}]
- tools? ( sys-devel/autogen )
+ tools? ( sys-devel/autogen:= )
dane? ( >=net-dns/unbound-1.4.20:=[${MULTILIB_USEDEP}] )
guile? ( >=dev-scheme/guile-2:=[networking] )
- nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
- pkcs11? ( >=app-crypt/p11-kit-0.23.1[${MULTILIB_USEDEP}] )
- idn? ( >=net-dns/libidn2-0.16-r1[${MULTILIB_USEDEP}] )"
+ nls? ( >=virtual/libintl-0-r1:=[${MULTILIB_USEDEP}] )
+ pkcs11? ( >=app-crypt/p11-kit-0.23.1:=[${MULTILIB_USEDEP}] )
+ idn? ( >=net-dns/libidn2-0.16-r1:=[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
test? (
seccomp? ( sys-libs/libseccomp )
@@ -74,10 +74,10 @@ src_prepare() {
# Use sane .so versioning on FreeBSD.
elibtoolize
- # bug#673574 - until upstream builds with guile.m4 of guile-2.2
- # eautoreconf will run gtk-doc gen so let's avoid that
- eaclocal
- eautoconf
+ # detect also guile-2.2, bug#673574
+ # aclocal/autoreconf will require more dependencies
+ # that we want to have
+ sed -i 's/\(_guile_versions_to_search="\)\(.*\)\("\)/\1\2 2.2\3/' configure || die
}
multilib_src_configure() {