summaryrefslogtreecommitdiff
path: root/net-libs/libaccounts-glib
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libaccounts-glib')
-rw-r--r--net-libs/libaccounts-glib/Manifest2
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.25-r1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/libaccounts-glib/Manifest b/net-libs/libaccounts-glib/Manifest
index 35bb6228d543..55f00e8f09f4 100644
--- a/net-libs/libaccounts-glib/Manifest
+++ b/net-libs/libaccounts-glib/Manifest
@@ -1,3 +1,5 @@
DIST libaccounts-glib-1.24.tar.gz 116578 BLAKE2B d3569ee9d4b92f285f20ab7bc285c62c9817a16f632ad9da83a86ab69e7e3ded74afbcb1307deee788a74796372c0011563ecd293cba4b0e81d15252eae4cf50 SHA512 d4e6906f642c7a196cb42172f31345f58037d528950bee3af2b8cb388aea386056cbaa22f0e7c604a4e00038b231e9ee455f6a1d48f82344cfc0037ad7251b7c
+DIST libaccounts-glib-1.25.tar.gz 117337 BLAKE2B 72e6e15b63eea4d5b2a3e994779a4636bee859c6d395c8c9f65120cfee1c25a5708971b438010f668eefee20735b01e9f9f4e1ac4cb55495a06143d20198e422 SHA512 cc8b493d246f99300ee614fed93258378ecdbe9c518a958a59827ee8f74559b1ee3683acfb85f59aa91390275497fb35041da2be47f27f24f96e1efd5d6d2e20
EBUILD libaccounts-glib-1.24-r1.ebuild 1224 BLAKE2B 182cab44010e82d4f03117ac6389bb342dc6be98480d1971f4574b240401b94d978e9867e70bb99fc05520b15319afcedf9405c7dc9ba90b8949b44722a65490 SHA512 abf2db02a4678f7968568dc510f64c40e6f6c7c1dd673208b81c0c7b989036dd03c65ad4f0580cc86351b904349071ad145559a8b9f3546ce8da12767303e6f7
+EBUILD libaccounts-glib-1.25-r1.ebuild 1313 BLAKE2B 76bcf2dc17771aadb53d91c7c54ac9d9f4bc6277d13ba46e37bea1829b1480aee6029f993330c9811557c51525d42656d1b49cb8f681a1da786765efeaa290f3 SHA512 db0734f8442ee6c7b5b3db028b040fb23c91c5824f901d61d34cfaae49d14a90828a465ae31b79e5321dcb9b07e741aa6fb209ca8ea3ae611cfeeb510964d093
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.25-r1.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.25-r1.ebuild
new file mode 100644
index 000000000000..4e1911060109
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.25-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit meson python-r1 vala
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://gitlab.com/accounts-sso/libaccounts-glib"
+SRC_URI="https://gitlab.com/accounts-sso/${PN}/-/archive/VERSION_${PV}/${PN}-VERSION_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/gobject-introspection:=
+ dev-libs/libxml2
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-libs/check
+ doc? ( dev-util/gtk-doc )
+"
+
+# fails
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-VERSION_${PV}"
+
+src_prepare() {
+ default
+
+ vala_src_prepare --ignore-use
+
+ use doc || sed -e "/^subdir('docs')$/d" -i meson.build || die
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir meson_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir meson_src_compile
+}
+
+src_install() {
+ einstalldocs
+ python_foreach_impl run_in_build_dir meson_src_install
+ python_foreach_impl python_optimize
+}