summaryrefslogtreecommitdiff
path: root/net-libs/libaccounts-glib
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libaccounts-glib')
-rw-r--r--net-libs/libaccounts-glib/Manifest6
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild48
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild47
-rw-r--r--net-libs/libaccounts-glib/metadata.xml8
4 files changed, 109 insertions, 0 deletions
diff --git a/net-libs/libaccounts-glib/Manifest b/net-libs/libaccounts-glib/Manifest
new file mode 100644
index 000000000000..a416a1672b50
--- /dev/null
+++ b/net-libs/libaccounts-glib/Manifest
@@ -0,0 +1,6 @@
+DIST libaccounts-glib-1.21.tar.gz 127061 SHA256 27cb75f3f2f0ce736b77f0fd0432f8d565297f0735846a2862577eadaec92488 SHA512 3eef882597392387a962dddbc49e4428f7e11e329fac1c3f4d39f3ef315118274b253e36095754d6392802cf298f2bfc0adf30b9a114b047082cda231bb10f60 WHIRLPOOL 46f8f04958199b4b1b91f1b03b66772e1a46440f390c30fef43c09f1171af28d41f57fb92d1303263d1771d21ff9e035729ff2396637894dd811dc0fd314f059
+DIST libaccounts-glib-1.23.tar.gz 127931 SHA256 b4686af19b86cbedc0eb6a00aceee70f2c61254013d2cadd8aba15e9c540fff7 SHA512 88fec1fed7a135375516363e4b7f1330d45a6337bbfb45dd35dabce87097ee4e550e968870541e1b496c2ee3db1bd26e0665f4155f1e64d1cc7b6b74d5b71b5c WHIRLPOOL 90d200bec667dd1bd7666d040a432494e1ce703e54ba38ceecd1850059991c3927c638228b9287e19e9d5971fbe4d8197470934c1a6542f729d0fc450b7e0377
+EBUILD libaccounts-glib-1.21-r2.ebuild 826 SHA256 8811d89173837c8fb6c234ea65f8b2c8af09b759e91fb0d758fe8c0da0b278b4 SHA512 1e5c60ace5100e2a7a1bc5c7643ab93401725a152716b2e412f2885612450653477caea0ac4ec05e31b18cbd265112227a27fece5cca3b78454248d42d962c78 WHIRLPOOL b97092d2e26b42ffd79b556bdf1e1f8580c905515945fb539592fe26ff08519668a529cf5b4182cd4f14d255c231a880170b1ce138e80d76671f926e34dcae0c
+EBUILD libaccounts-glib-1.23.ebuild 820 SHA256 e07342eb7d388e98a40c4d9791693615b522d3a3f8e7361c306e7566c1f715a7 SHA512 481f1a558781fc31905fcc8a6599e77f52cf80721868a74f7882bd767dc1247fe05f4dfe4d2f873498eeb75ad34bee2a00f1cd48ad1ab95c3542a4297a3585a3 WHIRLPOOL 3abf2eb85ea8a374ea7c76b92175af204543aea988495a6caa384ddcd1d7755bf6a119275192fd80adef6f6f9885cd3d7a20e4c65a1d723c6af3f7931584124c
+MISC ChangeLog 3385 SHA256 872627cf78c551afce5d35894f715cfd2e2462cbeff225571bd15e24ca792677 SHA512 92ee5fd595976004eb2e811e2f42125deb6a372f976065b67f88d219bc4fd5e6816d78e3076c50561bc13cba0d223f08fa3c65e0541ae4aebe7b5e1d6d43d091 WHIRLPOOL 0bf8c1f3c023f7a28316793cb8d470b53e009b3d18d047f74745588db00ff423d912a4115eae6e311eec28dea944c586aec29973b2d6a26ee6323cdd72d0d011
+MISC metadata.xml 249 SHA256 584f1dcf51866dc24a9abf7a89bfba0fad11dde81ae1c1b715da41770d233c99 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3 WHIRLPOOL 200c07a8bf7c55b11b7936d5cd30e991a511684913334e72f59def66c0ced5fed0b4a8754e2d98bffbab631cb90d4e17fcccc59d5dcc5a8e988f69e47c85518c
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild
new file mode 100644
index 000000000000..e7b1dda81e88
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils vcs-snapshot xdg-utils
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/libaccounts-glib/repository/archive.tar.gz?ref=VERSION_${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+"
+
+RESTRICT="test"
+
+DOCS=( AUTHORS NEWS )
+
+pkg_setup() {
+ xdg_environment_reset
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-python \
+ --disable-tests \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild
new file mode 100644
index 000000000000..928af3370a31
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils vcs-snapshot xdg-utils
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/libaccounts-glib/repository/archive.tar.gz?ref=VERSION_${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+"
+
+DOCS=( AUTHORS NEWS )
+
+pkg_setup() {
+ xdg_environment_reset
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-python \
+ --disable-tests \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/net-libs/libaccounts-glib/metadata.xml b/net-libs/libaccounts-glib/metadata.xml
new file mode 100644
index 000000000000..2fdbf33d963d
--- /dev/null
+++ b/net-libs/libaccounts-glib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+</pkgmetadata>