summaryrefslogtreecommitdiff
path: root/net-libs/libotr
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libotr')
-rw-r--r--net-libs/libotr/Manifest2
-rw-r--r--net-libs/libotr/files/libotr-4.1.1-dont-clobber-fortify-source.patch23
-rw-r--r--net-libs/libotr/libotr-4.1.1-r2.ebuild40
3 files changed, 65 insertions, 0 deletions
diff --git a/net-libs/libotr/Manifest b/net-libs/libotr/Manifest
index 96d63cfbb57d..174c4602ed6d 100644
--- a/net-libs/libotr/Manifest
+++ b/net-libs/libotr/Manifest
@@ -1,4 +1,6 @@
+AUX libotr-4.1.1-dont-clobber-fortify-source.patch 762 BLAKE2B 0d9fe67330b78887751622c5dc9f7ca997ac3a0138aafc3a0ecf9fe9eaff39ef39f3a21ed8b8fa5c5cfd0d4cd39d0387a8b4e3319eed4f55bbdf750ffb319813 SHA512 ed9daa6ee9da54fa318678bb01e7d9c6f0b5de80036d591110dfe60b6f352cd66fc3566295671bcaaded759a812561a2bc3d4599c3e53576b67af3b71ce49cca
AUX libotr-4.1.1-fix-build-with-libgcrypt-1.10.patch 285 BLAKE2B c83895dc849645ae83bf2f5e5a7c63fd5d94071af6859744551be298d2de7708d6818aadecfc1d83e6fb93c14cad23d2d3e5f1650067fbf29e4cb43aab8101ad SHA512 d1d59c884ec96ab258aeb9d41ce39949aec97de85859c4fc376b5afdc225495a0f7266b4214140f5f6cc4e0acd1a63a376f070a4393460d36e72934a8398e06f
DIST libotr-4.1.1.tar.gz 655791 BLAKE2B 51be68277b56dab96a68fb744e467dc13d966038849ccc0b98b1d0082bcf3b4a0b7fcaeb3f050b0798851723bcdf11bc7ef6681a94999105656dec2fe919659b SHA512 c957206235b9f627542f23a645c822ea1b318d83fa655f41ed8d9a3c0dddf30b88f0ca82060026af155e48ecb13969dc9270831f20304669794151f666ae5cb0
EBUILD libotr-4.1.1-r1.ebuild 777 BLAKE2B 8276f8bc612232da153b99a00da3d0df585ae2ce4c6339dcd4f8bd836ee67407f6724821b92745d7b202e4e95a64ca2e2d0c9c1be00899664cf1e924791e5d75 SHA512 4e15bf596cb902eff60c565ad16e29bdfce7c68209a4550f702714975a043741e03f36ff13b584e935153357362af9faf7d4c07d156d1dc16b01eb7553fadee4
+EBUILD libotr-4.1.1-r2.ebuild 914 BLAKE2B 6ebefeccfb4cfa20a2263d7f234ffa207bc0d9906fdac71e7ae2b7aff8524af30bb4beddb9e384d382436ad3d720015dd9f49991003807b25c33115d83dae5d1 SHA512 af3965195f2f9581c223aaa98e4ff4c9d13d612f8f6f2d36dcd5fe371b26a5553370aa595bf3b8b1b4dff584481732cccac3fbdfa8f17a804b8eff26274a0be1
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/net-libs/libotr/files/libotr-4.1.1-dont-clobber-fortify-source.patch b/net-libs/libotr/files/libotr-4.1.1-dont-clobber-fortify-source.patch
new file mode 100644
index 000000000000..af9330b97d3a
--- /dev/null
+++ b/net-libs/libotr/files/libotr-4.1.1-dont-clobber-fortify-source.patch
@@ -0,0 +1,23 @@
+Don't clobber our toolchain defaults.
+
+https://bugs.gentoo.org/895680
+--- a/configure.ac
++++ b/configure.ac
+@@ -151,7 +151,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
+ ])], have_clang=yes, have_clang=no)
+
+ if test x$enable_gcc_hardening != xno; then
+- CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=2"
++ CFLAGS="$CFLAGS"
+ if test x$have_clang = xyes; then
+ OTR_CHECK_CFLAGS(-Qunused-arguments)
+ fi
+@@ -181,6 +181,8 @@ if test x$enable_linker_hardening != xno; then
+ OTR_CHECK_LDFLAGS(-z relro -z now, "$all_ldflags_for_check", "$all_libs_for_check")
+ fi
+
++AX_ADD_FORTIFY_SOURCE
++
+ AC_OUTPUT([Makefile src/Makefile toolkit/Makefile tests/Makefile tests/utils/Makefile libotr.pc
+ tests/utils/tap/Makefile
+ tests/unit/Makefile
diff --git a/net-libs/libotr/libotr-4.1.1-r2.ebuild b/net-libs/libotr/libotr-4.1.1-r2.ebuild
new file mode 100644
index 000000000000..d1082fa841cc
--- /dev/null
+++ b/net-libs/libotr/libotr-4.1.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE="https://otr.cypherpunks.ca"
+SRC_URI="https://otr.cypherpunks.ca/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ dev-libs/libgcrypt:=
+ dev-libs/libgpg-error:=
+"
+DEPEND="${RDEPEND}"
+# autoconf-archive for F_S patch
+BDEPEND="sys-devel/autoconf-archive"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.1.1-fix-build-with-libgcrypt-1.10.patch"
+ "${FILESDIR}/${PN}-4.1.1-dont-clobber-fortify-source.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc UPGRADING
+
+ # no static archives, #465686
+ find "${ED}" -name '*.la' -delete || die
+}