summaryrefslogtreecommitdiff
path: root/net-libs/libquotient
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libquotient')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.8.1.2.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index c7bbf97be29b..990bd25fd11a 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -2,5 +2,4 @@ AUX libquotient-0.8.0-no-android.patch 993 BLAKE2B 119a902b67ac0c101a84217e52f34
AUX libquotient-0.8.0-no-tests.patch 1215 BLAKE2B 4749dfb1b6e2be0f59b83a73092e7b4191458ad7220faefe0db71846d3d5fcbd59eb4adfcf97c0d779bc074fb0ccd1faef8eccfc44e4ad53750f79da6524b7dc SHA512 2923d0cec567378e1ddd9c7a50667a28bb79cdf871ce328b6db1ee0eb457b6c7d1a376b7659cb92f13483c29baa4991f410b3c5c478c881f80443a7eb4003b7f
DIST libquotient-0.8.1.2.tar.gz 730435 BLAKE2B 7c43bc394d46ddb600c683d771add48f9a20d205ce61796b27a34933521e38be2b3b331263ffc6bb00fd1197a195b295e3311d52d8d74cdfe51453954cb79ae1 SHA512 ff11f1e9093004461425179fcab630237bf1d28f6e5abe6486d657b455b560884047715fccff5b31f26275ffd423df787014aaac35c556eddb1842e8e68841ce
EBUILD libquotient-0.8.1.2-r1.ebuild 1926 BLAKE2B a5104973ab5d280f35f5a4af480faa02404bcc8ae13a7a1cfa8c1cbb0b152bcf92aac092d243ae1266a24bd3334bdb43ab9e772c47783e37b35150400c156eb9 SHA512 1ec198a0cf6e08f34dd18339f2159eb7c7fca4fe3f9d6163110b30488acde7f2792ac31c40ea43923240595ae040c593a7c28c4e533cd87299a508ae552001b8
-EBUILD libquotient-0.8.1.2.ebuild 1300 BLAKE2B d8fbf9f6f4fca3c5ff7996ce7eacd74c8c57baa115ac139c5610862da4b0277c6ed7baa729a776b4681f002a56f82b23bd672f8e775ebc9edeafc8299007df07 SHA512 6b8a4ec5db4684ba27935b8469fcee51244a42dd3d35274d972ffc5e0523dd230acaa5698bd0cf6cd072f822a8a51d119ccc000b0f18711643704d6902337f87
MISC metadata.xml 338 BLAKE2B 84af57de6f4faeb65a9a9bd272a29e6cb4491e8eff3d79c4704566baa4af7cfa2f9c6c14a52a0a44e8751848b9e89f30807a6d0c304eb28d8b2cb9f43f0b37c5 SHA512 f93f27e29f09f8e6e6c0038a403990260c8998213c8248c2acbfc1f7e76faa07c296d4b30214c746f30d42b37d636be92720e692280098d4d72d3d542b5004aa
diff --git a/net-libs/libquotient/libquotient-0.8.1.2.ebuild b/net-libs/libquotient/libquotient-0.8.1.2.ebuild
deleted file mode 100644
index 77b91909c07b..000000000000
--- a/net-libs/libquotient/libquotient-0.8.1.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Qt-based SDK to develop applications for Matrix"
-HOMEPAGE="https://github.com/quotient-im/libQuotient"
-SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/libQuotient-${PV}"
-
-LICENSE="LGPL-2+"
-SLOT="0/${PV}" # FIXME: check soname on next version bump
-KEYWORDS="amd64 arm64 ~ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/olm
- dev-libs/openssl:=
- dev-libs/qtkeychain:=[qt5(+)]
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtsql:5
-"
-DEPEND="${RDEPEND}
- test? (
- dev-qt/qtconcurrent:5
- dev-qt/qttest:5
- )
-"
-
-PATCHES=(
- # downstream patches
- "${FILESDIR}"/${PN}-0.8.0-no-android.patch
- "${FILESDIR}"/${PN}-0.8.0-no-tests.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_WITH_QT6=OFF
- -DBUILD_TESTING=$(usex test)
- -DQuotient_ENABLE_E2EE=ON
- )
- use test && mycmakeargs+=(
- -DQuotient_INSTALL_TESTS=OFF
- )
- cmake_src_configure
-}
-
-src_test() {
- # https://github.com/quotient-im/libQuotient/issues/435
- # testolmaccount requires network connection/server set up
- local myctestargs=(
- -j1
- -E "(testolmaccount)"
- )
- cmake_src_test
-}