summaryrefslogtreecommitdiff
path: root/net-libs/librsync
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/librsync')
-rw-r--r--net-libs/librsync/Manifest2
-rw-r--r--net-libs/librsync/librsync-2.3.4.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/librsync/Manifest b/net-libs/librsync/Manifest
index 65dad8dd32a5..236b0feae85a 100644
--- a/net-libs/librsync/Manifest
+++ b/net-libs/librsync/Manifest
@@ -1,3 +1,5 @@
DIST librsync-2.3.2.tar.gz 194461 BLAKE2B 72f55c3809c35ee4eff4af03776aed6acfc33cf6109ea8e7fc5cdb4c3919e8f69f156d17ace4443bbb520cbdbe5220df7b5059f00173298839cbb86e0df491c7 SHA512 77d826dbaf02061b759d876a6b537238bad40379a08e4494ebfd3e380b2eb921b7b060bc570330aeac9424ef1a9d521f449d559c9ffa3be24acdef4ad530fe90
+DIST librsync-2.3.4.tar.gz 201307 BLAKE2B eb1f2cde347a6314f1dbcc72f326cd542005458294413bf473478c5665b4090b5ee133ab1059dcea932e41d57202795a057f52206ec3363b5d611ea1792079a8 SHA512 ac01413b875e774db9fec3888210a4b9a5f3d32c081f1ed5f2cf9dc29cfae6ecedf6eac42062631e6dcf188853313fce4520430549768a0f68993419b07e58d9
EBUILD librsync-2.3.2.ebuild 586 BLAKE2B 34edb159d8c26e2c997526f3afa7f558902e2dcec84343f46c2cab14fb322b93dcf4052d5577e74bc6757f1f231b0df25cfe971a71023f82b0d58a46b08bc66c SHA512 ca68f767af578d9751880a03838d4010bd06fc73d573f7529abf8cd372f5a489b0d590668f29c9863d91dd58636ff35b46dfc8cabbeeb26587c271e6c36ac80a
+EBUILD librsync-2.3.4.ebuild 592 BLAKE2B 11a9b78f3255b88ce266cd8171e6500d3d68b1bd195b643de59c0fff75d4370840bd69949bdf79862be99790a1a4bc4631a07b56a001a5dbc8da7ac5ece811fd SHA512 dcb9345778f194e0c0f1606beb804a12de3368387c1d271180ff57620b64f6189642cd7d552241d61a2fd09cc87037869142c6220cdaccfc083bbfbd3a60aec9
MISC metadata.xml 388 BLAKE2B 80d7575764d0921330e63232cde4810b5b93b6e4c1dd02d05b21dbd93cad44facf9bfaec7a03eb39042e25e22e22a96ba00a669e60853d5134647a0373e19f91 SHA512 e2fdddabaf1450596f679d5214671e5695ef026d171aaa9dbd84cde16247996295e70677485b64df59c360a3036fef5bd20d0666653be78a4091392a245e3d67
diff --git a/net-libs/librsync/librsync-2.3.4.ebuild b/net-libs/librsync/librsync-2.3.4.ebuild
new file mode 100644
index 000000000000..1a3139b85484
--- /dev/null
+++ b/net-libs/librsync/librsync-2.3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Remote delta-compression library"
+HOMEPAGE="https://librsync.github.io/"
+SRC_URI="https://github.com/librsync/librsync/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_LIBB2=OFF
+ )
+
+ cmake_src_configure
+}