summaryrefslogtreecommitdiff
path: root/net-libs/libvncserver
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libvncserver')
-rw-r--r--net-libs/libvncserver/Manifest5
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.11-r1.ebuild72
-rw-r--r--net-libs/libvncserver/metadata.xml31
3 files changed, 108 insertions, 0 deletions
diff --git a/net-libs/libvncserver/Manifest b/net-libs/libvncserver/Manifest
new file mode 100644
index 000000000000..a3ca9085b020
--- /dev/null
+++ b/net-libs/libvncserver/Manifest
@@ -0,0 +1,5 @@
+DIST LibVNCServer-0.9.11.tar.gz 1413739 SHA256 193d630372722a532136fd25c5326b2ca1a636cbb8bf9bb115ef869c804d2894 SHA512 e473c081b68dd3cdd96a1756b4f4945ece79d3c8e4cef62140be1699671555fc16d3080e81d764197a14ea83203ffcd0e18c3cc182e012d036e3faae943003fb WHIRLPOOL 98a24e533a0b8065d1f3c52672b601750f26a89e29cee8e3b253cc15219d0249befd1aa2735f06351d7911777ff7dc3ce39dc903f7046f39a0abf0af277dff11
+EBUILD libvncserver-0.9.11-r1.ebuild 1932 SHA256 111be18814ecd74a232ee58ec8743169af34b9eeff4fc39989c08309be87bafc SHA512 f811f67aae5e0724f1b8f95cfdea020351524a8c03e5a5d009073571ab4b4da6280bdcd879292b5649c2e73d92f68d8ab4bcace81c455491150044eed2215b93 WHIRLPOOL f9751bab8ea6426c6e183f266ef240c88804b7680a2805435caf8cb8a44d78af17fe1cc08af33dce6e8e86022773cee90c55135bf4111d3c878f20b124c5d2fc
+MISC ChangeLog 4226 SHA256 9991eead9456a60b7e8324ef418f6b0072d3b52e415c712f75249f2e7299924c SHA512 b4731ff6504276baf2a4f71b93568dccce537cf747d85c978a2a7f4867791d027886ae982e2012814d2b65b1d53900e4aa7f049fe3dd5cb2c9ef04880313b65e WHIRLPOOL 4ee5a7adbce2f6c4e064e28498993899615a3d8d3be0b0b7bca9dc866e89684ce18a1d8fa7f60f4a4deee1e3fb6918611ac7df6829bf3d4d8ffc390bec43486a
+MISC ChangeLog-2015 14713 SHA256 31edf042312d3db31d45ebfc2da6cac73f7691b541da0b4158118c4c984fa716 SHA512 cab18518fb2e65d58581cc6ebdfdbc28e72a6484cfa8b8283d9cb52262d77126ae914b1d1b92c7c48db882dbd90de1915e2445d3abaabb87ba15f9ce6c7903ce WHIRLPOOL 386e3eb78e88e1be29531bc129f46b1d9513498fc7d2d7b506b3787514a690902bac4035956592d1f063470090d5775e211c398793e8c798227e293b4a30c58b
+MISC metadata.xml 1077 SHA256 3ceba8ccecf68db8e45e4f87b08c6ce5b19b858515b2878edcfdc1a6d0beccde SHA512 9a6e708b40d590b968d4cc534661f52cde4848edb93fe5775b69dd20ba8d1e794cbb284a63d9c674936a1530f520f559546c78f457853b61b4489b8f264084b9 WHIRLPOOL ef0a19bb0e78f811f402bea1a905e781572a450fb6602b2b611938f9e0127e9233714779144be8cd9d6d023bf04fd00397af5d3dcd0999697cc6453c6b1548ac
diff --git a/net-libs/libvncserver/libvncserver-0.9.11-r1.ebuild b/net-libs/libvncserver/libvncserver-0.9.11-r1.ebuild
new file mode 100644
index 000000000000..218aea83cd84
--- /dev/null
+++ b/net-libs/libvncserver/libvncserver-0.9.11-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools eutils multilib-minimal
+
+MY_PN="LibVNCServer"
+
+DESCRIPTION="library for creating vnc servers"
+HOMEPAGE="https://libvnc.github.io/"
+SRC_URI="https://github.com/LibVNC/${PN}/archive/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+# No sub slot wanted (yet), see #578958
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+24bpp gcrypt gnutls ipv6 +jpeg libressl +png ssl static-libs systemd test +threads +zlib"
+REQUIRED_USE="!gnutls? ( ssl? ( threads ) )"
+
+DEPEND="
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}] )
+ gnutls? (
+ >=net-libs/gnutls-2.12.23-r6:0=[${MULTILIB_USEDEP}]
+ >=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}]
+ )
+ !gnutls? (
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ )
+ )
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ png? ( >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}] )
+ systemd? ( sys-apps/systemd:= )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1:0=[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PN}-${PV}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ default
+
+ sed -i -r \
+ -e "/^SUBDIRS/s:\<$(usex test '' 'test|')client_examples|examples\>::g" \
+ Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static) \
+ $(use_with 24bpp) \
+ $(use_with gnutls) \
+ $(usex gnutls --with-gcrypt $(use_with gcrypt)) \
+ $(usex gnutls --without-ssl $(use_with ssl)) \
+ $(use_with ipv6) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with threads pthread) \
+ $(use_with zlib)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/net-libs/libvncserver/metadata.xml b/net-libs/libvncserver/metadata.xml
new file mode 100644
index 000000000000..6c1ab10cbc08
--- /dev/null
+++ b/net-libs/libvncserver/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+If you don't know VNC, have a look at the original VNC or at Tridia
+VNC, who also have commercial support for it.
+
+Now that you know what it is, maybe you want to make your own server. If
+this is not the case, you can ignore the rest of this page an go on
+surfing the internet.
+
+Now that you want to make a VNC server, that is, a server which speaks
+the RFB protocol, you can download this library from sourceforge.
+ </longdescription>
+ <use>
+ <flag name="24bpp">enable 24bpp support</flag>
+ <flag name="gcrypt">enable support for gcrypt</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">LibVNC/libvncserver</remote-id>
+ <remote-id type="sourceforge">libvncserver</remote-id>
+ </upstream>
+</pkgmetadata>