summaryrefslogtreecommitdiff
path: root/net-libs/nDPI/nDPI-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nDPI/nDPI-9999.ebuild')
-rw-r--r--net-libs/nDPI/nDPI-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-libs/nDPI/nDPI-9999.ebuild b/net-libs/nDPI/nDPI-9999.ebuild
index e2efa26265f9..704e7b7703e2 100644
--- a/net-libs/nDPI/nDPI-9999.ebuild
+++ b/net-libs/nDPI/nDPI-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,10 +27,6 @@ RDEPEND="${DEPEND}"
src_prepare() {
default
- sed -i \
- -e "s%^libdir\s*=\s*\${prefix}/lib\s*$%libdir = \${prefix}/$(get_libdir)%" \
- src/lib/Makefile.in || die
-
eautoreconf
}
@@ -52,5 +48,10 @@ src_test() {
src_install() {
default
+ # Makefile logic is broken in 4.6, let's wait a bit given history and
+ # go with hack for now.
+ mv "${ED}"/usr/$(get_libdir)/pkgconfig "${ED}"/usr/usr/$(get_libdir)/pkgconfig || die
+ mv "${ED}"/usr/usr/* "${ED}"/usr || die
rm "${ED}/usr/$(get_libdir)"/lib${PN,,}.a || die
+ rm -rf "${ED}"/usr/usr || die
}