summaryrefslogtreecommitdiff
path: root/net-libs/nghttp2/nghttp2-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp2/nghttp2-9999.ebuild')
-rw-r--r--net-libs/nghttp2/nghttp2-9999.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/net-libs/nghttp2/nghttp2-9999.ebuild b/net-libs/nghttp2/nghttp2-9999.ebuild
index fc3c9a321036..44a9ccc69a4e 100644
--- a/net-libs/nghttp2/nghttp2-9999.ebuild
+++ b/net-libs/nghttp2/nghttp2-9999.ebuild
@@ -5,21 +5,15 @@
EAPI=8
-inherit multilib-minimal
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
- inherit autotools git-r3
-else
- SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
+inherit autotools git-r3 multilib-minimal
DESCRIPTION="HTTP/2 C Library"
HOMEPAGE="https://nghttp2.org/"
+EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
LICENSE="MIT"
SLOT="0/1.14" # <C++>.<C> SONAMEs
+KEYWORDS=""
IUSE="cxx debug hpack-tools jemalloc static-libs test +threads utils xml"
RESTRICT="!test? ( test )"
@@ -47,7 +41,7 @@ BDEPEND="virtual/pkgconfig"
src_prepare() {
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ eautoreconf
}
multilib_src_configure() {