summaryrefslogtreecommitdiff
path: root/net-libs/nghttp3
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/Manifest2
-rw-r--r--net-libs/nghttp3/nghttp3-1.9.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index bda05f8d61d5..d14957859f3a 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1,5 +1,7 @@
DIST nghttp3-1.8.0.tar.xz 398640 BLAKE2B 14866d9efdfc847367dde782770f43374209bd4229fa621c3142bb6c8ac3b3db6feb34e7732365edaded49b6d27ca9c02b376d11a082c6f7ad2b3e8b4d799e01 SHA512 01b7a6e313e13ebfecd63afdfaed8c8518b49cff64d08359ec7fb7f05f2dc615c4d58a8338d789e54c2d85cb5fa8e2151c91df40ec39826283f7328fc86fc18b
+DIST nghttp3-1.9.0.tar.xz 400208 BLAKE2B d7d0807c3b445db9a8304273c99b4febdc962c505ce67af5ab5ccbd1434316291f5b41b3834c6462a950f94f6d434d3655b77fe1df78d2f5c758a8c1a2dc0639 SHA512 acef4156878047fcc44669888911cb2bcf255c11106da8342349406b906d46f641b59e295a1b650815d896465bebcbc6652581d906ce348ef8d07442b307f862
EBUILD nghttp3-1.8.0-r1.ebuild 973 BLAKE2B e87f8e2cac6e32fc10a141768486540505112f3a8ca3ab8a106198b66416e8edb2dc38c9db9bd2a6aad06be3de3fa598fbeeddb06c7b0b7fd7a01931d1dbcc2b SHA512 1aacad545d3aef95349031fc51254241514bd5128b4245b305a892ac7bbea126c5db7e2fab6e678fc700a5cb10eeb0eaae21dd612d764ce6790bc5f0d7085df6
EBUILD nghttp3-1.8.0.ebuild 988 BLAKE2B b9ceaf1f6fff3e99d320140d12339be50b015513a1225e9d42a74a4924da7f56146815704f165c4c158d39b88479d6b3eca38ffcdeb5da52548fb72a91d445b4 SHA512 a4dc4cf2a8b52ee52e82b9a7ab210699e9fb3305227059141d7a031821c299c3b5857235dbb3f6e024f1aadb3f56c449fffd4cf2658cfa26af76ad494d910025
+EBUILD nghttp3-1.9.0.ebuild 980 BLAKE2B 17c4849c84c29755dc506438dd514642bc0ecc2c421c45f16ec9e4441fb13dd3767ce93ab2628e8d05e553905fb22a525e78d1de30a405a9b90f1cddf17f5e88 SHA512 b5d6dbf6cba7c7830045bde4f9f41146db039355f4a9d47fd34648a5a602831a54f4904afc0f9d63b373cc9835ab82f6197265108aa5d9be16e7e3987c307d0d
EBUILD nghttp3-9999.ebuild 980 BLAKE2B 17c4849c84c29755dc506438dd514642bc0ecc2c421c45f16ec9e4441fb13dd3767ce93ab2628e8d05e553905fb22a525e78d1de30a405a9b90f1cddf17f5e88 SHA512 b5d6dbf6cba7c7830045bde4f9f41146db039355f4a9d47fd34648a5a602831a54f4904afc0f9d63b373cc9835ab82f6197265108aa5d9be16e7e3987c307d0d
MISC metadata.xml 328 BLAKE2B 6f0147cead329ef6b779485417ff33e5814b0cd86e99b571b0dc5653a7ca8f80f65fddb8b1b58fe249b7b86c0aecd32a446d415065fc70a0c72bf69651b19d25 SHA512 54e49a9c82c6a7f7a50daf557416845fa5c548f11ca243ff236105ad97903ea983436e94067c831b93ca95da154dd2561e314e96e8bde6d4678efd1adaf02f11
diff --git a/net-libs/nghttp3/nghttp3-1.9.0.ebuild b/net-libs/nghttp3/nghttp3-1.9.0.ebuild
new file mode 100644
index 000000000000..175e47477ab4
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-1.9.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Built with autotools rather than cmake to avoid circular dep (bug #951524)
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3"
+
+LICENSE="MIT"
+SLOT="0/0"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ --disable-debug
+ --enable-lib-only
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}"/usr -type f -name '*.la' -delete || die
+}