summaryrefslogtreecommitdiff
path: root/net-libs/nghttp3
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/Manifest4
-rw-r--r--net-libs/nghttp3/nghttp3-0_pre20190912.ebuild5
-rw-r--r--net-libs/nghttp3/nghttp3-9999.ebuild5
3 files changed, 8 insertions, 6 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index 96396613dcd9..9af179f241b4 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1,4 +1,4 @@
DIST nghttp3-0_pre20190912.tar.gz 155172 BLAKE2B fabd472e429222502288b7a4030b4aa51f8a1b609590d63b51ab3f918b8cdb462b766a40911986b3f72f2f1b0debee1f0ebdf8802991bf4fc5d4a6d14297bdcc SHA512 89c7b40843bde9d2c2ab24211794b6ae0e1fa15413e92dcf2238b876552f29bb2f0db724d9a205c2a1c98f25a14ef570c9e53df52fb519230b6f78dcc04d2117
-EBUILD nghttp3-0_pre20190912.ebuild 947 BLAKE2B afeea5dfc3c33793175981a74c0d1485b2ab33a5a45b387054705b238d4ccbc73d282ff6163b80295ba3ab550808b8a54aec014e81655ffbe2aacdb3dd5fc614 SHA512 18999a7d0dda93632ba6d015938e60c662448e5a33324b51a44a4e577b332a9be56060cd5b148039394fb9d8d0c843c23974695119d40594ae17411835e89684
-EBUILD nghttp3-9999.ebuild 849 BLAKE2B c471dbbbc2eb5409395d310c258bcd6056cad20f1b03caeb7f64249e28c8324abf323e0d2ba3208f802a6bb258517bd6529e1c261209a49d182a8104ad307fae SHA512 8632a568e194e9101cc77a648546af1b72831d5241860a4f4868ef4f19c4d1c8dd5dfe6f86aef20a144987db6f5e3b53f7fb7de007db6f491c4d0c5f584c25e8
+EBUILD nghttp3-0_pre20190912.ebuild 951 BLAKE2B dccd37b9e789f37395247abfb6018fd9967fd7c0bef54c18d71c06d1eda16dd3ce42c1e118229e32ae7531004f8778aebd41e43177f9d7800a4348a247e6d96d SHA512 a56e3962290706a1a9e4afc9e809792a480712ff84d5b8cb69b700bc3ae044638e7a9f560e6af5f66f2705af161ee6621bf0455b14163f8dcdc499d80c0627a4
+EBUILD nghttp3-9999.ebuild 853 BLAKE2B a7c78a6d9968179edecaabe1b2db1032d8aedd2fb840a31eb7c41caf7e860f1669c4954cf86570ae713a6c1479e22a6261c0772267d59d2b4f934c84c2a60813 SHA512 c8dc975f34b9040df82389bdb738ffa57f0565d708c8b711828f501bb8fd110923d945be8c494daf03346eac1bfe337132f4cb3dd236faf4b1745233844d7d4c
MISC metadata.xml 326 BLAKE2B 04521fe96f519c53e0a95a6a720be2e9828cb12ca5b51c6895d23e01e99d88d6b9970a5b01cdc9fc158444c01fd77e192a9071445f389df300e0fe9ec5c0d7f4 SHA512 02b24b1a01a3682c089affbba8f49eb19e1751362aa51306b9fd73e1050d465cf98511be57374321eb9b4fbb99db6c867995b9dcc1cc511b96d7286c039270bf
diff --git a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild b/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
index 82c8375e72b0..03aecea14f7e 100644
--- a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
+++ b/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == 9999 ]] ; then
@@ -33,9 +34,9 @@ multilib_src_configure() {
-DENABLE_EXAMPLES=OFF
-DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {
- cmake-utils_src_make check
+ cmake_build check
}
diff --git a/net-libs/nghttp3/nghttp3-9999.ebuild b/net-libs/nghttp3/nghttp3-9999.ebuild
index 7df7eb88b3ac..d6e17cdeb225 100644
--- a/net-libs/nghttp3/nghttp3-9999.ebuild
+++ b/net-libs/nghttp3/nghttp3-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == 9999 ]] ; then
@@ -31,9 +32,9 @@ multilib_src_configure() {
-DENABLE_EXAMPLES=OFF
-DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {
- cmake-utils_src_make check
+ cmake_build check
}