summaryrefslogtreecommitdiff
path: root/net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild')
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild
new file mode 100644
index 000000000000..52c36e4a8cc9
--- /dev/null
+++ b/net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( >=dev-util/cmocka-1.1.0 )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUNIT_TESTING=$(usex test ON OFF)
+ )
+ cmake-multilib_src_configure
+}