summaryrefslogtreecommitdiff
path: root/net-mail/ytnef/ytnef-2.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/ytnef/ytnef-2.1.2.ebuild')
-rw-r--r--net-mail/ytnef/ytnef-2.1.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-mail/ytnef/ytnef-2.1.2.ebuild b/net-mail/ytnef/ytnef-2.1.2.ebuild
new file mode 100644
index 000000000000..19c571ce77e4
--- /dev/null
+++ b/net-mail/ytnef/ytnef-2.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Yeraze's TNEF Stream Reader - for winmail.dat files"
+HOMEPAGE="https://github.com/Yeraze/ytnef"
+SRC_URI="https://github.com/Yeraze/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+QA_PKGCONFIG_VERSION="${PV}.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND="dev-perl/MIME-tools"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}