summaryrefslogtreecommitdiff
path: root/net-misc/aggregate/aggregate-1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/aggregate/aggregate-1.6.ebuild')
-rw-r--r--net-misc/aggregate/aggregate-1.6.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/net-misc/aggregate/aggregate-1.6.ebuild b/net-misc/aggregate/aggregate-1.6.ebuild
index a8700cfabbd5..8df22ac51199 100644
--- a/net-misc/aggregate/aggregate-1.6.ebuild
+++ b/net-misc/aggregate/aggregate-1.6.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils toolchain-funcs
+EAPI=6
+
+inherit toolchain-funcs
DESCRIPTION="Take a list of prefixes and perform two optimisations to reduce the length of the prefix list"
HOMEPAGE="http://dist.automagic.org/"
@@ -16,9 +17,7 @@ IUSE=""
RDEPEND="dev-lang/perl"
DEPEND=""
-src_prepare() {
- epatch "${FILESDIR}"/${P}-build-fixup.patch
-}
+PATCHES=( "${FILESDIR}/${P}-build-fixup.patch" )
src_configure() {
tc-export CC
@@ -26,7 +25,7 @@ src_configure() {
}
src_install() {
- dobin aggregate aggregate-ios || die
+ dobin aggregate{,-ios}
doman aggregate{,-ios}.1
- dodoc HISTORY
+ einstalldocs
}