summaryrefslogtreecommitdiff
path: root/net-misc/axel/axel-2.4-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/axel/axel-2.4-r3.ebuild')
-rw-r--r--net-misc/axel/axel-2.4-r3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/axel/axel-2.4-r3.ebuild b/net-misc/axel/axel-2.4-r3.ebuild
new file mode 100644
index 000000000000..d9fb8f0ef787
--- /dev/null
+++ b/net-misc/axel/axel-2.4-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DOWNLOAD_ID=3016
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="http://axel.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/${DOWNLOAD_ID}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris"
+IUSE="debug nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS=( API CHANGES CREDITS README axelrc.example )
+
+src_prepare() {
+ append-lfs-flags
+ epatch \
+ "${FILESDIR}"/${P}-buildsystem.patch \
+ "${FILESDIR}"/${P}-bffr-overflow.patch \
+ "${FILESDIR}"/${P}-max-redir.patch
+ tc-export CC
+}
+
+src_configure() {
+ local myconf=()
+
+ use debug && myconf+=( --debug=1 )
+ myconf+=( --i18n=$(usex nls 1 0) )
+ econf \
+ --strip=0 \
+ ${myconf[@]}
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND='\''axel -a -o "\${DISTDIR}/\${FILE}.axel" "\${URI}" && mv "\${DISTDIR}/\${FILE}.axel" "\${DISTDIR}/\${FILE}"'\'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}