summaryrefslogtreecommitdiff
path: root/net-misc/connman
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/Manifest2
-rw-r--r--net-misc/connman/connman-1.43.ebuild132
2 files changed, 134 insertions, 0 deletions
diff --git a/net-misc/connman/Manifest b/net-misc/connman/Manifest
index a0ad64b9b1a9..0dc24f32feb7 100644
--- a/net-misc/connman/Manifest
+++ b/net-misc/connman/Manifest
@@ -2,6 +2,8 @@ AUX connman.confd 728 BLAKE2B c4ee3b02bddaaa99af6aab2ecb0300cc7d67cfc73114d94863
AUX connman.initd2 479 BLAKE2B 4ef210f405b196fe2fe0fa2e95188cded69d3da37e9f368f500f95db48e1e51e881a5f04479e501283c70712f99a20569b9bf2c6793dc36fb37c68bafb9ff8c3 SHA512 6b636b53f1bede22f04d7107c0e5032dbd425032f317692b2ba39f810371eb89a840ced5f8988d26d384eb6e61ea967d1088c4f0ba6cff42782d9d39300b2a40
AUX libresolv-musl-fix.patch 1554 BLAKE2B 496cae4e748089c6f2fe46850a4940660bcaff8289f477e1c4b019f2a854d33022a171d7f16e2b8193c94964806542560e00fbf54e63deea9038845201120aa8 SHA512 c258e747e13b86c81ae96ac1743abf0c1461b9053c5b386d594a49f0b1890f10d89bea92610762ff609a4cc5fea04a43fab83894702f552b05af400f01cb011e
DIST connman-1.42.tar.gz 743965 BLAKE2B 1d9eeb4c917978df502de684128a3464bbc7f3960878842a3ac27295dc5d049641cd5218a9542055b5d9ab2b6114fb773fc8a173f54dca3afe37109ab58bde35 SHA512 98ede28854e5948c8b67c5ba03b156ed9966e9fcda2d39168062873b194a192d12af885c63d9a2cb0b7b5b882b69fdbb0e09c4eb0c6772a76db06de7b9e363d7
+DIST connman-1.43.tar.gz 800363 BLAKE2B f7d906df55e89ffe58fe4c684577be94468d24e6934f82f6461c93969743c44c227cc1caa1dc5123ffb8e521385a08bc7e59c733619c39beae34a2e8ca0b495f SHA512 60fef8fb5ac0679068794c84af7eefbc051c4fff12c86a02574d3225e5729ae9ff38d4223f72f03621db9b05624843165fee5692dc12d493676d987b9433174a
EBUILD connman-1.42.ebuild 3508 BLAKE2B 10e1bc360fa9a17a454302e30cdd601333aa33ab8d53f9cef1124c7063828892d292e18ad66ce60cfad926ce45fe7f50f0e45b2caa7b615dfdde13a5dd1152b3 SHA512 28ed3c6136d59153b5542bd2ee7d57b8ae2a7cbda635c0beac121edec61fcb3fc90d4eea90b4bc026ab41b2e07f2a0f0a250f9ed5a7fe49c511c513e432ef841
+EBUILD connman-1.43.ebuild 3514 BLAKE2B 3ccd6e7a452a80d2490270d0dd50e78dc5420860ca44f35eab6a3ddf9390369d6a67f2e68f00a6343288398b8d4b05127b6fe6470e3c94415936b09ff58d974c SHA512 8346031c1fff0e655004295633da89458063b167ecb3fefcc6fb47817b8fc5f60aefe0068299e1df42094206400a97a0c1ad6de4a53d900ee074b94bbce55fcb
EBUILD connman-9999.ebuild 3532 BLAKE2B 1af7dd81bb71adb568072d0b2e817c99b96fa2b2fea6be7a35ddface9169564787b9a79fa8f4fce64612b4d3e1efcd4c6aa92f064e9a521e3eb2d251790337ed SHA512 c6da057d5c9a3bee4b203c9c5c3bbcdca8f5f5d0d44ffb4cb3674ddeb317474a89e980fd2248c3ffdfff758ad0957ae9003f6468b49334bd508241cecd708761
MISC metadata.xml 1314 BLAKE2B 8ac27df91b77d2da814c0f35368359f2c55c9cf9c9b8db56748ca9a6128f59514dbcba5c966777a1dda27ed37ccdc6e7e37b57724f7bac83e383c3f8e5b427ce SHA512 98dcfc78d0d4a7abab5282efc2cd10419ab067d6f52f9743f7b72dc446f6e0cc0c5a63266ffa3b9cdb4df3935fc5e7f96faa143bf796ccd90e709c26e7a652b7
diff --git a/net-misc/connman/connman-1.43.ebuild b/net-misc/connman/connman-1.43.ebuild
new file mode 100644
index 000000000000..117268197dc3
--- /dev/null
+++ b/net-misc/connman/connman-1.43.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+inherit autotools systemd tmpfiles
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/connman/connman.git"
+else
+ SRC_URI="https://git.kernel.org/pub/scm/network/connman/connman.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://git.kernel.org/pub/scm/network/connman/connman.git/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="bluetooth debug doc +ethernet examples iptables iwd l2tp networkmanager
++nftables ofono openconnect openvpn policykit pptp tools vpnc +wifi wireguard
+wispr"
+
+REQUIRED_USE="^^ ( iptables nftables )"
+BDEPEND="virtual/pkgconfig"
+COMMON_DEPEND=">=dev-libs/glib-2.16
+ net-libs/gnutls
+ >=sys-apps/dbus-1.2.24
+ sys-libs/readline:0=
+ nftables? (
+ >=net-libs/libnftnl-1.0.4:0=
+ >=net-libs/libmnl-1.0.0:0=
+ )
+ openconnect? ( net-vpn/openconnect )
+ openvpn? ( net-vpn/openvpn )
+ pptp? ( net-dialup/pptpclient )
+ vpnc? ( net-vpn/vpnc )
+ wireguard? ( >=net-libs/libmnl-1.0.0:0= )"
+RDEPEND="${COMMON_DEPEND}
+ bluetooth? ( net-wireless/bluez )
+ iptables? ( >=net-firewall/iptables-1.4.8 )
+ l2tp? ( net-dialup/xl2tpd )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ wifi? (
+ !iwd? ( >=net-wireless/wpa_supplicant-0.7.3-r3[dbus] )
+ iwd? ( net-wireless/iwd )
+ )"
+DEPEND="${COMMON_DEPEND}
+ >=sys-kernel/linux-headers-2.6.39"
+
+PATCHES=( "${FILESDIR}/libresolv-musl-fix.patch" )
+
+if [ ! -z ${COMMIT} ]; then
+ S=${WORKDIR}/${PN}-${COMMIT}
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+
+ cp "${FILESDIR}"/connman.initd2 "${T}"
+ if use iwd; then
+ sed -i \
+ -e "s/need dbus/need dbus iwd/" \
+ -e '/start-stop-daemon --start/ s/ -- / -- --wifi=iwd_agent /' \
+ "${T}"/connman.initd2 || die
+ sed -i \
+ -e "/^ExecStart/ s/$/ --wifi=iwd_agent/" \
+ src/connman.service.in || die
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var \
+ --runstatedir=/run \
+ --with-systemdunitdir=$(systemd_get_systemunitdir) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable debug) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable examples test) \
+ $(use_enable l2tp l2tp builtin) \
+ $(use_enable networkmanager nmcompat) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable pptp pptp builtin) \
+ $(use_enable tools) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wireguard) \
+ $(use_enable wispr wispr builtin) \
+ --with-firewall=$(usex iptables "iptables" "nftables" ) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+ )
+ # wifi USE logic to match networkmanager ebuild behavior
+ if use wifi; then
+ if use iwd; then
+ myeconfargs+=( --enable-iwd --disable-wifi )
+ else
+ myeconfargs+=( --disable-iwd --enable-wifi=builtin )
+ fi
+ else
+ myeconfargs+=( --disable-iwd --disable-wifi )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dobin client/connmanctl
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /usr/lib/${PN}/scripts
+ keepdir /var/lib/${PN}
+ newinitd "${T}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process connman_resolvconf.conf
+}