summaryrefslogtreecommitdiff
path: root/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch')
-rw-r--r--net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch50
1 files changed, 0 insertions, 50 deletions
diff --git a/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch b/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch
deleted file mode 100644
index 867561f2e7e5..000000000000
--- a/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- a/m4macros/ax_cpp11.m4
-+++ b/m4macros/ax_cpp11.m4
-@@ -182,6 +182,7 @@
- AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [#include <thread>
-+ #include <memory>
- std::shared_ptr<std::thread> th;],
- [th.reset(new std::thread([[]]() { return; }));
- th->join();])],
---- a/src/bin/perfdhcp/Makefile.am
-+++ b/src/bin/perfdhcp/Makefile.am
-@@ -3,7 +3,6 @@
- AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
- AM_CPPFLAGS += -I$(top_srcdir)/src/bin -I$(top_builddir)/src/bin
- AM_CPPFLAGS += $(BOOST_INCLUDES)
--AM_CPPFLAGS += -Werror
-
- AM_CXXFLAGS = $(KEA_CXXFLAGS)
-
---- a/src/bin/perfdhcp/tests/Makefile.am
-+++ b/src/bin/perfdhcp/tests/Makefile.am
-@@ -4,7 +4,6 @@
- AM_CPPFLAGS += -I$(srcdir)/.. -I$(builddir)/..
- AM_CPPFLAGS += -DTEST_DATA_DIR=\"$(abs_srcdir)/testdata\"
- AM_CPPFLAGS += $(BOOST_INCLUDES)
--AM_CPPFLAGS += -Werror
- AM_CXXFLAGS = $(KEA_CXXFLAGS)
-
- if USE_STATIC_LINK
---- a/src/lib/database/backend_selector.cc
-+++ b/src/lib/database/backend_selector.cc
-@@ -7,6 +7,7 @@
- #include <database/backend_selector.h>
- #include <exceptions/exceptions.h>
- #include <climits>
-+#include <limits>
- #include <sstream>
-
- using namespace isc::data;
---- a/src/lib/dhcpsrv/subnet_id.h
-+++ b/src/lib/dhcpsrv/subnet_id.h
-@@ -10,6 +10,7 @@
- #include <exceptions/exceptions.h>
- #include <stdint.h>
- #include <typeinfo>
-+#include <limits>
-
- namespace isc {
- namespace dhcp {