summaryrefslogtreecommitdiff
path: root/net-misc/openrsync
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openrsync')
-rw-r--r--net-misc/openrsync/Manifest4
-rw-r--r--net-misc/openrsync/files/openrsync-0.5.0_p20220508-extern-stdint-include.patch11
-rw-r--r--net-misc/openrsync/metadata.xml11
-rw-r--r--net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild40
4 files changed, 66 insertions, 0 deletions
diff --git a/net-misc/openrsync/Manifest b/net-misc/openrsync/Manifest
new file mode 100644
index 000000000000..a24a01361fd1
--- /dev/null
+++ b/net-misc/openrsync/Manifest
@@ -0,0 +1,4 @@
+AUX openrsync-0.5.0_p20220508-extern-stdint-include.patch 162 BLAKE2B fe8c67b12602e56d162bfe84f939253135b325a3eb273c87139705e7cdd720570102043a96a4f61bff762971ec8468382e671ccc67248cbbd8afa87d3f66fac9 SHA512 0d5cbe3bfbce3e0264c9e3b83b9c57a5130a1779eec225deb98ac549977b9cdc147a67e3fd031b38faf862d5529754af6a67a5f484d070ba4f26f17b8a6746b6
+DIST openrsync-0.5.0_p20220508.tar.gz 139218 BLAKE2B 2ff7614a10095d01ac46f92281d8e22dd8bd03c943324d4f5eff0f3cd981a5e97a8ce8ee361f8dbd144229c39d29ad33035a704c7e0e753d66eb72ec65c92bed SHA512 f2fec287d57502e3b478652a7c91c38e295221f936eb089f8ecd9efd69e51e0b9896e6f9d5457195db8d4661faf461c34d2d1547373ba5ddae22a5f7135677e9
+EBUILD openrsync-0.5.0_p20220508.ebuild 901 BLAKE2B 1f16de2383f68452df015c4edd50e1a428e56453de242efa9984cfaf8bc2488443b8df540a6d3de3ed1787f1537da64024adec913e1eaf5609b2c6126d958424 SHA512 cd664d73a327227998e10f3beb92124ed9d6d3c1429b97d7f7219002878a174315e110a06beb2a96273c26bd82f86715979032fe45cff668559717b75a94c4d2
+MISC metadata.xml 325 BLAKE2B 92469ad0379f831dde4cc90f4c1cf29dfd20a30ce3604745e537f8b8b5c526891af243ad79a66f856bc1b8816d7a31fb3d945bb361a718f93c4b5a3136a4b9bb SHA512 eee3e66063873c21680e1ea3b45f00a5fa50362194450a26a81fc1e8ab6403c60dfb25af5cce6293aef87c9427bba2d0f23ef66ca13090727e615bd029b87e1c
diff --git a/net-misc/openrsync/files/openrsync-0.5.0_p20220508-extern-stdint-include.patch b/net-misc/openrsync/files/openrsync-0.5.0_p20220508-extern-stdint-include.patch
new file mode 100644
index 000000000000..ea2af659fad2
--- /dev/null
+++ b/net-misc/openrsync/files/openrsync-0.5.0_p20220508-extern-stdint-include.patch
@@ -0,0 +1,11 @@
+--- a/extern.h
++++ b/extern.h
+@@ -17,6 +17,8 @@
+ #ifndef EXTERN_H
+ #define EXTERN_H
+
++#include <stdint.h>
++
+ #if !HAVE_PLEDGE
+ # define pledge(x, y) (1)
+ #endif
diff --git a/net-misc/openrsync/metadata.xml b/net-misc/openrsync/metadata.xml
new file mode 100644
index 000000000000..93a67ab8e286
--- /dev/null
+++ b/net-misc/openrsync/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kristapsdz/openrsync</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild b/net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild
new file mode 100644
index 000000000000..bfbf341c0781
--- /dev/null
+++ b/net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="BSD-licensed implementation of rsync"
+HOMEPAGE="https://www.openrsync.org/"
+
+if [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT="f50d0f8204ea18306a0c29c6ae850292ea826995"
+ SRC_URI="https://github.com/kristapsdz/openrsync/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+else
+ SRC_URI="https://github.com/kristapsdz/openrsync/archive/refs/tags/VERSION_$(ver_rs 3 _).tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.0_p20220508-extern-stdint-include.patch
+)
+
+src_configure() {
+ tc-export CC
+
+ local confargs=(
+ PREFIX="${EPREFIX}"/usr
+ MANDIR="${EPREFIX}"/usr/share/man
+ )
+
+ edo ./configure "${confargs[@]}"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}