summaryrefslogtreecommitdiff
path: root/net-misc/pedro/pedro-1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pedro/pedro-1.6.ebuild')
-rw-r--r--net-misc/pedro/pedro-1.6.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/net-misc/pedro/pedro-1.6.ebuild b/net-misc/pedro/pedro-1.6.ebuild
index 428ab0412b8a..68f35cb0e6f4 100644
--- a/net-misc/pedro/pedro-1.6.ebuild
+++ b/net-misc/pedro/pedro-1.6.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="Pedro is a subscription/notification communications system"
HOMEPAGE="http://www.itee.uq.edu.au/~pjr/HomePages/PedroHome.html"
SRC_URI="http://www.itee.uq.edu.au/~pjr/HomePages/PedroFiles/${P}.tgz
doc? ( mirror://gentoo/${PN}-manual-${PV}.tar.gz )"
+S="${WORKDIR}"/${P}
LICENSE="GPL-2"
SLOT="0"
@@ -14,11 +17,20 @@ KEYWORDS="amd64 ppc x86"
IUSE="doc examples"
RDEPEND="dev-libs/glib:2"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
-S="${WORKDIR}"/${P}
+PATCHES=(
+ "${FILESDIR}"/${P}-portage.patch
+)
-PATCHES=( "${FILESDIR}/${P}-portage.patch" )
+src_configure() {
+ tc-export PKG_CONFIG
+
+ default
+}
src_install() {
default