summaryrefslogtreecommitdiff
path: root/net-misc/proxytunnel
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/proxytunnel')
-rw-r--r--net-misc/proxytunnel/Manifest4
-rw-r--r--net-misc/proxytunnel/metadata.xml4
-rw-r--r--net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild48
-rw-r--r--net-misc/proxytunnel/proxytunnel-9999.ebuild45
4 files changed, 98 insertions, 3 deletions
diff --git a/net-misc/proxytunnel/Manifest b/net-misc/proxytunnel/Manifest
index e7498b7c8a05..c62ada3a21a0 100644
--- a/net-misc/proxytunnel/Manifest
+++ b/net-misc/proxytunnel/Manifest
@@ -1,4 +1,6 @@
AUX proxytunnel-allowTLS.patch 592 BLAKE2B 2c48bb1a1c2e2374043d9bc73e653a5f87f5bbda6a64a5572cbe3bdafe533205f619b7248c8f7b6cecf7de8c72940a6ccf64e054c5419e9ba656f773e9d7d346 SHA512 67b0103054c56c69cd9c0d1aa144498151f105004b400bcdbbb3df519d37424630554e101e5617faf075fd978edddfc4d06cca7524c51e28cd33c1165b6a22f9
DIST proxytunnel-1.9.1.tar.gz 48025 BLAKE2B 5a844d8fdbb9a1eae9c40c7621086b873ae89813b7c596da4416efcb777a8110ad7d224a0efa2e193cfbbb82dbfe69d44d4dd36db080b8e902630a464a85b953 SHA512 819dd11bc13fc279d2d475b89909c0eea414ff71d772d4bfed742dd8d425669dc502f2c22d983bb8c58e426a2bc7209526cb21492ca5f8e92ea1b9ea961fcfdc
EBUILD proxytunnel-1.9.1-r1.ebuild 1062 BLAKE2B 456dd113a2b48783723fdb5493e891db17654ae9a7fc4bdf5bb6254ae46d1c6f059df4c42a17f82fba569cd84496d3cc3a6f1f95b3353d379eccdfff25641187 SHA512 8bc963c149db9d497a969d6f24b3cedd64d0a9d099d94825cf85b89415e98d9b11defc545f424dd1366aa1c28f089692f2efd0f8bc3e488341d7b09bdddf1518
-MISC metadata.xml 722 BLAKE2B 577965e10bc1b8d5c67a892fc50ea97721bc122accbece1b3f42eecdd505add994c74b7d9aa6fc66710af6893389c4ebe1dd4b44ac64d5fbf2e0c2aab6b75a97 SHA512 b51f63b3865144d4a4f21f851d7316ebab5e2c194e5019333ce80d6df7f41bf1b9217ba864dafbc8db7569a89a22861fc0a6bd07664040172e472fe9de00c7eb
+EBUILD proxytunnel-1.9.1-r2.ebuild 1158 BLAKE2B 3f5a88d370e82f690cb1a109d963a7b9a1442c8b8f3516a92a2ebe274a9dbbb7f05d5748a074afbc35fa0d6c54f99a1937e02b7726a670a18e7c42c9a6ab077b SHA512 aa7bc374946215f40263f9f868b160d181b26e858db5d23d3909e8e0415dbffb50a484e827a3b1f0237122edc5c6017bc4dc92ebd0fa9e97139ea905c9a4503c
+EBUILD proxytunnel-9999.ebuild 1110 BLAKE2B bf3f8dac9a9c63691cf961f2ad29d335c872df7cef1680ac1acfe6119628214214d329cdbe981248bc77ad0ec826b1ca97eacdbb0f1859c04ef203f92f875977 SHA512 92b3595da31853468a24aa0d5468d2d26e2d03e5851c695b2d4445c50d06faa4c4ce0d21a54f70824c5ae5e539ba09b520e62da0633fba4f98c725e882a63870
+MISC metadata.xml 717 BLAKE2B da3b819d7e0caeee376359837cf0a6294eee0363ad857369816fbf595e6add90666feeea356a9864d71a3987f7393ac7483bd4fe800bae67364291da420a2c39 SHA512 ecf80d876bccd3c2c98cb6a46e543e6adbe5a52a1666b6678cd86def313593d5200189f67cec5d85150e7a308139089786c416ee0a2d6bfe58d800b0fc7a18da
diff --git a/net-misc/proxytunnel/metadata.xml b/net-misc/proxytunnel/metadata.xml
index faa64f120cb8..9dec21f8f5a2 100644
--- a/net-misc/proxytunnel/metadata.xml
+++ b/net-misc/proxytunnel/metadata.xml
@@ -2,8 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>vikraman@gentoo.org</email>
- <name>Vikraman Choudhury</name>
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
</maintainer>
<longdescription lang="en">
ProxyTunnel is a program that connects stdin and stdout to a server
diff --git a/net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild b/net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild
new file mode 100644
index 000000000000..c3a2f9493841
--- /dev/null
+++ b/net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Connect stdin and stdout to a server via an HTTPS proxy"
+HOMEPAGE="https://github.com/proxytunnel/proxytunnel/ https://proxytunnel.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl:="
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ "
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGES CREDITS INSTALL KNOWN_ISSUES LICENSE.txt README RELNOTES TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-allowTLS.patch
+)
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+src_prepare() {
+ default
+ sed -i -e 's/libssl/libssl libcrypto/' Makefile || die "Sed failed!"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake install prefix="${EPREFIX}"/usr DESTDIR="${D}" || die
+ einstalldocs
+}
diff --git a/net-misc/proxytunnel/proxytunnel-9999.ebuild b/net-misc/proxytunnel/proxytunnel-9999.ebuild
new file mode 100644
index 000000000000..16a4a63d0bb9
--- /dev/null
+++ b/net-misc/proxytunnel/proxytunnel-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Connect stdin and stdout to a server via an HTTPS proxy"
+HOMEPAGE="https://github.com/proxytunnel/proxytunnel/ https://proxytunnel.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl:="
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ "
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGES CREDITS INSTALL KNOWN_ISSUES LICENSE.txt README RELNOTES TODO )
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+src_prepare() {
+ default
+ sed -i -e 's/libssl/libssl libcrypto/' Makefile || die "Sed failed!"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake install prefix="${EPREFIX}"/usr DESTDIR="${D}" || die
+ einstalldocs
+}