summaryrefslogtreecommitdiff
path: root/net-misc/socat
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/socat')
-rw-r--r--net-misc/socat/Manifest1
-rw-r--r--net-misc/socat/socat-1.7.4.4-r1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/socat/Manifest b/net-misc/socat/Manifest
index 634c92efb9e2..93f493f4e6ab 100644
--- a/net-misc/socat/Manifest
+++ b/net-misc/socat/Manifest
@@ -1,5 +1,6 @@
DIST socat-1.7.4.3.tar.gz 655520 BLAKE2B d91de7ef55332001e6439f64130555b9558338fb9b6c15c91ab5efc8f86a2e7e0f5fe0b292754731a198d83be5f511c3388c65c7c7f559c55691f42703f1849b SHA512 81cb34c245052b6a0ae38a711591358460b6070957af4a9eeb11a3cadb4aff184eeaedabbc7ecdc7fdf21a6126c06f90f19b24a87ce74b30bfd60a3879181046
DIST socat-1.7.4.4.tar.bz2 522127 BLAKE2B 221b1c7c1ef0ac9c2402a6917ce7740a7ed857ceae4f4c346ed3c69c261fd0f9ca667e21cab5f97427d3947b06fdb0ac6d090852465878db968a24b8ece587ad SHA512 3eedfbf599ecf1d6fd391d03d710044bc5e18a762395bc4cb151b96fe673d405a6630da3070ecddd5ac558126b56aa65feaa74d528eeb755a04aa0ec61690651
EBUILD socat-1.7.4.3.ebuild 1846 BLAKE2B 51b7d2f01afd4efec5338d1d38aa53dc287f8493424206b0d1a60ad86b0e250c209a82b61164a6b3d2768c5619d94b9b216ae8cec55541f3a276795d2f523201 SHA512 3958922ef28097cdca8ee392c1e45e7947603e6bbd3fa397055145f00fb94728b762c59fab722d7b25b33298f073d08f05bdc82f3634c6c2cc56c687fda3e320
+EBUILD socat-1.7.4.4-r1.ebuild 1218 BLAKE2B f438f70287b53c7b601efaaff57778b6ce97479c52e7af618db075942548baa87a923f51b9186f6fc81579a5270fce31941280533e70f955829d341b87739ba0 SHA512 3428aaf66c246f5efefcbdd757838d10879ec5bcda52b296e7a1132a5326aa5789f8fa774ed26330acb2da658903582a001819231117dfffda04a55d9021d035
EBUILD socat-1.7.4.4.ebuild 1516 BLAKE2B d2a2be258287e57b9b8b62db14870a2b3871e5498d6a15b835d183888c088e12265d4602912cdc3408121df9fec1de1226e3812f45dfee6d21c4d153ec4b9ed6 SHA512 4de4667635deb2d4d139e5a3dcf9e7fc324a2bdffb277bdb303af659202a73cb45275dc1ecdbba6deedb9368c5a4be63c651453c0347942c244c217040e70edc
MISC metadata.xml 468 BLAKE2B 3b8eb979af07fe02eac29cbb79d6da3782adf46025c072e03026bd765c562ddb7ae18dff9f162b18f9f9a07fa5fff3b3fda9a4445c9dc75d65d4395abc0de217 SHA512 0c3b9355c7420ea8bba4932c9c5f457393e0b7719fa65e5f9cd05ce38209d8cf8ab3e4401b8608a62fc8277742cf2b8728b9718b1183b634cfd596cedbe353aa
diff --git a/net-misc/socat/socat-1.7.4.4-r1.ebuild b/net-misc/socat/socat-1.7.4.4-r1.ebuild
new file mode 100644
index 000000000000..26ff914b02af
--- /dev/null
+++ b/net-misc/socat/socat-1.7.4.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P=${P/_beta/-b}
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="ipv6 readline ssl tcpd"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )
+ readline? ( sys-libs/readline:= )
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}"
+
+# Tests are a large bash script
+# Hard to disable individual tests needing network or privileges
+# in 1.7.4.2: FAILED: 59 329
+RESTRICT="test"
+
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
+
+src_configure() {
+ # bug #293324
+ filter-flags '-Wno-error*'
+
+ tc-export AR
+
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc doc/*.html doc/*.css
+}