summaryrefslogtreecommitdiff
path: root/net-misc/youtube-dl/youtube-dl-99999999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/youtube-dl/youtube-dl-99999999.ebuild')
-rw-r--r--net-misc/youtube-dl/youtube-dl-99999999.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/net-misc/youtube-dl/youtube-dl-99999999.ebuild b/net-misc/youtube-dl/youtube-dl-99999999.ebuild
index f30b1cfa0a04..e5aaeb99e391 100644
--- a/net-misc/youtube-dl/youtube-dl-99999999.ebuild
+++ b/net-misc/youtube-dl/youtube-dl-99999999.ebuild
@@ -1,28 +1,32 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{6,7,8}})
inherit bash-completion-r1 distutils-r1 git-r3 readme.gentoo-r1
DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="https://github.com/ytdl-org/youtube-dl/"
-EGIT_REPO_URI="${HOMEPAGE}"
+EGIT_REPO_URI="https://github.com/ytdl-org/youtube-dl/"
LICENSE="public-domain"
KEYWORDS=""
-RESTRICT="test"
SLOT="0"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
+IUSE="test"
RDEPEND="
- ${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
|| (
dev-python/pycryptodome[${PYTHON_USEDEP}]
dev-python/pycrypto[${PYTHON_USEDEP}]
)
"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
src_compile() {
distutils-r1_src_compile
@@ -30,6 +34,10 @@ src_compile() {
emake ${PN}.{bash-completion,fish,zsh}
}
+python_test() {
+ emake offlinetest
+}
+
python_install_all() {
dodoc README.md