summaryrefslogtreecommitdiff
path: root/net-misc/youtube-dl
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest2
-rw-r--r--net-misc/youtube-dl/youtube-dl-2019.02.18.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index de00727912c1..c0fdb93188c2 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,4 +1,6 @@
DIST youtube-dl-2019.02.08.tar.gz 3104780 BLAKE2B e89a9950de84c3d2c5530ca229f2dfb39bb372454a6a1d67c0d1c966f68f2372008556ffda32c042eca6d3c0aee3ace0c1cabdf1d65cb16efc80326b821a3624 SHA512 4fc027ec6d9d7059c34a3c16f1265989ec000c131e6a937f667928531dd2a6d9f56592d367f08ec5e3b1900b3e191aa36bcc997db04b77b95850a43ed1272640
+DIST youtube-dl-2019.02.18.tar.gz 3114830 BLAKE2B f948fc68d9bc2b7e400d22b4d2980b7f56bf734476a54b3e30b6ee33d5e4a0950233dfd74b0db26108a5759e3589acde4fe104d41ea856c88f68e165f330132b SHA512 86a321003b9e0bdc852294c8ac75d601141177f3469330c6ab01fa821758ee848dfcdf0e9dd514ca2da7b7e3c2a7f2dcddab9929f7fa8be2ab3c86d6eccbd5e3
EBUILD youtube-dl-2019.02.08.ebuild 2021 BLAKE2B a7fe20e586f2d3243069237315e89ad05ff23c1684854a4029111c30622f23a8ba0c73325bb3a98f6fdc76203afd3ae4246ae62e0cfdc02c281188d3b1e25e40 SHA512 c589d6d581b2a91443ba9def42b278ed427bebc45a02b25a053dbb556c23dc299b5a8873540679394863a1ca2a3da929d27b779e467c0269707600fea55a7e7a
+EBUILD youtube-dl-2019.02.18.ebuild 2027 BLAKE2B 028f1bd62a12ad5b2b20eeaaf83e63c3dc765c0fd220ec2a187844993159f449b631a7e5c5d0b80977545e7ed47c9c452b3492c5001ce78c0452a69207120b8b SHA512 ce09e4ee4e17b44a51581d252ae5bda890d22168c612785033abd9297ea8be0409845b25a175775ddc64d9dbee0dd9324a2494df6316b4a41837fd4e8f483b23
EBUILD youtube-dl-99999999.ebuild 1916 BLAKE2B 035ac8f58fec97b741be4d080401d6dea03531c95ef61782dcad898f51b2fe845d97ede3ddb4ac3ae52c327fb08d5729b41a1c057e8fb6c81e81afc3d87c4651 SHA512 ae1467fcc2b1bde3b33354a61e29b311a6d8876cbd0502186f55f0826c0182ea21afb229b34b39b37c9e625bb142d86348baa31dc0defc01e19beb427de40321
MISC metadata.xml 218 BLAKE2B 717fcfd86a1f75e0ad21845c9b496cf01d7bc7c80b6be8c08143ea304a08fbb75352e82e8fc883398e96da9c037f8912c4a9612b5cf85ffb25b3a5f041b02fe2 SHA512 d36d668a636222ce6394eca2598850e68139819543fd3cf0e76301e2a61c9b9303026b49536d1ed1b52f44d5703dc5e4247df786e0b4a704b28872e0a4a71b27
diff --git a/net-misc/youtube-dl/youtube-dl-2019.02.18.ebuild b/net-misc/youtube-dl/youtube-dl-2019.02.18.ebuild
new file mode 100644
index 000000000000..2cb0551f3e35
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2019.02.18.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+RESTRICT="test"
+SLOT="0"
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}