summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/Manifest.gzbin54464 -> 54448 bytes
-rw-r--r--net-misc/curl/Manifest1
-rw-r--r--net-misc/curl/files/curl-8.0.1-onion-resolution.patch158
-rw-r--r--net-misc/dhcpcd-ui/Manifest1
-rw-r--r--net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch13
-rw-r--r--net-misc/frr/Manifest1
-rw-r--r--net-misc/frr/files/frr-openrc-v1301
7 files changed, 0 insertions, 475 deletions
diff --git a/net-misc/Manifest.gz b/net-misc/Manifest.gz
index 6d80624067bf..707f56039903 100644
--- a/net-misc/Manifest.gz
+++ b/net-misc/Manifest.gz
Binary files differ
diff --git a/net-misc/curl/Manifest b/net-misc/curl/Manifest
index 7333d5c31c11..3517adf33ccd 100644
--- a/net-misc/curl/Manifest
+++ b/net-misc/curl/Manifest
@@ -1,4 +1,3 @@
-AUX curl-8.0.1-onion-resolution.patch 4036 BLAKE2B 7f9a693f5090585c46d596133e915b67cf6a0b0a78ee164f987de166f24fb3d64a968f6263110c119710735363429447d52e5cc52df90d0f3830cf0e10c3673b SHA512 72efe3cd6d594cd2b73a19596e587c88a7ca89ed6f9a7325df98df2e18a1e85f26232ea48e80097d2d1e2f8db2c1cd945896311cd70ee830c8838afbcb7628d9
AUX curl-8.3.0-CVE-2023-38545.patch 4345 BLAKE2B b3519d1fdccecf40e9a49cd96bf61e53c2a8ab44b2ca05543ea431da6a00125ccc9b6f7cdde0371db30e741b19a8c86cc90038987750744d2f02a0b1c1f0bec0 SHA512 1b0d3f4d4475bf4d579d4a99504a1e488b4a64e956497dc9558206234f67c60a6006ec9c93df89dc5b18c8d60312877838564adbcb834af5d6389f2f7be856d8
AUX curl-8.3.0-CVE-2023-38546.patch 4852 BLAKE2B 316a6ca5a05c55ffa029aa97ad9c23844bf9dce2a0220cdce324c678baa8f1bfef6dcb21a6460c80345d2fe81e7738055d207a76e3d0c920c6bbb827869b02c5 SHA512 1a0d047c9c661d39caf4f4f47177aa804b8b8689f68f1f14e83163ce311b5783b58ae3d216e84dbec6bf93b6b0ba7a838831121282702e613ab4c00c1874730d
AUX curl-8.3.0-tests-arm-musl.patch 3472 BLAKE2B 6722ff38b03191a9c26b90b9a2d4dc9d439cfb0d7227e10f1f100bec4a4d8709878bfab89ef9cfa854955dd44462eef66b8eb3a31db75b4555d9eccaa4457729 SHA512 3beaf54c017c9c13e023bdcaa7e187b1689f988ff2837c2e9a998ed9e7beb850e8baf9dafb0a506b60018b853c8039763d59f2849f1772a8bc8b63843111d769
diff --git a/net-misc/curl/files/curl-8.0.1-onion-resolution.patch b/net-misc/curl/files/curl-8.0.1-onion-resolution.patch
deleted file mode 100644
index 65b486529c1f..000000000000
--- a/net-misc/curl/files/curl-8.0.1-onion-resolution.patch
+++ /dev/null
@@ -1,158 +0,0 @@
-https://bugs.gentoo.org/887287
-https://github.com/curl/curl/pull/10705
-
-From e2bbd1adc22ec5033e2292b780e1790db93c3cb4 Mon Sep 17 00:00:00 2001
-From: Matt Jolly <Matt.Jolly@footclan.ninja>
-Date: Wed, 8 Mar 2023 02:16:45 +1100
-Subject: [PATCH] Refuse to resolve the .onion TLD.
-
-RFC 7686 states that:
-
-> Applications that do not implement the Tor
-> protocol SHOULD generate an error upon the use of .onion and
-> SHOULD NOT perform a DNS lookup.
-
-Let's do that.
-
-See curl/curl#543
-https://www.rfc-editor.org/rfc/rfc7686#section-2
---- a/docs/KNOWN_BUGS
-+++ b/docs/KNOWN_BUGS
-@@ -80,7 +80,6 @@ problems may have been fixed or changed somewhat since this was written.
- 10.3 FTPS over SOCKS
-
- 11. Internals
-- 11.1 Curl leaks .onion hostnames in DNS
- 11.2 error buffer not set if connection to multiple addresses fails
- 11.4 HTTP test server 'connection-monitor' problems
- 11.5 Connection information when using TCP Fast Open
-@@ -525,14 +524,6 @@ problems may have been fixed or changed somewhat since this was written.
-
- 11. Internals
-
--11.1 Curl leaks .onion hostnames in DNS
--
-- Curl sends DNS requests for hostnames with a .onion TLD. This leaks
-- information about what the user is attempting to access, and violates this
-- requirement of RFC7686: https://datatracker.ietf.org/doc/html/rfc7686
--
-- Issue: https://github.com/curl/curl/issues/543
--
- 11.2 error buffer not set if connection to multiple addresses fails
-
- If you ask libcurl to resolve a hostname like example.com to IPv6 addresses
---- a/lib/hostip.c
-+++ b/lib/hostip.c
-@@ -652,6 +652,14 @@ enum resolve_t Curl_resolv(struct Curl_easy *data,
- CURLcode result;
- enum resolve_t rc = CURLRESOLV_ERROR; /* default to failure */
- struct connectdata *conn = data->conn;
-+ /* We should intentionally error and not resolve .onion TLDs */
-+ size_t hostname_len = strlen(hostname);
-+ if(hostname_len >= 7 &&
-+ (curl_strequal(&hostname[hostname_len-6], ".onion") ||
-+ curl_strequal(&hostname[hostname_len-7], ".onion."))) {
-+ failf(data, "Not resolving .onion address (RFC 7686)");
-+ return CURLRESOLV_ERROR;
-+ }
- *entry = NULL;
- #ifndef CURL_DISABLE_DOH
- conn->bits.doh = FALSE; /* default is not */
---- a/tests/data/Makefile.inc
-+++ b/tests/data/Makefile.inc
-@@ -186,8 +186,8 @@ test1432 test1433 test1434 test1435 test1436 test1437 test1438 test1439 \
- test1440 test1441 test1442 test1443 test1444 test1445 test1446 test1447 \
- test1448 test1449 test1450 test1451 test1452 test1453 test1454 test1455 \
- test1456 test1457 test1458 test1459 test1460 test1461 test1462 test1463 \
--test1464 test1465 test1466 test1467 test1468 test1469 test1470 \
--\
-+test1464 test1465 test1466 test1467 test1468 test1469 test1470 test1471 \
-+test1472 \
- test1500 test1501 test1502 test1503 test1504 test1505 test1506 test1507 \
- test1508 test1509 test1510 test1511 test1512 test1513 test1514 test1515 \
- test1516 test1517 test1518 test1519 test1520 test1521 test1522 test1523 \
---- /dev/null
-+++ b/tests/data/test1471
-@@ -0,0 +1,39 @@
-+<testcase>
-+<info>
-+<keywords>
-+Onion
-+Tor
-+FAILURE
-+</keywords>
-+</info>
-+#
-+# Server-side
-+<reply>
-+</reply>
-+
-+#
-+# Client-side
-+<client>
-+<server>
-+none
-+</server>
-+<name>
-+Fail to resolve .onion TLD
-+</name>
-+<command>
-+red.onion
-+</command>
-+</client>
-+
-+#
-+# Verify data after the test has been "shot"
-+<verify>
-+# Couldn't resolve host name
-+<errorcode>
-+6
-+</errorcode>
-+<stderr mode="text">
-+curl: (6) Not resolving .onion address (RFC 7686)
-+</stderr>
-+</verify>
-+</testcase>
---- /dev/null
-+++ b/tests/data/test1472
-@@ -0,0 +1,39 @@
-+<testcase>
-+<info>
-+<keywords>
-+Onion
-+Tor
-+FAILURE
-+</keywords>
-+</info>
-+#
-+# Server-side
-+<reply>
-+</reply>
-+
-+#
-+# Client-side
-+<client>
-+<server>
-+none
-+</server>
-+<name>
-+Fail to resolve .onion. TLD
-+</name>
-+<command>
-+tasty.onion.
-+</command>
-+</client>
-+
-+#
-+# Verify data after the test has been "shot"
-+<verify>
-+# Couldn't resolve host name
-+<errorcode>
-+6
-+</errorcode>
-+<stderr mode="text">
-+curl: (6) Not resolving .onion address (RFC 7686)
-+</stderr>
-+</verify>
-+</testcase>
-
diff --git a/net-misc/dhcpcd-ui/Manifest b/net-misc/dhcpcd-ui/Manifest
index fbba90d8f620..0217bc165097 100644
--- a/net-misc/dhcpcd-ui/Manifest
+++ b/net-misc/dhcpcd-ui/Manifest
@@ -1,4 +1,3 @@
-AUX dhcpcd-ui-0.7.9-respect-qmake-args.patch 316 BLAKE2B 4015a89728f68685c46268ac86af761e060ce40e1232e088478e9f29defca5ac6a9834161c8c8503e11df04bd583cea97940078156f3945bd14c17ce2354c8e7 SHA512 950d56277d934661136f236b5d402d427a47932238c37242048f2d093a1ad67aa2c30106c9ee9b828b9f958f81dcefa51d3db3ffdad1cbde6d6a0c4f862744b3
DIST dhcpcd-ui-0.7.8.tar.xz 135028 BLAKE2B f3e79bb00708e2ce2ebb93d917506bb0fb015071b415768c47979d7f2b5e35d6f22bf71a58c43989dedc6561f0a8be738824f06627d2fa0995e335d7ef1925cd SHA512 5f0d2c32c32fc141feca0ab43a531d9b4f45e071a8a1e3ee1923d6394a3e5d6322e6f7e607b91154af4cfee93d649164c7ed3b805731dfc242c3ac367ec156c4
DIST dhcpcd-ui-0.7.9.tar.xz 104100 BLAKE2B 7e2bbbb9ad657deccc16296a0c7191f35fa15dbc84f1f8ac4f8ac5de4c56e5948da457398409527774ffc62e58659cac2dd37aa66842179f710db04a9791ab9e SHA512 fe0c9ff2f777e7b97438eb50507fce765b8e18b1a71883d76e9b6570a18e6f13414f8e64d8034f9c3352496775c283a0540e331ec449d6fbe48ddc8d64e14691
EBUILD dhcpcd-ui-0.7.8.ebuild 1317 BLAKE2B 9184c0a56b1163f7ddf4a2de6f84bf6a3ee3b0d25029686aa55c1a8f4ed00a318ca586bde1b5798ca2c42afbe5979d098a997eb0e9e9ea517384f97aab0036f8 SHA512 d19ab69d655ae6886654cc69fb49a2ec5b8bd2c07d66fc62f92806e6ce437f5425783ed365dac7f91c05a6dd8fbf7b1780f8b65ed9a8171523f088fe57c7dee8
diff --git a/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch b/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch
deleted file mode 100644
index 2ed516048e5d..000000000000
--- a/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/configure b/configure
-index ec61c80..9372b38 100755
---- a/configure
-+++ b/configure
-@@ -230,7 +230,7 @@ if [ -n "$LDFLAGS" ]; then
- echo "LDFLAGS=" >>$CONFIG_MK
- echo "LDFLAGS+= $LDFLAGS" >>$CONFIG_MK
- fi
--QMAKE_CONFIG=
-+#QMAKE_CONFIG
-
- for x in $INCLUDEDIR; do
- echo "CPPFLAGS+= -I$x" >>$CONFIG_MK
diff --git a/net-misc/frr/Manifest b/net-misc/frr/Manifest
index ac0fc0a7b7ac..94eaeb750b09 100644
--- a/net-misc/frr/Manifest
+++ b/net-misc/frr/Manifest
@@ -1,6 +1,5 @@
AUX frr-7.5-ipctl-forwarding.patch 731 BLAKE2B 9c97d7fdc7b7facb59a73f4b693c285ebd91cb0ba8f7fea0ef49d5eddd8660100315ca7d74ece8d553cdd8ad79a9a0b1a4c173c6dedf90e0be2bdc72d948b2be SHA512 56bdeb8a1f350fea3ad8ed0cdba28964b00384878853e584746d8ce80c6f9ea5ca5adc4539e314f7fd82203c08d5f2ce6adeec61dac9a7a28282131d0d371447
AUX frr-8.4.1-logrotate.patch 2487 BLAKE2B f3eb9b9ce25dd9dd796668ecef5dfeb51b5f3ea3428ef4c03bd78becaf26deb5cb59aa56918fdc3c0230a8905d7edf4a12582ab4e6f7d297e3c94c62b7468b0c SHA512 8658dd1280d201d9f3a7f8caa6c5bf513133a3928ba97334202b0fed84dc03f12c82d76cbb8aeae3f363024d2373161c9bda74e1d9a27a085071c524c9941ad0
-AUX frr-openrc-v1 7078 BLAKE2B d5c0276540fa09318f6e92575dd7e03f3bc6ebfce186d062c2d65fa49c502b3b4de0fd32914ce7c4708bb6f6188296f75d387e0384c142381bb77cfb706c7e1c SHA512 8e6f0e58863402f0169b8a7625d049bf85db60bebe40a42dfb450a1bddfcd6f8f436002de6c1ff599c8f848e4ba85a70e4058cb55a9a49fafb1e69a8e7eb9f57
AUX frr-openrc-v2 7079 BLAKE2B abbad56f0715b79ba5ba24df373ccb8ab63caa12b04d892693b060c771d47323fd7fcebd9b5688720d4aded23fcb79a36e89a7734b315b0862d16e5ce08d8b10 SHA512 5744c433fd983a56abb8f45e34229b3ab3a03c3e9d5532e2b30a31f3e875076fb56b81a06e661dba7df9f76e463190e831c82ae79deefe1add22d7f0365098ce
AUX frr.pam 969 BLAKE2B 227dc91f51fab504229fa5489486fed1aa393d33c024849724ea3fb934e3fd78ee6c9147240133d458ec52021f13e8a27a2d8a0b4625415007c4595222b815ee SHA512 9a169d58232eba7481aee83d92b4e104b6c4ca95e5b31befe29117fbcebc187ad87c061f37ec7c571ff5702101a329ae0c113cf714e2d0dcd39ca4212734a9ed
DIST frr-9.0.1.tar.gz 10334150 BLAKE2B c5f0d092421cdaea400e669973da3d53d9875871488be3b5e8c2c9afa78bf357a775671756eacb94372c5067a8a1284cb4feb4927988e0f1a42d19239a871f3b SHA512 fa1884529a98c8e5ad2dab7f6f67246844ea34ba4d68e3a907a01d43e0eec9317104107f5f18e4b61c11d2cbb4d20eac1e8aef6e4a2b2e54efcad245ee3fb6b9
diff --git a/net-misc/frr/files/frr-openrc-v1 b/net-misc/frr/files/frr-openrc-v1
deleted file mode 100644
index 3f9da62e2a18..000000000000
--- a/net-misc/frr/files/frr-openrc-v1
+++ /dev/null
@@ -1,301 +0,0 @@
-#!/sbin/openrc-run
-#
-# FRR OpenRC init script.
-#
-# Copyright (C) 2020 Rafael F. Zalamena
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; only version 2 of the License.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-description="FRR initialization script."
-
-# FRR variables.
-frr_dir="/usr/lib/frr"
-frr_state_dir="/run/frr"
-config_file="/etc/frr/frr.conf"
-daemon_file="/etc/frr/daemons"
-daemon_db="/run/frrdb"
-vty_config_file="/etc/frr/vtysh.conf"
-frr_reload="$frr_dir/frr-reload.py"
-frr_reload_log="$frr_state_dir/reload.log"
-
-# Don't change profile here, use $daemon_file. This is the default.
-frr_profile="traditional"
-
-# watchfrr variables.
-watchfrr_daemons=''
-watchfrr_pidfile="$frr_state_dir/watchfrr.pid"
-
-#
-# Helpers.
-#
-_check_daemon_binary() {
- local daemon=$1
-
- [ -x "$frr_dir/$daemon" ] && return 0
-
- eerror "No binary found for $daemon in $frr_dir"
- return 1
-}
-
-_load_daemon_list() {
- # Load FRR daemons configuration file.
- while read line <&3 ; do
- case $line in
- ""|"#"*)
- # Skip empty/commented lines.
- continue
- ;;
-
- *d=*|*_instances=*|*_options=*|*_wrap=*)
- # Load daemon options.
- eval "$line"
- ;;
-
- MAX_FDS=*|frr_profile=*|vtysh_enable=*)
- # Load misc configuration.
- eval "$line"
- ;;
- esac
- done 3< $daemon_file
-
- # `zebra` and `staticd` are mandatory.
- _check_daemon_binary 'zebra' || return 1
- _check_daemon_binary 'staticd' || return 1
- watchfrr_daemons='zebra staticd'
-
- # Create the watchfrr command line.
- for daemon in \
- babeld bfdd bgpd eigrpd fabricd isisd ldpd nhrpd ospfd ospf6d pbrd \
- pimd ripd ripngd sharpd vrrpd \
- ; do
- # Trick to read variable name with variable.
- cdaemon=$(eval echo \$$daemon)
- cdaemon_instances=$(eval echo \$${daemon}_instances)
-
- # Add daemon to command line if specified.
- if [ ! -z $cdaemon ] && [ $cdaemon = 'yes' ]; then
- _check_daemon_binary $daemon || return 1
-
- # Multi instance daemon handling.
- if [ ! -z $cdaemon_instances ]; then
- for instance in $(echo $cdaemon_instances | tr ',' ' '); do
- watchfrr_daemons="$watchfrr_daemons $daemon-$instance"
- done
- continue
- fi
-
- # Single instance daemon handling.
- watchfrr_daemons="$watchfrr_daemons $daemon"
- continue
- fi
- done
-}
-
-_frr_start() {
- # Apply MAX_FDS configuration if set.
- if [ ! -z $MAX_FDS ]; then
- veinfo " Setting maximum file descriptors to ${MAX_FDS}"
- ulimit -n $MAX_FDS >/dev/null 2>/dev/null
- fi
-
- # Save started daemons to state database.
- rm -f -- $daemon_db
- for daemon in $watchfrr_daemons; do
- echo $daemon >> $daemon_db
- veinfo " Starting $daemon..."
- done
-
- veinfo " Starting watchfrr..."
-
- # Start watchfrr which will start all configured daemons.
- eval $all_wrap $frr_dir/watchfrr -d -F $frr_profile $watchfrr_daemons
-
- veinfo " Loading configuration..."
-
- # After starting the daemons, lets load the configuration.
- if [ $vtysh_enable = 'yes' ]; then
- vtysh -b -n
- else
- veinfo " Configuration loading disabled (vtysh_enable=$vtysh_enable)"
- fi
-}
-
-_get_pid() {
- local daemon=$1
- local pid_file="$frr_state_dir/$daemon.pid"
-
- # Test for file existence.
- if [ ! -r "$pid_file" ]; then
- eerror "Failed to find or read $daemon pid file"
- return 1
- fi
-
- # Get PID if any.
- pid=$(cat $pid_file)
- if [ -z $pid ]; then
- eerror "$daemon PID file empty"
- return 1
- fi
-
- return 0
-}
-
-_stop_daemon() {
- local daemon=$1
- local pid_file="$frr_state_dir/$daemon.pid"
-
- # Get daemon pid.
- _get_pid $daemon
-
- # Ask daemon to quit.
- kill -2 "$pid"
-
- # Test if daemon is still running.
- attempts=1200
- while kill -0 "$pid" 2>/dev/null; do
- sleep 0.5
- [ $((attempts - 1)) -gt 0 ] || break
- done
-
- # Tell user about our situation.
- if kill -0 "$pid" 2>/dev/null ; then
- eerror "Failed to stop $daemon (PID=${pid})"
- return 1
- else
- rm -f -- $pid_file
- fi
-}
-
-_frr_stop() {
- local failures=0
-
- # Stop watchfrr first so it doesn't restart anyone.
- veinfo " Stopping watchfrr..."
- _stop_daemon watchfrr || failures=1
-
- # Read started daemon database.
- while read line <&3 ; do
- case $line in
- ""|"#"*)
- # Skip empty/commented lines.
- continue
- ;;
-
- *)
- # Get daemon name.
- veinfo " Stopping $line..."
- _stop_daemon $line || failures=1
- ;;
- esac
- done 3< $daemon_db
-
- # Remove daemon database file.
- rm -f -- $daemon_db
-
- return $failures
-}
-
-_check_watchfrr() {
- _get_pid watchfrr || return 1
- return 0
-}
-
-#
-# Main.
-#
-depend() {
- # We need root to write logs.
- need localmount
- # Optionally wait for network to start.
- use net
- # Expect /run to be ready.
- after bootmisc
-}
-
-start_pre() {
- # Check configuration file readability.
- checkpath -f -m 0640 -o frr:frr $vty_config_file
- checkpath -f -m 0640 -o frr:frr $daemon_file
- checkpath -f -m 0640 -o frr:frr $config_file
-
- # Check run state directory.
- checkpath -d -o frr $frr_state_dir
-
- # Load daemon list and peform checks.
- _load_daemon_list
-}
-
-start() {
- # Load daemon list.
- _load_daemon_list
-
- # Handle restarts.
- if [ "$RC_CMD" = 'restart' ]; then
- ebegin 'Reloading FRR configuration'
- else
- ebegin 'Starting FRR'
- fi
-
- # Start FRR.
- _frr_start
-
- # New daemons and watchfrr started, apply new configuration.
- if [ "$RC_CMD" = 'restart' ]; then
- "$frr_reload" --reload "$config_file" 2>/run/frr/reload.log
- [ $? -ne 0 ] && ewarn " Failed to reload (check $frr_reload_log)"
- # NOTE: we can't return bad status otherwise OpenRC will think we
- # failed to start, lets print a helpful message instead.
- fi
-
- eend 0
-}
-
-stop() {
- local failures=0
-
- # Handle restarts.
- if [ "$RC_CMD" = 'restart' ]; then
- # Load daemon list.
- _load_daemon_list
-
- # We must restart 'watchfrr' in order to start new daemons.
- veinfo " Stopping watchfrr..."
- _stop_daemon watchfrr
-
- # Stop daemons that are no longer in configuration file.
- for daemon in $(ls -1 /run/frr/*.pid | cut -d '.' -f 1); do
- # Filter daemon name.
- daemon=$(basename "$daemon")
-
- # Skip watchfrr.
- [ "$daemon" = 'watchfrr' ] && continue
-
- echo "$watchfrr_daemons" | grep "$daemon" >/dev/null
- if [ $? -ne 0 ]; then
- veinfo " Stopping $daemon..."
- _stop_daemon $daemon
- fi
- done
-
- return 0
- fi
-
- ebegin 'Stopping FRR'
- _frr_stop || failures=1
- eend $failures 'some daemons failed to stop'
-}
-
-status() {
- _check_watchfrr || return 1
-}