summaryrefslogtreecommitdiff
path: root/net-nntp
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/Manifest.gzbin1372 -> 1370 bytes
-rw-r--r--net-nntp/sabnzbd/Manifest2
-rw-r--r--net-nntp/sabnzbd/sabnzbd-4.4.1.ebuild180
3 files changed, 182 insertions, 0 deletions
diff --git a/net-nntp/Manifest.gz b/net-nntp/Manifest.gz
index 185674a47c5c..559c73745b0b 100644
--- a/net-nntp/Manifest.gz
+++ b/net-nntp/Manifest.gz
Binary files differ
diff --git a/net-nntp/sabnzbd/Manifest b/net-nntp/sabnzbd/Manifest
index de24ba23dc7c..5854b8353e9a 100644
--- a/net-nntp/sabnzbd/Manifest
+++ b/net-nntp/sabnzbd/Manifest
@@ -3,5 +3,7 @@ AUX sabnzbd-r1.initd 1391 BLAKE2B 1ff6d3dc4f5ece413cf1c0ab104b23c3a4ab451d5cda28
AUX sabnzbd.confd 156 BLAKE2B 8cd006eedf4f6614fa00ad9bfee6411dbfb99e1e487c19c4b314b3a7a12742ae4da5de93d771f3fb11a8c2ff5a7eef8fc1b879c1d85757ce218d9357037a70d6 SHA512 91915b54b6e2c2dc7839c23726aba7982b158b20a813ad0f66fa879d2454db14e24472e57e076b41866b28c7cd3991f9961c114b17dfc7e37322b23aa1e6c468
AUX sabnzbd_at.service 185 BLAKE2B bedc84a8dec50c230bd2d4041d3e56dd33fdd7814488e3a6b53fbb8e0c7df2100ac13ee746e4b6cd45b384acfe6a9478df3a3d1f75bfc70dc41f51ac8f018916 SHA512 e5e6882c8520d26c21583fd2b9895248a777fa7519dc3588726dcccf689f81d604f2ef883681e54f6b212a51a8d8e690570ab60742d8b0232af73e98d61d6d34
DIST SABnzbd-4.3.3-src.tar.gz 5108172 BLAKE2B 668c2c13da3039f2ca34a2d67a1b06a6cb831a27b3bf997bdba674e1830a01837561b67a97d802a4ae2018085e7491489c87398801e0413e3006911620c4e324 SHA512 9b4bd35b1c44c9dc03a83319450b71043f4ffcf7c680e5d206ed51157d0fc69376065d0a5cec7dd144bfca9eaa1932bb7d2fc984dea5cacd8361c91ad701e8f2
+DIST SABnzbd-4.4.1-src.tar.gz 5114314 BLAKE2B 2cd96635b35c23ca4a34534ac2133b33fe414ae5037ebaebd8d6cf57da38d04fd26ffcac52fe72f8893483328ffc229cdc3a98d293e5976453b33128eb743a70 SHA512 a0fa34bc6abafa0cd0aacf51ca4527c2fa2bf1a38e8e7fd03417a66621c54eae493cdcb03697bdd0e6c010f30f002290362b6aa0f62f4ef67693a80af5c39bbf
EBUILD sabnzbd-4.3.3.ebuild 6097 BLAKE2B 6d7bfd7830bcf01c60cf416ba027f6159774f6f36763b3febb7a2f8fbbaf4da49d9a5efdf74b288c11f0e4165b12eea355af5d2396faab7d76c275a8e36fd9cf SHA512 7b1097426aad0967ebfb1b49605dc54676aabc54df8c37cfe4c7b6273a09a61749f0f1f8f5702509e9597747c67b9c260857811df5958fea0bb84fa37fd0824e
+EBUILD sabnzbd-4.4.1.ebuild 6158 BLAKE2B 03ba6c9c4c29508a8b62d1ed830cd79e13800db6c637565a8d6d4bea8e881f6a189750a3813667c0d92f9bccce0b306df4c00feb7fdc230de81e3659edcc87ec SHA512 47ec4971c38f367aaf8f15b12bfc53157a3811bff000ec81296358fb1478b8b2b4fcc8aaab0fd2509b5b133b48d8d0be3a65f9c7183d3a5bc04d1accf4bba245
MISC metadata.xml 463 BLAKE2B 90b3702d7d29524a2f0c450d757fa35178211816fbf04661251a257d681d0af7ca7020f920e51fb1ae380fa24c5dd473588ae8ea42f1eb4982246c903872becd SHA512 ea4d26003fa929bc21a5678633a8df6cf76a6ce4dc4a6c33c15207e41fd147e94e2632dfcf3c1bfd46467920d8c46a667ec83fe71caa1347a5da2b798dffc329
diff --git a/net-nntp/sabnzbd/sabnzbd-4.4.1.ebuild b/net-nntp/sabnzbd/sabnzbd-4.4.1.ebuild
new file mode 100644
index 000000000000..26f113c0fba0
--- /dev/null
+++ b/net-nntp/sabnzbd/sabnzbd-4.4.1.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+#dev-python/tavern needs py3.13 before incrementing
+PYTHON_COMPAT=( python3_{11..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit optfeature python-single-r1 systemd
+
+MY_PV="${PV/_alpha/Alpha}"
+MY_PV="${MY_PV/_beta/Beta}"
+MY_PV="${MY_PV/_rc/RC}"
+
+MY_P="SABnzbd-${MY_PV}"
+
+DESCRIPTION="Binary newsgrabber with web-interface"
+HOMEPAGE="https://sabnzbd.org/"
+SRC_URI="https://github.com/sabnzbd/sabnzbd/releases/download/${MY_PV}/${MY_P}-src.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+# Sabnzbd is GPL-2 but bundles software with the following licenses.
+LICENSE="GPL-2 BSD LGPL-2 MIT BSD-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ acct-user/sabnzbd
+ acct-group/sabnzbd
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/apprise-1.8.0[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/cheetah3-3.4.0[${PYTHON_USEDEP}]
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-6.0.11[${PYTHON_USEDEP}]
+ >=dev-python/guessit-3.8.0[${PYTHON_USEDEP}]
+ dev-python/notify2[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/puremagic[${PYTHON_USEDEP}]
+ ~dev-python/sabctools-8.2.5[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ >=app-arch/par2cmdline-0.8
+ >=app-arch/par2cmdline-turbo-1.1.0
+ )
+ net-misc/wget
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyfakefs-5.6.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/tavalidate[${PYTHON_USEDEP}]
+ >=dev-python/tavern-2[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ ')
+ app-arch/p7zip
+ app-arch/unrar
+ app-arch/unzip
+ www-apps/chromedriver-bin
+ )
+"
+
+src_test() {
+ local EPYTEST_IGNORE=(
+ # network sandbox
+ tests/test_getipaddress.py
+ tests/test_rss.py
+ tests/test_urlgrabber.py
+ tests/test_utils/test_happyeyeballs.py
+ tests/test_utils/test_internetspeed.py
+ )
+ local EPYTEST_DESELECT=(
+ # network sandbox
+ 'tests/test_cfg.py::TestValidators::test_validate_host'
+ 'tests/test_consistency.py::TestWiki'
+ 'tests/test_newswrapper.py::TestNewsWrapper'
+ 'tests/test_happyeyeballs.py::TestHappyEyeballs'
+ 'tests/test_internetspeed.py::TestInternetSpeed'
+ # Just plain fails
+ 'tests/test_newsunpack.py::TestPar2Repair::test_basic'
+ # Does not work with pytest-8.x
+ 'tests/test_functional_api.py'
+ # Chromedriver tests don't want to behave in portage
+ 'tests/test_functional_config.py::TestBasicPages::test_base_pages'
+ 'tests/test_functional_config.py::TestBasicPages::test_base_submit_pages'
+ 'tests/test_functional_config.py::TestConfigLogin::test_login'
+ 'tests/test_functional_config.py::TestConfigCategories::test_page'
+ 'tests/test_functional_config.py::TestConfigRSS::test_rss_basic_flow'
+ 'tests/test_functional_config.py::TestConfigServers::test_add_and_remove_server'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_basic_rar5'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_zip'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_7zip'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_passworded'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_fully_obfuscated'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_unicode_rar'
+ 'tests/test_functional_misc.py::TestShowLogging::test_showlog'
+ 'tests/test_functional_misc.py::TestQueueRepair::test_queue_repair'
+ 'tests/test_functional_misc.py::TestDaemonizing::test_daemonizing'
+ 'tests/test_functional_sorting.py::TestDownloadSorting'
+ # Bug https://bugs.gentoo.org/934331 fixed in 4.3.3.
+ 'tests/test_sorting.py::TestSortingSorter'
+ # cryptography-43, https://bugs.gentoo.org/938453
+ 'tests/test_utils/test_cert_gen.py::TestCertGen::test_generate_key_custom[512-test_key.pem]'
+ )
+
+ # The test suite is prone to being broken by random plugins that happen
+ # to be installed, so disable autoloading.
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # Use PYTEST_PLUGINS instead of args to 'epytest' because the test suite
+ # calls pytest itself and the args would get lost. To get the list of plugins,
+ # if stuck, comment out the AUTOLOAD line above, look at the list of loaded
+ # plugins at the top of the pytest output, then translate those into module names
+ # by e.g. checking equery f.
+ local -x PYTEST_PLUGINS=pytest_mock,tavern,tavern._core.pytest,pyfakefs.pytest_plugin,pytest_asyncio.plugin
+
+ epytest -s
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r email icons interfaces locale po sabnzbd scripts tools
+
+ exeinto /usr/share/${PN}
+ doexe SABnzbd.py
+
+ python_fix_shebang "${ED}"/usr/share/${PN}
+ python_optimize "${ED}"/usr/share/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-r1.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ diropts -o ${PN} -g ${PN}
+ dodir /etc/${PN}
+ keepdir /var/log/${PN}
+
+ insinto "/etc/${PN}"
+ insopts -m 0600 -o "${PN}" -g "${PN}"
+ newins "${FILESDIR}"/${PN}-r1.ini ${PN}.ini
+
+ dodoc ISSUES.txt README.mkd
+
+ systemd_newunit "${FILESDIR}"/sabnzbd_at.service 'sabnzbd@.service'
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ einfo "Default directory: /var/lib/${PN}"
+ einfo
+ einfo "To add a user to the sabnzbd group so it can edit SABnzbd+ files, run:"
+ einfo
+ einfo " usermod -a -G sabnzbd <user>"
+ einfo
+ einfo "By default, SABnzbd will listen on TCP port 8080."
+ fi
+
+ optfeature "7z archive support" app-arch/p7zip
+ optfeature "rar archive support" app-arch/unrar app-arch/rar
+ optfeature "zip archive support" app-arch/unzip
+}