summaryrefslogtreecommitdiff
path: root/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/bitcoind/bitcoind-0.16.3.ebuild')
-rw-r--r--net-p2p/bitcoind/bitcoind-0.16.3.ebuild28
1 files changed, 8 insertions, 20 deletions
diff --git a/net-p2p/bitcoind/bitcoind-0.16.3.ebuild b/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
index 86589b99be5e..74b734ed258c 100644
--- a/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
@@ -4,7 +4,7 @@
EAPI=6
DB_VER="4.8"
-inherit autotools bash-completion-r1 db-use systemd user
+inherit autotools bash-completion-r1 db-use systemd
BITCOINCORE_COMMITHASH="49e34e288005a5b144a642e197b628396f5a0765"
KNOTS_PV="${PV}.knots20180918"
@@ -20,10 +20,12 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE="+asm +bitcoin_policy_rbf examples knots libressl test upnp +wallet zeromq"
+IUSE="+asm examples knots libressl test upnp +wallet zeromq"
RESTRICT="!test? ( test )"
DEPEND="
+ acct-group/bitcoin
+ acct-user/bitcoin
>=dev-libs/boost-1.52.0:=[threads(+)]
dev-libs/libevent:=
>=dev-libs/libsecp256k1-0.0.0_pre20151118:=[recovery]
@@ -51,19 +53,9 @@ pkg_pretend() {
elog "For more information, see:"
elog "https://bitcoincore.org/en/2018/09/18/release-${PV}/"
fi
- if use bitcoin_policy_rbf; then
- elog "Replace By Fee policy is enabled: Your node will preferentially mine and"
- elog "relay transactions paying the highest fee, regardless of receive order."
- else
- elog "Replace By Fee policy is disabled: Your node will only accept the first"
- elog "transaction seen consuming a conflicting input, regardless of fee"
- elog "offered by later ones."
- fi
-}
-
-pkg_setup() {
- enewgroup bitcoin
- enewuser bitcoin -1 -1 /var/lib/bitcoin bitcoin
+ elog "Replace By Fee policy is now always enabled by default: Your node will"
+ elog "preferentially mine and relay transactions paying the highest fee, regardless"
+ elog "of receive order. To disable RBF, set mempoolreplacement=never in bitcoin.conf"
}
src_prepare() {
@@ -82,10 +74,6 @@ src_prepare() {
eapply_user
- if ! use bitcoin_policy_rbf; then
- sed -i 's/\(DEFAULT_ENABLE_REPLACEMENT = \)true/\1false/' src/validation.h || die
- fi
-
echo '#!/bin/true' >share/genbuild.sh || die
mkdir -p src/obj || die
echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
@@ -123,7 +111,7 @@ src_configure() {
src_install() {
default
- rm -f "${ED%/}/usr/bin/test_bitcoin" || die
+ rm -f "${ED}/usr/bin/test_bitcoin" || die
insinto /etc/bitcoin
newins "${FILESDIR}/bitcoin.conf" bitcoin.conf