summaryrefslogtreecommitdiff
path: root/net-p2p/bittornado
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/bittornado')
-rw-r--r--net-p2p/bittornado/Manifest1
-rw-r--r--net-p2p/bittornado/bittornado-0.4.1_p20160925-r4.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-p2p/bittornado/Manifest b/net-p2p/bittornado/Manifest
index db2a7c70e4cb..85ef50e6472b 100644
--- a/net-p2p/bittornado/Manifest
+++ b/net-p2p/bittornado/Manifest
@@ -3,4 +3,5 @@ AUX bttrack.rc 519 BLAKE2B 829b1a4cdb29bae41e25e832d7383ea4fda3ec2473d6d9bebc273
DIST BitTornado-0.4.1_p20160925.tar.gz 164352 BLAKE2B 34cebe27ab0cb18a960ef830311ffa47f2064c83768a9a011dcd9e45e9460b60438e159824eaf9cf844d7c5604a9de832e6a85cea3335d9e6223c31e7b349014 SHA512 09971cc5705c421c4440cd51b9aa37da9f8ce992a882d342c0547fe1771199fa61c4924f6d6cd321776f9dcefafd3e244b9cbfce047c4cdd4502dd0a1a1fdaaa
EBUILD bittornado-0.4.1_p20160925-r2.ebuild 1436 BLAKE2B 7b6926352072848ba683c977771c3a77673161a5c7a40494b5e3d799e0c864faa99af78f84c1cff0f5f8ddc1cdf1a25dfc033ff191e70949a63642f837086905 SHA512 5c0b9da4dcd356f6b93117c88f6c8b46507929867e90ba68df5d32572b3b8df6ed16b175790d11b432f59caf329c37bd1886fd6b3d8aced900fb6b62e0d8abe4
EBUILD bittornado-0.4.1_p20160925-r3.ebuild 1500 BLAKE2B 2ee5fca1f37d69f59abf1faa1ebd1c43a35f3991c58d5ebb8afcde85707096c07a45a7b742f73b97a73c6c41b7234441e2843c4a242ba0bbfe033b8c0439d3d7 SHA512 00bfe7d7d31dc735279c0af8cae63b9300e276775dfba3217cd6d90b62f549011cd10e8a50ca1f63d9a71d6dbfa59a5f2fa54a96a2b90101f3ed4ff69904af28
+EBUILD bittornado-0.4.1_p20160925-r4.ebuild 1511 BLAKE2B 3c43c892d1d04d8754c7e9472a1b1000f42ffec6b999a6d314402ff34f7f6092c70cdcf5731b321ceca03923a6cf88932d6b13061df6444b2b4c0d13a3ba572e SHA512 224bbd8b6b75ca3e92294004d6d682db5ec9476d18ae41b18e980ef9bb5b3e2031e6962721ea5a567cf66b522018824da5fbce5acbb221d35b1c95f4d7d7fede
MISC metadata.xml 251 BLAKE2B 2e57f7e8625022d92e5ff0f4ea468077072bf9de6a293b4b3626fc3f6bfa2c34cc1a4a07a2db9c1a5255fb524144a5d8c232e29a331169fee5303274ff5c59fd SHA512 92e2c6c337d3a54187195c333ae1fc7f7dddccad31a4a077037949d81ef125bc2b776cc65db09f1de5cef8bc47faae8dad17696db1ab85c9d81fb02a8cc17f2d
diff --git a/net-p2p/bittornado/bittornado-0.4.1_p20160925-r4.ebuild b/net-p2p/bittornado/bittornado-0.4.1_p20160925-r4.ebuild
new file mode 100644
index 000000000000..255fd674ce84
--- /dev/null
+++ b/net-p2p/bittornado/bittornado-0.4.1_p20160925-r4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+MY_PN=BitTornado
+MY_P=${MY_PN}-${PV}
+EGIT_COMMIT="ed327c4e1ebbe1fe949be81723527cfda87aeb8d"
+
+DESCRIPTION="John Hoffman's fork of the original bittorrent"
+HOMEPAGE="https://github.com/effigies/BitTornado"
+SRC_URI="https://github.com/effigies/BitTornado/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+# GPL-2 is just for the init script from FILESDIR.
+LICENSE="MIT GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha amd64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+# Block dev-python/pytest-testmon for bug #693508.
+DEPEND="
+ test? (
+ !!dev-python/pytest-testmon
+ )
+"
+
+S=${WORKDIR}/${MY_PN}-${EGIT_COMMIT}
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # https://github.com/effigies/BitTornado/pull/53
+ sed -e 's:"BitTornado.Tracker":\0, "BitTornado.Types":' -i setup.py || die
+ find "${S}" -name '*.py' -print0 | \
+ xargs --null -- \
+ sed -r -i '
+ s:time.clock\(\):time.perf_counter():g;
+ s:collections.(MutableSet|Set|Sequence|Mapping):collections.abc.\1:g
+ ' || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest BitTornado/tests
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newconfd "${FILESDIR}"/bttrack.conf bttrack
+ newinitd "${FILESDIR}"/bttrack.rc bttrack
+}