summaryrefslogtreecommitdiff
path: root/net-p2p/torrentinfo/torrentinfo-1.8.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/torrentinfo/torrentinfo-1.8.7.ebuild')
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.7.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.7.ebuild
new file mode 100644
index 000000000000..34117dc5b487
--- /dev/null
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A torrent file parser"
+HOMEPAGE="https://github.com/Fuuzetsu/torrentinfo"
+SRC_URI="https://github.com/Fuuzetsu/torrentinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ # https://github.com/Fuuzetsu/torrentinfo/pull/16
+ "${FILESDIR}/${PN}-1.8.6-fix-tests.patch"
+ # https://github.com/Fuuzetsu/torrentinfo/pull/18
+ "${FILESDIR}/${PN}-1.8.6-remove-nose.patch"
+)
+
+distutils_enable_tests pytest