summaryrefslogtreecommitdiff
path: root/net-p2p/xnap
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/xnap')
-rw-r--r--net-p2p/xnap/Manifest3
-rw-r--r--net-p2p/xnap/metadata.xml13
-rw-r--r--net-p2p/xnap/xnap-2.5-r3.ebuild32
3 files changed, 48 insertions, 0 deletions
diff --git a/net-p2p/xnap/Manifest b/net-p2p/xnap/Manifest
new file mode 100644
index 000000000000..bcc439a5bb34
--- /dev/null
+++ b/net-p2p/xnap/Manifest
@@ -0,0 +1,3 @@
+DIST xnap-2.5r3.jar 1320779 BLAKE2B ed5103e4371aa9bc96cb1610c9fcdfcf8177ffcbe8c1801f2130e6e5ac9bd7fdb0b91c8bca8fd3e411f72b3dd6cd7284a6fab8da35c026385347c6a64a21e2d5 SHA512 6dcfc7b6d56c86a8a2e554b67449c60c784033cdc8962613dc0e4555b9139c71c7cc958f40b2a5a14e60c4abfde747b5ba9868a358837ceee3b730af34cf5f69
+EBUILD xnap-2.5-r3.ebuild 609 BLAKE2B e9ca818a43eaf43967a0a7b3a654b847002423e65110f195670f39d45e8e50edb4f890849d3585ffd29f7624cb460a1f7d8c6e4f19e98cda04a4f84cc2247c89 SHA512 fe9847fdb5a0b37c9bb58f3cb77fea78ffee95b9725afb85e3f3c33909f9242619c57775bb4685381e35a560b8e0cf42a2dcff4667cffcca7dd4472112aa14f2
+MISC metadata.xml 676 BLAKE2B 7c001310cd973732c3bd57d15a4199d59e74bd65b5eb8ed4fb9919704ae5fbdb5a727b483002f145153d33182545672e1313fd6d1b5ccd44d5b289c3e7e71b98 SHA512 60ea34fc1d512f325b5fb05cbfc99fe7ae8934e1c744dd17709a7067bc9fd7ff0d245c3e6597e43a9d5065b83904aad19d1820283f566fd41a62e816bf39104e
diff --git a/net-p2p/xnap/metadata.xml b/net-p2p/xnap/metadata.xml
new file mode 100644
index 000000000000..c1b47035759d
--- /dev/null
+++ b/net-p2p/xnap/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ XNap provides a plugin enabled framework for peer-to-peer (P2P) applications and a client which is based on that framework. It is free software and licensed under the GNU Public License .
+
+ XNap is purely written in Java. The client features a modern Swing based user interface and console support that will run nicely on every platform with a recent Java Runtime Environment (1.3 or higher).
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xnap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-p2p/xnap/xnap-2.5-r3.ebuild b/net-p2p/xnap/xnap-2.5-r3.ebuild
new file mode 100644
index 000000000000..c77d4e4539f6
--- /dev/null
+++ b/net-p2p/xnap/xnap-2.5-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+DESCRIPTION="A P2P framework and client"
+HOMEPAGE="http://xnap.sf.net"
+SRC_URI="mirror://sourceforge/xnap/${P}r3.jar"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+RDEPEND=">=virtual/jre-1.3"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp ${DISTDIR}/${A} ${WORKDIR}/
+}
+
+src_install() {
+ mv ${S}/${A} ${S}/${PN}.jar
+ insinto /opt/${PN}/lib
+ doins ${PN}.jar
+
+ echo "#!/bin/sh" > ${PN}
+ echo "cd /opt/${PN}" >> ${PN}
+ echo '${JAVA_HOME}'/bin/java -jar lib/${PN}.jar '$*' >> ${PN}
+
+ into /opt
+ dobin ${PN}
+}