summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Manifest.gzbin6755 -> 6751 bytes
-rw-r--r--net-p2p/biglybt/Manifest2
-rw-r--r--net-p2p/biglybt/biglybt-3.7.0.0.ebuild108
3 files changed, 110 insertions, 0 deletions
diff --git a/net-p2p/Manifest.gz b/net-p2p/Manifest.gz
index af572c97c0fc..46d6f14aa401 100644
--- a/net-p2p/Manifest.gz
+++ b/net-p2p/Manifest.gz
Binary files differ
diff --git a/net-p2p/biglybt/Manifest b/net-p2p/biglybt/Manifest
index a7faa90863df..b3a324088116 100644
--- a/net-p2p/biglybt/Manifest
+++ b/net-p2p/biglybt/Manifest
@@ -4,5 +4,7 @@ AUX biglybt-3.5.0.0-Entities.javadoc.patch 1378 BLAKE2B 0984fcc6d342a3b54129b019
AUX biglybt-3.6.0.0-disable-PluginUpdatePlugin.patch 1374 BLAKE2B 9f2e72b24e20db59ba57df5591e3a722b114b697f6bd4c872c5a2b41eae1310d03489c03c353748cb877735a698e3ee5bced62809ab2bf30f8bf7609be9e07a2 SHA512 dd4dc70157685acdcd0e4c4e61058367489ef4081fc027c858a31af85e5b84432d2146c7a4742ff644ae6bf79a60e2c08d5a68590829c66c008a490c9cb04247
AUX biglybt-3.6.0.0-fix-ambiguous.patch 572 BLAKE2B 931cc112671559a05420be81ba41cbdfc40ff28ea255f1af7789ae558a7c8c7b7b8fe9f4d5fceea43a54eab0f2a0c6da4ff99ed97fb1c3a663ab7c5999316691 SHA512 38c49b47952832d9be3a793c0ab2f50051bbf729df51c8ce55308830d5982431b60b7a96cc1f9ebd4b4dec388d38b766e35562358fed50dbf345c3e8c79d995d
DIST biglybt-3.6.0.0.tar.gz 43972902 BLAKE2B 76995d3d5f24f054690e609d2be7bd822f6c8573b6627bcf380c3a93be86265f4ca827c2991db65ef39c9f3f79b0cd8e0aebce492571a36bf237c95fc3d6cc54 SHA512 b56beb006ab813efa2ab2aff8563a04675e677ea70fe6ef72062e2d38ec753749b36740ae87f851739cb1389948a916273cb6ffb65758e651d0701a7f6237afd
+DIST biglybt-3.7.0.0.tar.gz 44021778 BLAKE2B 9ce54062b298d2e47f9fcc88a3fa8da935c7d3c4ad24f28cf2975300b78140b547e3e43c377cae50fd1276d49d53a43bc77e36957133dc6fe1fa7e301ebe80fe SHA512 815ce2f2b327de266650d9650dcbc539247dca2a8bce727ca0a4fc6eb7dfbcee770ffce04dd3b96aef458df1ee20ce39229f6a3d409725a532d081c82d4504bd
EBUILD biglybt-3.6.0.0-r3.ebuild 3072 BLAKE2B 0ec4692ea5073d5fb19abf3c2d67645e70a96d97ac345f0916be33718bac21e54440aba0c43a2b2dad1569f859555f2ab25281cf370b30191a6d1fa71e886ced SHA512 7f54629997baf7b75923e7b642df95518ccbc9894cc7fce6421e4476f2ac63da000aaedb980e6cbfc90f32da2202acec87b9af1271bef9371811d50212d2fa70
+EBUILD biglybt-3.7.0.0.ebuild 3468 BLAKE2B 50eb1ce3b2ebfe8294a0ab78ae90abc4ea4c51348367ca739675cdfc7fb8d5f9e52f0680b414044052020a7a3e5490c68e3db8a9afa5b2eb180d377b43ff7795 SHA512 bff0370ff5ffb206ad72ac99101a542b288a8635dd11b6772a24f55dcac00ca0fa47c24bc232d8bb29effe54cb4106cbfbe4e38450a073643a0719e989fb420c
MISC metadata.xml 904 BLAKE2B fd6313faad9aa5140a1110c0fbb53fb5b220e33cdf8c0c59d8a96ed6b424d67cb1922537543b0c7bfdf6fdced2d9273b963db5e7126b0f9d9c61404d4774ea60 SHA512 5106049f93d633214a67dfa9bc52d721911bd7c7c08f36dc8dd2cc052121929c0d95483138685877a6cbbe152be58ec8165320b06a3f1bd78f9f625af2d55c1b
diff --git a/net-p2p/biglybt/biglybt-3.7.0.0.ebuild b/net-p2p/biglybt/biglybt-3.7.0.0.ebuild
new file mode 100644
index 000000000000..78bc7fda2552
--- /dev/null
+++ b/net-p2p/biglybt/biglybt-3.7.0.0.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# javadocs are too broken and no tests, #839681
+JAVA_PKG_IUSE="source"
+MAVEN_PROVIDES="com.${PN}:${PN}-core:${PV} com.${PN}:${PN}-ui:${PV}"
+
+inherit desktop java-pkg-2 java-pkg-simple optfeature xdg
+
+DESCRIPTION="Feature-filled Bittorrent client based on the Azureus open source project"
+HOMEPAGE="https://www.biglybt.com"
+SRC_URI="https://github.com/BiglySoftware/BiglyBT/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/BiglyBT-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+CP_DEPEND="
+ dev-java/commons-cli:0
+ dev-java/swt:4.27[cairo]
+"
+
+# Due to removal of AENameServiceDescriptor it would fail to start under jdk:1.8
+# StartServer ERROR: unable to bind to 127.0.0.1:6880 listening for passed torrent info: \
+# sun.net.spi.nameservice.NameServiceDescriptor: Provider com.biglybt.core.util.spi.AENameServiceDescriptor not found
+DEPEND="${CP_DEPEND}
+ >=virtual/jdk-11:*"
+
+RDEPEND="${CP_DEPEND}
+ >=virtual/jre-1.8:*"
+
+DOCS=(
+ CODING_GUIDELINES.md
+ CONTRIBUTING.md
+ ChangeLog.txt
+ README.md
+ TRANSLATE.md
+)
+
+JAVA_GENTOO_CLASSPATH_EXTRA="target/classes"
+JAVA_JAR_FILENAME="BiglyBT.jar"
+JAVA_MAIN_CLASS="com.${PN}.ui.Main"
+JAVA_RESOURCE_DIRS=( {core,uis}/resources ) # yes, need them both
+JAVA_SRC_DIR="uis/src"
+
+PATCHES=(
+ "${FILESDIR}/biglybt-3.2.0.0-disable-SWTUpdateChecker.patch"
+ "${FILESDIR}/biglybt-3.2.0.0-disable-shared-plugins.patch"
+ "${FILESDIR}/biglybt-3.5.0.0-Entities.javadoc.patch"
+ "${FILESDIR}/biglybt-3.6.0.0-disable-PluginUpdatePlugin.patch"
+ "${FILESDIR}/biglybt-3.6.0.0-fix-ambiguous.patch"
+)
+
+src_prepare() {
+ default #780585
+ java-pkg-2_src_prepare
+ # AENameServiceDescriptor fails to compile with jdk >= 11
+ # "error: package sun.net.spi.nameservice does not exist"
+ # https://github.com/BiglySoftware/BiglyBT/pull/2611
+ rm -r core/src/com/biglybt/core/util/spi || die
+
+ # java-pkg-simple.eclass expects resources in a separate directory.
+ cp -r core/{src,resources} || die
+ rm -r core/resources/META-INF || die "deleting META-INF"
+ find core/resources -type f -name '*.java' -exec rm -rf {} + || die "core deleting *.java"
+ find core/resources -type f -name '.editorconfig' -exec rm -rf {} + || die "deleting .editorconfig"
+
+ cp -r uis/{src,resources} || die
+ find uis/resources -type f -name '*.java' -exec rm -rf {} + || die "uis deleting *.java"
+}
+
+src_compile() {
+ # build core classes, needed for compiling uis
+ ejavac -d target/classes \
+ -cp "$(java-pkg_getjars commons-cli):$(java-pkg_getjars swt-4.27)" \
+ $(find core/src -name "*.java") || die
+
+ java-pkg-simple_src_compile
+
+ # uis/src/com/biglybt/ui/swt/plugin/net/buddy/swt/BuddyPluginView.java:68:
+ # uis/src/com/biglybt/ui/swt/plugin/net/buddy/swt/BuddyPluginViewChat.java:45:
+ # uis/src/com/biglybt/ui/swt/plugin/net/buddy/swt/BuddyPluginViewInstance.java:75:
+ # error: package com.biglybt.ui.swt.plugin.net.buddy does not exist
+# use doc && JAVA_SRC_DIR=( {core,uis}/src ) ejavadoc
+}
+
+src_install() {
+ java-pkg-simple_src_install
+
+ make_desktop_entry "${PN}" BiglyBT "${PN}" "Network;FileTransfer"
+
+ if use source; then
+ java-pkg_dosrc "core/src/*"
+ java-pkg_dosrc "uis/src/*"
+ fi
+ default
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature_header "If you are using plugin proxies you might want to swap them for these native packages:"
+ optfeature "I2P SOCKS proxy" net-vpn/i2p net-vpn/i2pd
+ optfeature "TOR SOCKS proxy" net-vpn/tor
+}