summaryrefslogtreecommitdiff
path: root/net-voip/mumble/mumble-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip/mumble/mumble-9999.ebuild')
-rw-r--r--net-voip/mumble/mumble-9999.ebuild8
1 files changed, 1 insertions, 7 deletions
diff --git a/net-voip/mumble/mumble-9999.ebuild b/net-voip/mumble/mumble-9999.ebuild
index c6f9fc3576ea..2ddad477ef4d 100644
--- a/net-voip/mumble/mumble-9999.ebuild
+++ b/net-voip/mumble/mumble-9999.ebuild
@@ -16,14 +16,13 @@ if [[ "${PV}" == 9999 ]] ; then
# even if these components may not be compiled in
EGIT_SUBMODULES=(
'-*'
- themes/Mumble
3rdparty/FindPythonInterpreter
3rdparty/gsl
3rdparty/minhook
+ 3rdparty/opus
3rdparty/rnnoise-src
3rdparty/speexdsp
3rdparty/tracy
- opus
)
else
if [[ "${PV}" == *_pre* ]] ; then
@@ -124,11 +123,6 @@ src_configure() {
mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
fi
- # https://bugs.gentoo.org/879569
- # convert absolute install paths to relative paths to satisfy path assertions
- mycmakeargs+=( -DCMAKE_INSTALL_MANDIR="$(realpath --relative-to="${S}" "${ED}"/usr/share/man)" )
- mycmakeargs+=( -DCMAKE_INSTALL_DOCDIR="$(realpath --relative-to="${S}" "${ED}"/usr/share/doc/"${PF}")" )
-
# https://bugs.gentoo.org/832978
# fix tests (and possibly runtime issues) on arches with unsigned chars
append-cxxflags -fsigned-char