summaryrefslogtreecommitdiff
path: root/net-vpn/httptunnel
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/httptunnel')
-rw-r--r--net-vpn/httptunnel/Manifest4
-rw-r--r--net-vpn/httptunnel/files/httptunnel-3.3-fix_write_stdin.patch12
-rw-r--r--net-vpn/httptunnel/httptunnel-3.3-r2.ebuild30
-rw-r--r--net-vpn/httptunnel/metadata.xml5
4 files changed, 51 insertions, 0 deletions
diff --git a/net-vpn/httptunnel/Manifest b/net-vpn/httptunnel/Manifest
new file mode 100644
index 000000000000..a22f636fdf20
--- /dev/null
+++ b/net-vpn/httptunnel/Manifest
@@ -0,0 +1,4 @@
+AUX httptunnel-3.3-fix_write_stdin.patch 541 SHA256 11b9ebbd380054e2666a5efdf59a6f545c362e37ab838adc5e1c4b3fa7e845d7 SHA512 d8a0cf3319c31f67a7e7bdf097923d52c619aa39cf80e261475213c1fcfaf43297f2a797952bcee413ecc78e78c15f817bc6f783ed525b07940fbe053e49fb6b WHIRLPOOL 253993015351bd8fcb80accba66a6effee8cd1dcf8981a0082c073a3dcffb143c12190260f666d2f85799c9415db4cb93cd971d18a7f5bdb5b908689740e5c82
+DIST httptunnel-3.3.tar.gz 262749 SHA256 142f82b204876c2aa90f19193c7ff78d90bb4c2cba99dfd4ef625864aed1c556 SHA512 84503e27e84cd39441a7592d6446e30fce07a54b940e4398407dc105fabc6c8f96d3b5d05137d6dab22b2088c5b114728551337429748c900bd6fe7d6b6109e5 WHIRLPOOL 2a747d5c7b0feb563a055013a330d8842b7cddbb4864aa13c98a47aaadab04480c48ffe00a4a26c44a52fe9afd7820646307b4d815ee1038d65a1e2546c451d4
+EBUILD httptunnel-3.3-r2.ebuild 658 SHA256 6e4118388a4646aa5fb5c04bcd57ab3fd91d22be93c132b58336980c50f5d427 SHA512 06a39ab5fae75f191f9e9376905ba5053dac1f063c904a17c37fadc7362f3acd787082c3c99bb57f5f214f4707bddeadbbedea5641b92800beb6a92d98ac2b38 WHIRLPOOL d4e8f85d99cc04b43b85f400e14d131fc2e8d31342f94fa37ad10ee17a57f0411b79998ae0a71b3edf691792d327a65721670336cf812b822791fc3ecd8e3c40
+MISC metadata.xml 166 SHA256 2caff447f5bd2701d8456ada5cc633c41ef4373fa4bfeabeb73599d40bcc941b SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84 WHIRLPOOL 1ff70497eca6531f0e0614c72a19f4b8e5ff486a58d369f4f0b36308d1d6b01168f9da887740e3b9f536236be251d3fe05f904d27a9233a7cf613416ba882968
diff --git a/net-vpn/httptunnel/files/httptunnel-3.3-fix_write_stdin.patch b/net-vpn/httptunnel/files/httptunnel-3.3-fix_write_stdin.patch
new file mode 100644
index 000000000000..904df6f91159
--- /dev/null
+++ b/net-vpn/httptunnel/files/httptunnel-3.3-fix_write_stdin.patch
@@ -0,0 +1,12 @@
+diff -dur httptunnel-3.3/common.c httptunnel-3.3-fix_write_stdin/common.c
+--- httptunnel-3.3/common.c 2001-02-25 12:45:41.000000000 +0100
++++ httptunnel-3.3-fix_write_stdin/common.c 2007-06-20 21:38:54.000000000 +0200
+@@ -314,7 +314,7 @@
+
+ /* If fd == 0, then we are using --stdin-stdout so write to stdout,
+ * not fd. */
+- m = write_all (fd ? fd : 0, buf, (size_t)n);
++ m = write_all (fd ? fd : 1, buf, (size_t)n);
+ log_annoying ("write_all (%d, %p, %d) = %d", fd ? fd : 1, buf, n, m);
+ return m;
+ }
diff --git a/net-vpn/httptunnel/httptunnel-3.3-r2.ebuild b/net-vpn/httptunnel/httptunnel-3.3-r2.ebuild
new file mode 100644
index 000000000000..74bc2848e259
--- /dev/null
+++ b/net-vpn/httptunnel/httptunnel-3.3-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="httptunnel can create IP tunnels through firewalls/proxies using HTTP"
+HOMEPAGE="http://www.nocrew.org/software/httptunnel.html"
+SRC_URI="http://www.nocrew.org/software/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix_write_stdin.patch
+ tc-export CC
+}
+
+src_configure() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die
+}
diff --git a/net-vpn/httptunnel/metadata.xml b/net-vpn/httptunnel/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/net-vpn/httptunnel/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>