summaryrefslogtreecommitdiff
path: root/net-vpn/ocserv/ocserv-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/ocserv/ocserv-9999.ebuild')
-rw-r--r--net-vpn/ocserv/ocserv-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-vpn/ocserv/ocserv-9999.ebuild b/net-vpn/ocserv/ocserv-9999.ebuild
index 9ff9e3fd75a7..52512265f732 100644
--- a/net-vpn/ocserv/ocserv-9999.ebuild
+++ b/net-vpn/ocserv/ocserv-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,6 +30,7 @@ BDEPEND+="
test? (
net-libs/gnutls[tools(+)]
net-libs/socket_wrapper
+ net-misc/ipcalc
net-vpn/openconnect
sys-libs/nss_wrapper
sys-libs/uid_wrapper
@@ -43,7 +44,6 @@ DEPEND="
dev-libs/pcl:0=
dev-libs/protobuf-c:0=
>=net-libs/gnutls-3.3.0:0=
- net-libs/http-parser:0=
sys-libs/readline:0=
sys-libs/talloc:0=
virtual/libcrypt:=
@@ -69,13 +69,13 @@ src_prepare() {
src_configure() {
local myconf=(
--without-root-tests
- --without-nuttcp-tests
$(use_enable seccomp)
$(use_enable systemd)
$(use_with geoip)
$(use_with kerberos gssapi)
+ --without-llhttp
$(use_with lz4)
$(use_with otp liboath)
$(use_with radius)
@@ -84,6 +84,11 @@ src_configure() {
econf "${myconf[@]}"
}
+src_test() {
+ addwrite /proc
+ default
+}
+
src_install() {
default