summaryrefslogtreecommitdiff
path: root/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild')
-rw-r--r--net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild b/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild
index fbf88104daa3..20f4fead01b5 100644
--- a/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild
+++ b/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{9..13} )
inherit cmake python-single-r1
@@ -38,18 +38,14 @@ BDEPEND="dev-lang/swig"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_prepare() {
- #although cppunit is not used, it fails if it isn't there, fix it
- sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
- sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
- sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
- sed -i '/GR_PKG_DOC_DIR/d' CMakeLists.txt
+ # fix path for doc files
+ sed -i "s/802_15_4 CXX/802154 CXX/" CMakeLists.txt || die
cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DPYTHON_EXECUTABLE="${PYTHON}"
- -DGR_PKG_DOC_DIR="/usr/share/doc/${P}"
)
cmake_src_configure
}