summaryrefslogtreecommitdiff
path: root/net-wireless/hostapd/hostapd-2.9-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/hostapd/hostapd-2.9-r3.ebuild')
-rw-r--r--net-wireless/hostapd/hostapd-2.9-r3.ebuild39
1 files changed, 18 insertions, 21 deletions
diff --git a/net-wireless/hostapd/hostapd-2.9-r3.ebuild b/net-wireless/hostapd/hostapd-2.9-r3.ebuild
index 7a63076e50a7..174b3dd6157a 100644
--- a/net-wireless/hostapd/hostapd-2.9-r3.ebuild
+++ b/net-wireless/hostapd/hostapd-2.9-r3.ebuild
@@ -28,30 +28,29 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="internal-tls ipv6 logwatch netlink sqlite +suiteb +wps +crda"
+IUSE="internal-tls ipv6 netlink sqlite +suiteb +wps +crda"
DEPEND="
- internal-tls? ( dev-libs/libtommath )
- !internal-tls? ( dev-libs/openssl:0=[-bindist] )
-
+ internal-tls? ( dev-libs/libtommath )
+ !internal-tls? ( dev-libs/openssl:0=[-bindist] )
kernel_linux? (
dev-libs/libnl:3
crda? ( net-wireless/crda )
)
netlink? ( net-libs/libnfnetlink )
sqlite? ( >=dev-db/sqlite-3 )"
-
RDEPEND="${DEPEND}"
pkg_pretend() {
if use internal-tls; then
- ewarn "internal-tls implementation is experimental and provides fewer features"
+ ewarn "internal-tls implementation is experimental and provides fewer features"
fi
}
src_unpack() {
# Override default one because we need the SRC_URI ones even in case of 9999 ebuilds
default
+
if [[ ${PV} == 9999 ]] ; then
git-r3_src_unpack
fi
@@ -63,12 +62,12 @@ src_prepare() {
pushd ../ >/dev/null || die
default
- # CVE-2019-16275 bug #696032
- eapply "${FILESDIR}/hostapd-2.9-AP-Silently-ignore-management-frame-from-unexpected.patch"
- # CVE-2020-12695 bug #727542
- eapply "${FILESDIR}/${P}-0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch"
- eapply "${FILESDIR}/${P}-0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch"
- eapply "${FILESDIR}/${P}-0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch"
+ # CVE-2019-16275 (bug #696032)
+ eapply "${FILESDIR}"/${P}-AP-Silently-ignore-management-frame-from-unexpected.patch
+ # CVE-2020-12695 (bug #727542)
+ eapply "${FILESDIR}"/${P}-0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch
+ eapply "${FILESDIR}"/${P}-0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch
+ eapply "${FILESDIR}"/${P}-0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch
popd >/dev/null || die
@@ -77,7 +76,7 @@ src_prepare() {
}
src_configure() {
- local CONFIG="${S}/.config"
+ local CONFIG="${S}"/.config
restore_config "${CONFIG}"
if [[ -f "${CONFIG}" ]]; then
@@ -233,20 +232,18 @@ src_install() {
docinto examples
dodoc wired.conf
- if use logwatch; then
- insinto /etc/log.d/conf/services/
- doins logwatch/${PN}.conf
+ insinto /etc/log.d/conf/services/
+ doins logwatch/${PN}.conf
- exeinto /etc/log.d/scripts/services/
- doexe logwatch/${PN}
- fi
+ exeinto /etc/log.d/scripts/services/
+ doexe logwatch/${PN}
save_config .config
}
pkg_postinst() {
einfo
- einfo "If you are running openRC you need to follow this instructions:"
+ einfo "If you are running OpenRC you need to follow this instructions:"
einfo "In order to use ${PN} you need to set up your wireless card"
einfo "for master mode in /etc/conf.d/net and then start"
einfo "/etc/init.d/${PN}."
@@ -267,7 +264,7 @@ pkg_postinst() {
if use wps; then
einfo "You have enabled Wi-Fi Protected Setup support, please"
- einfo "read the README-WPS file in /usr/share/doc/${P}"
+ einfo "read the README-WPS file in /usr/share/doc/${PF}"
einfo "for info on how to use WPS"
fi
}