summaryrefslogtreecommitdiff
path: root/net-wireless/kismet/files/fix-setuptools.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/kismet/files/fix-setuptools.patch')
-rw-r--r--net-wireless/kismet/files/fix-setuptools.patch73
1 files changed, 0 insertions, 73 deletions
diff --git a/net-wireless/kismet/files/fix-setuptools.patch b/net-wireless/kismet/files/fix-setuptools.patch
deleted file mode 100644
index a86f66b4447c..000000000000
--- a/net-wireless/kismet/files/fix-setuptools.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-commit e31263b50acd960f7bb0c34c0396383319d7da30
-Author: Rick Farina (Zero_Chaos) <zerochaos@gentoo.org>
-Date: Tue Apr 24 11:38:17 2018 -0400
-
- make setuptools respect DESTDIR
-
- thanks to mgorny for pointint it out
-
-diff --git a/capture_freaklabs_zigbee/Makefile.in b/capture_freaklabs_zigbee/Makefile.in
-index 75c85da9..980c417a 100644
---- a/capture_freaklabs_zigbee/Makefile.in
-+++ b/capture_freaklabs_zigbee/Makefile.in
-@@ -6,7 +6,7 @@ all:
- $(PYTHON2) ./setup.py build
-
- install:
-- $(PYTHON2) ./setup.py install
-+ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
- $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
-
- clean:
-diff --git a/capture_sdr_rtl433/Makefile.in b/capture_sdr_rtl433/Makefile.in
-index 23446edc..babc63f4 100644
---- a/capture_sdr_rtl433/Makefile.in
-+++ b/capture_sdr_rtl433/Makefile.in
-@@ -7,7 +7,7 @@ all:
- $(PYTHON2) ./setup.py build
-
- install:
-- $(PYTHON2) ./setup.py install
-+ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
- $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
- $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MQTTMONITOR_BIN) $(BIN)/$(MQTTMONITOR_BIN)
-
-diff --git a/python_modules/KismetExternal/Makefile b/python_modules/KismetExternal/Makefile
-index 036541a0..fc660dfe 100644
---- a/python_modules/KismetExternal/Makefile
-+++ b/python_modules/KismetExternal/Makefile
-@@ -4,7 +4,7 @@ all:
- $(PYTHON2) ./setup.py build
-
- install:
-- $(PYTHON2) ./setup.py install
-+ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
-
- protobuf:
- $(PROTOCBIN) -I ../../protobuf_definitions --python_out=./KismetExternal ../../protobuf_definitions/*.proto
-diff --git a/python_modules/KismetLog/Makefile b/python_modules/KismetLog/Makefile
-index d0d6f784..60e1eac1 100644
---- a/python_modules/KismetLog/Makefile
-+++ b/python_modules/KismetLog/Makefile
-@@ -4,7 +4,7 @@ all:
- $(PYTHON2) ./setup.py build
-
- install:
-- $(PYTHON2) ./setup.py install
-+ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
-
- clean:
- @-$(PYTHON2) ./setup.py clean
-diff --git a/python_modules/KismetRest/Makefile b/python_modules/KismetRest/Makefile
-index d0d6f784..60e1eac1 100644
---- a/python_modules/KismetRest/Makefile
-+++ b/python_modules/KismetRest/Makefile
-@@ -4,7 +4,7 @@ all:
- $(PYTHON2) ./setup.py build
-
- install:
-- $(PYTHON2) ./setup.py install
-+ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
-
- clean:
- @-$(PYTHON2) ./setup.py clean