summaryrefslogtreecommitdiff
path: root/net-wireless/lorcon/lorcon-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/lorcon/lorcon-9999.ebuild')
-rw-r--r--net-wireless/lorcon/lorcon-9999.ebuild21
1 files changed, 6 insertions, 15 deletions
diff --git a/net-wireless/lorcon/lorcon-9999.ebuild b/net-wireless/lorcon/lorcon-9999.ebuild
index d9ac3ecfbee9..7e81f8596710 100644
--- a/net-wireless/lorcon/lorcon-9999.ebuild
+++ b/net-wireless/lorcon/lorcon-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6,7,8})
DISTUTILS_OPTIONAL=1
inherit distutils-r1
@@ -15,10 +15,9 @@ if [[ ${PV} == "9999" ]] ; then
#EGIT_REPO_URI="https://www.kismetwireless.net/lorcon.git"
EGIT_REPO_URI="https://github.com/kismetwireless/lorcon.git"
inherit git-r3
- KEYWORDS=""
S="${WORKDIR}"/${P}
else
- GIT_HASH="d8637792f2e857f31849f29759c1022eb0518c83"
+ GIT_HASH="7dbf24ee6f7c277240c0fbd988b6902850577772"
SRC_URI="https://github.com/kismetwireless/lorcon/archive/${GIT_HASH}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/"${PN}-${GIT_HASH}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
@@ -35,6 +34,7 @@ DEPEND="
RDEPEND="${DEPEND}"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test"
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
@@ -45,12 +45,6 @@ src_unpack() {
}
src_prepare() {
- sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.c
- sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.h
- sed -i 's#<lorcon2/lorcon_packet.h>#"../lorcon_packet.h"#' pylorcon2/PyLorcon2.c
- sed -i 's#<lorcon2/lorcon_packet.h>#"../lorcon_packet.h"#' pylorcon2/PyLorcon2.h
- sed -i 's#<lorcon2/lorcon_multi.h>#"../lorcon_multi.h"#' pylorcon2/PyLorcon2.c
- sed -i 's#<lorcon2/lorcon_multi.h>#"../lorcon_multi.h"#' pylorcon2/PyLorcon2.h
default
use python && distutils-r1_src_prepare
}
@@ -74,8 +68,5 @@ src_install() {
cd pylorcon2 || die
distutils-r1_src_install
fi
-}
-
-src_test() {
- :
+ find "${D}" -xtype f -name '*.la' -delete || die
}