summaryrefslogtreecommitdiff
path: root/net-wireless/soapyhackrf
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/soapyhackrf')
-rw-r--r--net-wireless/soapyhackrf/Manifest4
-rw-r--r--net-wireless/soapyhackrf/metadata.xml15
-rw-r--r--net-wireless/soapyhackrf/soapyhackrf-0.3.2.ebuild26
-rw-r--r--net-wireless/soapyhackrf/soapyhackrf-9999.ebuild26
4 files changed, 71 insertions, 0 deletions
diff --git a/net-wireless/soapyhackrf/Manifest b/net-wireless/soapyhackrf/Manifest
new file mode 100644
index 000000000000..11e1d1158374
--- /dev/null
+++ b/net-wireless/soapyhackrf/Manifest
@@ -0,0 +1,4 @@
+DIST soapyhackrf-0.3.2.tar.gz 15643 BLAKE2B e57a0e2bc50984434f0e97207f8b274cc08d84e5884f4bee523614adb07d10cee810f1dd43d771f8b3a97bdb0dd84a0ac6b34d840aa9c93df19f7777f658d8d4 SHA512 667f27491d5fe18a04670ff0ade32b4a6f696ba8718e211957c7f8bab64957023ee4905df22214524ae3796a350a725d4f192fde21bb3d60cb9e69a4e629df90
+EBUILD soapyhackrf-0.3.2.ebuild 633 BLAKE2B c0149f8cb1f577f83b31821265a3356219f4b3b9b1609f01b0fdabd87d3f973af4fd32f79c3a5c27bbebe6e6018e17ffd3e6d747261f84d20d54f18d0aabaa04 SHA512 6d676eaa271fbf6376a7a4a818ab73a130668224124ad85bcfb3bcac6108d5cb94bb4acaa02715f230b7b9bab564561e88421ccf54b34db528c06d51c2e95901
+EBUILD soapyhackrf-9999.ebuild 633 BLAKE2B c0149f8cb1f577f83b31821265a3356219f4b3b9b1609f01b0fdabd87d3f973af4fd32f79c3a5c27bbebe6e6018e17ffd3e6d747261f84d20d54f18d0aabaa04 SHA512 6d676eaa271fbf6376a7a4a818ab73a130668224124ad85bcfb3bcac6108d5cb94bb4acaa02715f230b7b9bab564561e88421ccf54b34db528c06d51c2e95901
+MISC metadata.xml 433 BLAKE2B b7864a9b9321c5cf86ad577d28555f00e4fd49ac6fada7c22a4e204fb38508e3f3e4cd3020940b8cae33b0aa14338e3c96b044bd56804d181d018f5c31be82bd SHA512 6ca16459623f460a4d9b6b101aa96e1092ee29ccdb9098780b236596608505886d047d0207ea65a2415fe7096f595c2a9c3161bbcc1131ac0977b8d0f66011cf
diff --git a/net-wireless/soapyhackrf/metadata.xml b/net-wireless/soapyhackrf/metadata.xml
new file mode 100644
index 000000000000..2633b05296ff
--- /dev/null
+++ b/net-wireless/soapyhackrf/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>radio@gentoo.org</email>
+ <name>Radio</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pothosware/SoapyHackRF</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-wireless/soapyhackrf/soapyhackrf-0.3.2.ebuild b/net-wireless/soapyhackrf/soapyhackrf-0.3.2.ebuild
new file mode 100644
index 000000000000..b5dece6d6651
--- /dev/null
+++ b/net-wireless/soapyhackrf/soapyhackrf-0.3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="SoapySDR HackRF module"
+HOMEPAGE="https://github.com/pothosware/SoapyHackRF"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyHackRF.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyHackRF/archive/soapy-hackrf-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyHackRF-soapy-hackrf-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr
+ net-libs/libhackrf:="
+DEPEND="${RDEPEND}"
diff --git a/net-wireless/soapyhackrf/soapyhackrf-9999.ebuild b/net-wireless/soapyhackrf/soapyhackrf-9999.ebuild
new file mode 100644
index 000000000000..b5dece6d6651
--- /dev/null
+++ b/net-wireless/soapyhackrf/soapyhackrf-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="SoapySDR HackRF module"
+HOMEPAGE="https://github.com/pothosware/SoapyHackRF"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyHackRF.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyHackRF/archive/soapy-hackrf-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyHackRF-soapy-hackrf-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr
+ net-libs/libhackrf:="
+DEPEND="${RDEPEND}"