summaryrefslogtreecommitdiff
path: root/net-wireless/soapyuhd
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/soapyuhd')
-rw-r--r--net-wireless/soapyuhd/Manifest4
-rw-r--r--net-wireless/soapyuhd/files/soapyuhd-0.4.1-uhd-4.8.patch43
-rw-r--r--net-wireless/soapyuhd/soapyuhd-0.4.1-r1.ebuild28
-rw-r--r--net-wireless/soapyuhd/soapyuhd-9999.ebuild8
4 files changed, 79 insertions, 4 deletions
diff --git a/net-wireless/soapyuhd/Manifest b/net-wireless/soapyuhd/Manifest
index d31127e044d8..535bb6b5791e 100644
--- a/net-wireless/soapyuhd/Manifest
+++ b/net-wireless/soapyuhd/Manifest
@@ -1,4 +1,6 @@
+AUX soapyuhd-0.4.1-uhd-4.8.patch 1390 BLAKE2B b12cc53ac695ade10e42245116e4ab37d0550b34495b2596fcc9df19deb01956ecd27b6dd99eaf2eff9fa6f7dea3c110d935f5e9700307b99d82cce976fcaa6e SHA512 6de4de6b4c0735a41a3426c7e78b6e850e5cb99860699e259ba83ec24877bbe7b55f87022b4ff721ff149119584c323809d680f86603ac7299d6c29c9e3fd67a
DIST soapyuhd-0.4.1.tar.gz 33838 BLAKE2B ee5639fda7213a7e3273c6bd27366a9d9f0e7d561655d316c19f055a008f31ed4362df945823bc3b5c159362ace9a7cc9fa7f943d2d128ba2b37047a71677352 SHA512 7a78ac386d92e4b36b36710f5943623ec8742cb770df69ac0c9bbd26827567277cb3309e3ad6eb0148b1b76083f16fdd188619700d38dcc5eab362b6db65340f
+EBUILD soapyuhd-0.4.1-r1.ebuild 722 BLAKE2B 1e146502cf049ad102afcf38e4b25d61fd55630df507826817419c5842d3112a9dc9fcb83cf6ec4ec2db49593321cfb6fba0b3c3ff9cf446fcb3085d6150dc07 SHA512 3f39d5317d7306069a7818f817159067790390d4ce2e1f666a3bc9fd897a49928b616b9dd1d3c9b1debb6e5cb3c95c3ea235c7f037e8cb4071d22e2e78522e8f
EBUILD soapyuhd-0.4.1.ebuild 648 BLAKE2B abfad5e4f47e3336fce09f17a748cbcb384a1551fad7e0b0b4ce6c1989f3f26a76af015ef4d1af9733163f730e29d4ea831fd1a94cb9d0244874a9990c512d65 SHA512 8133e132499059ed4492989553a8bde6b5261055176c42ac3a59ab929c5a2de7c964cbc7dfc218e855b8486bb395e0ac2a28bf119db006f02aab28fd7d0fba15
-EBUILD soapyuhd-9999.ebuild 637 BLAKE2B eaeddb5bd24f659dee39a1699f8828e7b2a578308b6c02b544b9809f8ff4924b29f215c551469301d1ee69b379fbf1a954a5809ff50e7b1613c0f977e0dac0ea SHA512 6a725dcbbe5445cbb38ebcd4ac0fc50975f379f5dcbbd6cacc9be5b130904d683f852140d78460bc1abd04fdde6bd7572c51f9f8dbef23f5239580d0019d9a0d
+EBUILD soapyuhd-9999.ebuild 722 BLAKE2B 1e146502cf049ad102afcf38e4b25d61fd55630df507826817419c5842d3112a9dc9fcb83cf6ec4ec2db49593321cfb6fba0b3c3ff9cf446fcb3085d6150dc07 SHA512 3f39d5317d7306069a7818f817159067790390d4ce2e1f666a3bc9fd897a49928b616b9dd1d3c9b1debb6e5cb3c95c3ea235c7f037e8cb4071d22e2e78522e8f
MISC metadata.xml 431 BLAKE2B 12571909a1964cdf9083b47c2fd60bc267515a2fb684b472c0d5d2a701ed2c1a204308f2ed2195e274442f1c979e9020a42ee7ebc573746bccee26c884fa0c67 SHA512 59b5211d71b99fa00edeb9deb38cad6c285e28f940422abd90022dfb334b7372312273fa6f53d47b4ed9e4da511505fbb8d5fe32f8c67add9689495b826b61ed
diff --git a/net-wireless/soapyuhd/files/soapyuhd-0.4.1-uhd-4.8.patch b/net-wireless/soapyuhd/files/soapyuhd-0.4.1-uhd-4.8.patch
new file mode 100644
index 000000000000..94356817204b
--- /dev/null
+++ b/net-wireless/soapyuhd/files/soapyuhd-0.4.1-uhd-4.8.patch
@@ -0,0 +1,43 @@
+From 6eeee4fd3217166199068bbe05c555c2bccb2a7b Mon Sep 17 00:00:00 2001
+From: Ryan Volz <ryan.volz@gmail.com>
+Date: Fri, 7 Feb 2025 11:09:35 -0500
+Subject: [PATCH] Define post_input_action/post_output_action for UHD 4.8+
+
+---
+ UHDSoapyDevice.cpp | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+
+diff --git a/UHDSoapyDevice.cpp b/UHDSoapyDevice.cpp
+index 3ce66f3..88641c5 100644
+--- a/UHDSoapyDevice.cpp
++++ b/UHDSoapyDevice.cpp
+@@ -707,6 +707,14 @@ class UHDSoapyRxStream : public uhd::rx_streamer
+ if (ret != 0) throw std::runtime_error(str(boost::format("UHDSoapyRxStream::issue_stream_cmd() = %d") % ret));
+ }
+
++ #if UHD_VERSION >= 4080000
++ void post_input_action(
++ const std::shared_ptr<uhd::rfnoc::action_info>&, const size_t) override
++ {
++ throw uhd::not_implemented_error("post_input_action is not implemented here!");
++ }
++ #endif
++
+ private:
+ SoapySDR::Device *_device;
+ SoapySDR::Stream *_stream;
+@@ -851,6 +859,14 @@ class UHDSoapyTxStream : public uhd::tx_streamer
+ return true;
+ }
+
++ #if UHD_VERSION >= 4080000
++ void post_output_action(
++ const std::shared_ptr<uhd::rfnoc::action_info>&, const size_t) override
++ {
++ throw uhd::not_implemented_error("post_output_action is not implemented here!");
++ }
++ #endif
++
+ private:
+ bool _active;
+ SoapySDR::Device *_device;
diff --git a/net-wireless/soapyuhd/soapyuhd-0.4.1-r1.ebuild b/net-wireless/soapyuhd/soapyuhd-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..32a1a57cf8c5
--- /dev/null
+++ b/net-wireless/soapyuhd/soapyuhd-0.4.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Soapy SDR plugins for UHD supported SDR devices"
+HOMEPAGE="https://github.com/pothosware/SoapyUHD"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyUHD.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyUHD/archive/soapy-uhd-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyUHD-soapy-uhd-"${PV}"
+ # picked up from git repo
+ PATCHES=( "${FILESDIR}"/${P}-uhd-4.8.patch )
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr:=
+ net-wireless/uhd:=
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"
diff --git a/net-wireless/soapyuhd/soapyuhd-9999.ebuild b/net-wireless/soapyuhd/soapyuhd-9999.ebuild
index dba31a72d677..32a1a57cf8c5 100644
--- a/net-wireless/soapyuhd/soapyuhd-9999.ebuild
+++ b/net-wireless/soapyuhd/soapyuhd-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
@@ -12,9 +12,11 @@ if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/pothosware/SoapyUHD.git"
inherit git-r3
else
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
SRC_URI="https://github.com/pothosware/SoapyUHD/archive/soapy-uhd-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/SoapyUHD-soapy-uhd-"${PV}"
+ # picked up from git repo
+ PATCHES=( "${FILESDIR}"/${P}-uhd-4.8.patch )
fi
LICENSE="MIT"