summaryrefslogtreecommitdiff
path: root/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild')
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild32
1 files changed, 22 insertions, 10 deletions
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
index f73f675d9fde..3cb7b352a50f 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils qmake-utils systemd toolchain-funcs readme.gentoo-r1
+inherit eutils qmake-utils systemd toolchain-funcs readme.gentoo-r1 desktop
DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
HOMEPAGE="https://w1.fi/wpa_supplicant/"
@@ -18,7 +18,7 @@ else
fi
SLOT="0"
-IUSE="ap bindist dbus eap-sim eapol_test fasteap +fils +hs2-0 libressl macsec p2p privsep ps3 qt5 readline selinux smartcard tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
+IUSE="ap bindist broadcom-sta dbus eap-sim eapol-test fasteap +fils +hs2-0 libressl macsec +mbo +mesh p2p privsep ps3 qt5 readline selinux smartcard tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
# CONFIG_PRIVSEP=y does not have sufficient support for the new driver
# interface functions used for MACsec, so this combination cannot be used
@@ -26,6 +26,7 @@ IUSE="ap bindist dbus eap-sim eapol_test fasteap +fils +hs2-0 libressl macsec p2
REQUIRED_USE="
macsec? ( !privsep )
privsep? ( !macsec )
+ broadcom-sta? ( !fils !mesh !mbo )
"
CDEPEND="dbus? ( sys-apps/dbus )
@@ -147,7 +148,6 @@ src_configure() {
Kconfig_style_config TLSV11
Kconfig_style_config TLSV12
Kconfig_style_config GETRANDOM
- Kconfig_style_config MBO
# Basic authentication methods
# NOTE: we don't set GPSK or SAKE as they conflict
@@ -183,7 +183,7 @@ src_configure() {
Kconfig_style_config CTRL_IFACE_DBUS_INTRO n
fi
- if use eapol_test ; then
+ if use eapol-test ; then
Kconfig_style_config EAPOL_TEST
fi
@@ -196,6 +196,12 @@ src_configure() {
Kconfig_style_config HS20
fi
+ if use mbo ; then
+ Kconfig_style_config MBO
+ else
+ Kconfig_style_config MBO n
+ fi
+
if use uncommon-eap-types; then
Kconfig_style_config EAP_GPSK
Kconfig_style_config EAP_SAKE
@@ -232,8 +238,11 @@ src_configure() {
Kconfig_style_config FILS
Kconfig_style_config FILS_SK_PFS
fi
- # Enabling mesh networks.
- Kconfig_style_config MESH
+ if use mesh; then
+ Kconfig_style_config MESH
+ else
+ Kconfig_style_config MESH n
+ fi
#WPA3
Kconfig_style_config OWE
Kconfig_style_config SAE
@@ -303,6 +312,9 @@ src_configure() {
if use p2p ; then
Kconfig_style_config P2P
Kconfig_style_config WIFI_DISPLAY
+ else
+ Kconfig_style_config P2P n
+ Kconfig_style_config WIFI_DISPLAY n
fi
# Access Point Mode
@@ -357,7 +369,7 @@ src_compile() {
emake -C "${S}"/wpa_gui-qt4
fi
- if use eapol_test ; then
+ if use eapol-test ; then
emake eapol_test
fi
}
@@ -397,7 +409,7 @@ src_install() {
into /usr
dobin wpa_gui-qt4/wpa_gui
doicon wpa_gui-qt4/icons/wpa_gui.svg
- make_desktop_entry wpa_gui "WPA Supplicant Administration GUI" "wpa_gui" "Qt;Network;"
+ domenu wpa_gui-qt4/wpa_gui.desktop
else
rm "${ED}"/usr/share/man/man8/wpa_gui.8
fi
@@ -416,7 +428,7 @@ src_install() {
systemd_dounit systemd/wpa_supplicant.service
fi
- if use eapol_test ; then
+ if use eapol-test ; then
dobin eapol_test
fi